]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- applied kde-general-am18 patch
[packages/arts.git] / arts.spec
1 #
2 # TODO: consider:
3 # - separating artsc and its -devel? (but what are artsc deps?)
4 #
5 # Conditional build:
6 %bcond_without  alsa    # disable ALSA support
7 %bcond_with     nas     # enable NAS support
8 #
9
10 %define         _state          snapshots
11 %define         _ver            1.2.0
12 %define         _snap           031204
13
14 Summary:        aRts sound server
15 Summary(pl):    Serwer d¼wiêku
16 Summary(pt_BR): Servidor de sons usado pelo KDE
17 Name:           arts
18 Version:        %{_ver}.%{_snap}
19 Release:        2
20 Epoch:          12
21 License:        LGPL
22 Group:          Libraries
23 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
24 Source0:        http://www.kernel.pl/~adgor/kde/%{name}-%{_snap}.tar.bz2
25 # Source0-md5:  ed23773940e2b97e31a6850e2334bfe5
26 Patch0:         kde-general-am18.patch
27 URL:            http://www.kde.org/
28 %{?with_alsa:BuildRequires:     alsa-lib-devel}
29 BuildRequires:  audiofile-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  docbook-dtd41-sgml
33 BuildRequires:  docbook-utils
34 BuildRequires:  esound-devel
35 BuildRequires:  glib2-devel >= 2.0.0
36 BuildRequires:  libmad-devel
37 BuildRequires:  libtool >= 2:1.5-2
38 BuildRequires:  libvorbis-devel
39 %{?with_nas:BuildRequires:      nas-devel}
40 BuildRequires:  pkgconfig
41 BuildRequires:  qt-devel >= 6:3.2.1-4
42 BuildRequires:  perl-SGMLS
43 Obsoletes:      arts-glib
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 aRts sound server.
48
49 %description -l pl
50 Serwer d¼wiêku aRts.
51
52 %description -l pt_BR
53 O aRts é um sintetizador analógico em tempo real que é completamente
54 modular. Você pode criar sons e músicas (síntese em tempo real de
55 midi) usando pequenos módulos como oscilador para criar waveforms,
56 vários filtros, mixers, faders, etc. Você pode configurar tudo através
57 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
58 design foi escolhido para permitir que outras aplicações usem o aRts
59 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
60 outros.
61
62 %package devel
63 Summary:        Sound server - header files
64 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
65 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
66 Group:          Development/Libraries
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68 # not necessary for all libs (e.g. mcop), but propagated by artsflow
69 %{?with_alsa:Requires:  alsa-lib-devel}
70 Requires:       audiofile-devel
71 Requires:       esound-devel
72 Requires:       glib2-devel >= 2.0.0
73 Requires:       libmad-devel
74 Requires:       libvorbis-devel
75 %{?with_nas:Requires:   nas-devel}
76
77 %description devel
78 Header files required to compile programs using arts.
79
80 %description devel -l pl
81 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
82 arts.
83
84 %description devel -l pt_BR
85 Arquivos para desenvolvimento com o o aRts.
86
87 # separate from arts-devel because they are mostly independent and have very
88 # different deps
89 # there is no artsc base - it would be small and would require arts - so there
90 # is no reason to separate
91 %package -n artsc-devel
92 Summary:        Development files for artsc libraries
93 Summary(pl):    Pliki programistyczne bibliotek artsc
94 Group:          Development/Libraries
95 Requires:       %{name} = %{epoch}:%{version}-%{release}
96 Requires:       glib2-devel >= 2.0.0
97 Conflicts:      arts-devel < 12:1.2.0.031126-2
98
99 %description -n artsc-devel
100 Development files for artsc libraries (C interface to aRts sound
101 system).
102
103 %description -n artsc-devel -l pl
104 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
105 d¼wiêku aRts).
106
107 %package X11
108 Summary:        X11 dependent part of aRts
109 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
110 Group:          X11/Libraries
111 Requires:       %{name} = %{epoch}:%{version}-%{release}
112
113 %description X11
114 X11 dependent part of aRts (x11globalcomm module).
115
116 %description X11 -l pl
117 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
118
119 %package qt
120 Summary:        QT dependend part of aRts
121 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
122 Group:          X11/Libraries
123 Requires:       %{name} = %{epoch}:%{version}-%{release}
124 Requires:       qt >= 6:3.2.1-4
125
126 %description qt
127 QT dependend part of aRts (qtmcop library).
128
129 %description qt -l pl
130 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
131
132 %package qt-devel
133 Summary:        Development files for qtmcop library
134 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
135 Group:          X11/Development/Libraries
136 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
137 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
138 Requires:       qt-devel >= 6:3.2.1-4
139
140 %description qt-devel
141 Development files for qtmcop library.
142
143 %description qt-devel -l pl
144 Pliki programistyczne dla biblioteki qtmcop.
145
146 %prep
147 %setup -q -n %{name}-%{_snap}
148 %patch0 -p1
149
150 %build
151 %{__make} -f admin/Makefile.common cvs
152
153 %configure \
154         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
155         --%{?debug:en}%{!?debug:dis}able-debug \
156         --disable-rpath \
157         --enable-final \
158         --with%{!?with_alsa:out}-alsa
159
160 %{__make}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 # Debian manpages
169 install -d $RPM_BUILD_ROOT%{_mandir}/man1
170 cd debian
171 for f in *.sgml ; do
172         base="$(basename $f .sgml)"
173         upper="$(echo ${base} | tr a-z A-Z)"
174         db2man $f
175         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
176 done
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %post   X11 -p /sbin/ldconfig
185 %postun X11 -p /sbin/ldconfig
186
187 %post   qt -p /sbin/ldconfig
188 %postun qt -p /sbin/ldconfig
189
190 %files
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/artscat
193 %attr(755,root,root) %{_bindir}/artsd
194 %attr(755,root,root) %{_bindir}/artsdsp
195 %attr(755,root,root) %{_bindir}/artsplay
196 %attr(755,root,root) %{_bindir}/artsrec
197 %attr(755,root,root) %{_bindir}/artsshell
198 %attr(755,root,root) %{_bindir}/artswrapper
199 # shared libraries
200 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
208 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
209 # lt_dlopened modules (*.la needed)
210 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
211 %{_libdir}/libartscbackend.la
212 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
213 %{_libdir}/libartsdsp.la
214 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
215 %{_libdir}/libartsdsp_st.la
216 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
217 %{_libdir}/libartsgslplayobject.la
218 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
219 %{_libdir}/libartswavplayobject.la
220 #
221 %{_libdir}/mcop
222 %{_mandir}/man1/artscat.1*
223 %{_mandir}/man1/artsd.1*
224 %{_mandir}/man1/artsdsp.1*
225 %{_mandir}/man1/artsplay.1*
226 %{_mandir}/man1/artsrec.1*
227 %{_mandir}/man1/artsshell.1*
228 %{_mandir}/man1/artswrapper.1*
229
230 %files devel
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_bindir}/mcopidl
233 %attr(755,root,root) %{_libdir}/libartsflow.so
234 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
235 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
236 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
237 %attr(755,root,root) %{_libdir}/libgmcop.so
238 %attr(755,root,root) %{_libdir}/libkmedia2.so
239 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
240 %attr(755,root,root) %{_libdir}/libmcop.so
241 %attr(755,root,root) %{_libdir}/libmcop_mt.so
242 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
243 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
244 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
245 # shared libraries
246 %{_libdir}/libartsflow.la
247 %{_libdir}/libartsflow_idl.la
248 %{_libdir}/libgmcop.la
249 %{_libdir}/libkmedia2.la
250 %{_libdir}/libkmedia2_idl.la
251 %{_libdir}/libmcop.la
252 %{_libdir}/libmcop_mt.la
253 %{_libdir}/libsoundserver_idl.la
254 #
255 %{_includedir}/arts
256 %exclude %{_includedir}/arts/qiomanager.h
257 %{_mandir}/man1/mcopidl.1*
258
259 %files -n artsc-devel
260 %defattr(644,root,root,755)
261 %attr(755,root,root) %{_bindir}/artsc-config
262 %attr(755,root,root) %{_libdir}/libartsc.so
263 %attr(755,root,root) %{_libdir}/libartscbackend.so
264 %attr(755,root,root) %{_libdir}/libartsdsp.so
265 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
266 %{_libdir}/libartsc.la
267 %{_includedir}/artsc
268 %{_mandir}/man1/artsc-config.1*
269
270 %files X11
271 %defattr(644,root,root,755)
272 # lt_dlopened module (.la needed)
273 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
274 %{_libdir}/libx11globalcomm.la
275
276 %files qt
277 %defattr(644,root,root,755)
278 # shared library
279 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
280
281 %files qt-devel
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_libdir}/libqtmcop.so
284 %{_libdir}/libqtmcop.la
285 %{_includedir}/arts/qiomanager.h
This page took 0.147058 seconds and 4 git commands to generate.