]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
f51b2727cf0a20b2533bf3f200d4a0d4886f6333
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7
8 %define         _state          stable
9 %define         _kdever         3.3
10 %define         _ver            1.3.1
11
12 Summary:        aRts sound server
13 Summary(pl):    Serwer d¼wiêku
14 Summary(pt_BR): Servidor de sons usado pelo KDE
15 Name:           arts
16 Version:        %{_ver}
17 Release:        0.1
18 Epoch:          13
19 License:        LGPL
20 Group:          Libraries
21 #Source0:       http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
22 #Source0:       http://ftp.man.szczecin.pl/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
23 Source0:        http://ftp.pld-linux.org/software/kde/%{name}-%{_ver}.tar.bz2
24 # Source0-md5:  26554e4c47d9a52bc20a07e39d32a731
25 URL:            http://www.arts-project.org/
26 %{?with_alsa:BuildRequires:     alsa-lib-devel}
27 BuildRequires:  audiofile-devel
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  docbook-dtd41-sgml
31 BuildRequires:  docbook-utils >= 0.6.13-3
32 %{?with_esd:BuildRequires:      esound-devel}
33 BuildRequires:  glib2-devel >= 2.0.0
34 BuildRequires:  jack-audio-connection-kit-devel
35 BuildRequires:  libmad-devel
36 BuildRequires:  libtool >= 2:1.5-2
37 BuildRequires:  libvorbis-devel
38 %{?with_nas:BuildRequires:      nas-devel}
39 BuildRequires:  pkgconfig
40 BuildRequires:  qt-devel >= 6:3.2.1-4
41 BuildRequires:  unsermake >= 040805-1
42 Obsoletes:      arts-glib
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The Analog Real-Time Synthesizer, or aRts, is a modular system for
47 synthesizing sound and music on a digital computer. Using small
48 building blocks called modules, the user can easily build complex
49 audio processing tools. Modules typically provide functions such as
50 sound waveform generators, filters, audio effects, mixing, and
51 playback of digital audio in different file formats. The artsd sound
52 server mixes audio from several sources in real time, allowing
53 multiple sound applications to transparently share access to sound
54 hardware.
55
56 %description -l pl
57 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
58 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
59 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
60 d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
61 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
62 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
63 odtwarzanie d¼wiêku z wielu ¼róde³.
64
65 %description -l pt_BR
66 O aRts é um sintetizador analógico em tempo real que é completamente
67 modular. Você pode criar sons e músicas (síntese em tempo real de
68 midi) usando pequenos módulos como oscilador para criar waveforms,
69 vários filtros, mixers, faders, etc. Você pode configurar tudo através
70 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
71 design foi escolhido para permitir que outras aplicações usem o aRts
72 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
73 outros.
74
75 %package devel
76 Summary:        Sound server - header files
77 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
78 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
79 Group:          Development/Libraries
80 Requires:       %{name} = %{epoch}:%{version}-%{release}
81 # not necessary for all libs (e.g. mcop), but propagated by artsflow
82 %{?with_alsa:Requires:  alsa-lib-devel}
83 Requires:       audiofile-devel
84 Requires:       esound-devel
85 Requires:       glib2-devel >= 2.0.0
86 Requires:       jack-audio-connection-kit-devel
87 Requires:       libmad-devel
88 Requires:       libvorbis-devel
89 %{?with_nas:Requires:   nas-devel}
90
91 %description devel
92 Header files required to compile programs using arts.
93
94 %description devel -l pl
95 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
96 arts.
97
98 %description devel -l pt_BR
99 Arquivos para desenvolvimento com o o aRts.
100
101 # separate from arts-devel because they are mostly independent and have very
102 # different deps
103 # there is no artsc base - it would be small and would require arts - so
104 # there is no reason to separate
105 %package -n artsc-devel
106 Summary:        Development files for artsc libraries
107 Summary(pl):    Pliki programistyczne bibliotek artsc
108 Group:          Development/Libraries
109 Requires:       %{name} = %{epoch}:%{version}-%{release}
110 Requires:       glib2-devel >= 2.0.0
111 Conflicts:      arts-devel < 12:1.2.0.031126-2
112
113 %description -n artsc-devel
114 Development files for artsc libraries (C interface to aRts sound
115 system).
116
117 %description -n artsc-devel -l pl
118 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
119 d¼wiêku aRts).
120
121 %package X11
122 Summary:        X11 dependent part of aRts
123 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
124 Group:          X11/Libraries
125 Requires:       %{name} = %{epoch}:%{version}-%{release}
126
127 %description X11
128 X11 dependent part of aRts (x11globalcomm module).
129
130 %description X11 -l pl
131 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
132
133 %package qt
134 Summary:        QT dependend part of aRts
135 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
136 Group:          X11/Libraries
137 Requires:       %{name} = %{epoch}:%{version}-%{release}
138 Requires:       qt >= 6:3.2.1-4
139
140 %description qt
141 QT dependend part of aRts (qtmcop library).
142
143 %description qt -l pl
144 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
145
146 %package qt-devel
147 Summary:        Development files for qtmcop library
148 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
149 Group:          X11/Development/Libraries
150 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
151 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
152 Requires:       qt-devel >= 6:3.2.1-4
153
154 %description qt-devel
155 Development files for qtmcop library.
156
157 %description qt-devel -l pl
158 Pliki programistyczne dla biblioteki qtmcop.
159
160 %prep
161 %setup -q
162
163 %build
164 cp -f /usr/share/automake/config.sub admin
165
166 export UNSERMAKE=/usr/share/unsermake/unsermake
167
168 %{__make} -f admin/Makefile.common cvs
169
170 %configure \
171         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
172         --%{?debug:en}%{!?debug:dis}able-debug \
173         --disable-rpath \
174         --enable-final \
175         --with-qt-libraries=%{_libdir} \
176         --with%{!?with_alsa:out}-alsa
177
178 %{__make}
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} install \
184         DESTDIR=$RPM_BUILD_ROOT
185
186 # Debian manpages
187 install -d $RPM_BUILD_ROOT%{_mandir}/man1
188 cd debian/man
189 for f in *.sgml ; do
190         base="$(basename $f .sgml)"
191         upper="$(echo ${base} | tr a-z A-Z)"
192         db2man $f
193         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
194 done
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post   -p /sbin/ldconfig
200 %postun -p /sbin/ldconfig
201
202 %post   X11 -p /sbin/ldconfig
203 %postun X11 -p /sbin/ldconfig
204
205 %post   qt -p /sbin/ldconfig
206 %postun qt -p /sbin/ldconfig
207
208 %files
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/artscat
211 %attr(755,root,root) %{_bindir}/artsd
212 %attr(755,root,root) %{_bindir}/artsdsp
213 %attr(755,root,root) %{_bindir}/artsplay
214 %attr(755,root,root) %{_bindir}/artsrec
215 %attr(755,root,root) %{_bindir}/artsshell
216 %attr(755,root,root) %{_bindir}/artswrapper
217 # shared libraries
218 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
227 # lt_dlopened modules (*.la needed)
228 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
229 %{_libdir}/libartscbackend.la
230 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
231 %{_libdir}/libartsdsp.la
232 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
233 %{_libdir}/libartsdsp_st.la
234 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
235 %{_libdir}/libartsgslplayobject.la
236 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
237 %{_libdir}/libartswavplayobject.la
238 #
239 %{_libdir}/mcop
240 %{_mandir}/man1/artscat.1*
241 %{_mandir}/man1/artsd.1*
242 %{_mandir}/man1/artsdsp.1*
243 %{_mandir}/man1/artsplay.1*
244 %{_mandir}/man1/artsrec.1*
245 %{_mandir}/man1/artsshell.1*
246 %{_mandir}/man1/artswrapper.1*
247
248 %files devel
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_bindir}/mcopidl
251 %attr(755,root,root) %{_libdir}/libartsflow.so
252 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
253 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
254 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
255 %attr(755,root,root) %{_libdir}/libgmcop.so
256 %attr(755,root,root) %{_libdir}/libkmedia2.so
257 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
258 %attr(755,root,root) %{_libdir}/libmcop.so
259 %attr(755,root,root) %{_libdir}/libmcop_mt.so
260 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
261 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
262 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
263 # shared libraries
264 %{_libdir}/libartsflow.la
265 %{_libdir}/libartsflow_idl.la
266 %{_libdir}/libgmcop.la
267 %{_libdir}/libkmedia2.la
268 %{_libdir}/libkmedia2_idl.la
269 %{_libdir}/libmcop.la
270 %{_libdir}/libmcop_mt.la
271 %{_libdir}/libsoundserver_idl.la
272 #
273 %{_includedir}/arts
274 %exclude %{_includedir}/arts/qiomanager.h
275 %{_mandir}/man1/mcopidl.1*
276
277 %files -n artsc-devel
278 %defattr(644,root,root,755)
279 %attr(755,root,root) %{_bindir}/artsc-config
280 %attr(755,root,root) %{_libdir}/libartsc.so
281 %attr(755,root,root) %{_libdir}/libartscbackend.so
282 %attr(755,root,root) %{_libdir}/libartsdsp.so
283 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
284 %{_libdir}/libartsc.la
285 %{_includedir}/artsc
286 %{_mandir}/man1/artsc-config.1*
287
288 %files X11
289 %defattr(644,root,root,755)
290 # lt_dlopened module (.la needed)
291 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
292 %{_libdir}/libx11globalcomm.la
293
294 %files qt
295 %defattr(644,root,root,755)
296 # shared library
297 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
298
299 %files qt-devel
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_libdir}/libqtmcop.so
302 %{_libdir}/libqtmcop.la
303 %{_includedir}/arts/qiomanager.h
This page took 0.112318 seconds and 3 git commands to generate.