]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
ed06ad8808de6e15f4703b92d2e426228525a776
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6
7 %define         _state          unstable
8 %define         _ver            1.1.95
9 %define         _snap           040110
10
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        1.1.95
16 Release:        0.1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
21 Source0:        http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
22 # Source0-md5:  76feb4e5d5559e3a97659cbc833dab3a
23 URL:            http://www.kde.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.13-3
30 BuildRequires:  esound-devel
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  libmad-devel
33 BuildRequires:  libtool >= 2:1.5-2
34 BuildRequires:  libvorbis-devel
35 %{?with_nas:BuildRequires:      nas-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt-devel >= 6:3.2.1-4
38 Obsoletes:      arts-glib
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 aRts sound server.
43
44 %description -l pl
45 Serwer d¼wiêku aRts.
46
47 %description -l pt_BR
48 O aRts é um sintetizador analógico em tempo real que é completamente
49 modular. Você pode criar sons e músicas (síntese em tempo real de
50 midi) usando pequenos módulos como oscilador para criar waveforms,
51 vários filtros, mixers, faders, etc. Você pode configurar tudo através
52 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
53 design foi escolhido para permitir que outras aplicações usem o aRts
54 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
55 outros.
56
57 %package devel
58 Summary:        Sound server - header files
59 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
60 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
61 Group:          Development/Libraries
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63 # not necessary for all libs (e.g. mcop), but propagated by artsflow
64 %{?with_alsa:Requires:  alsa-lib-devel}
65 Requires:       audiofile-devel
66 Requires:       esound-devel
67 Requires:       glib2-devel >= 2.0.0
68 Requires:       libmad-devel
69 Requires:       libvorbis-devel
70 %{?with_nas:Requires:   nas-devel}
71
72 %description devel
73 Header files required to compile programs using arts.
74
75 %description devel -l pl
76 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
77 arts.
78
79 %description devel -l pt_BR
80 Arquivos para desenvolvimento com o o aRts.
81
82 # separate from arts-devel because they are mostly independent and have very
83 # different deps
84 # there is no artsc base - it would be small and would require arts - so there
85 # is no reason to separate
86 %package -n artsc-devel
87 Summary:        Development files for artsc libraries
88 Summary(pl):    Pliki programistyczne bibliotek artsc
89 Group:          Development/Libraries
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91 Requires:       glib2-devel >= 2.0.0
92 Conflicts:      arts-devel < 12:1.2.0.031126-2
93
94 %description -n artsc-devel
95 Development files for artsc libraries (C interface to aRts sound
96 system).
97
98 %description -n artsc-devel -l pl
99 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
100 d¼wiêku aRts).
101
102 %package X11
103 Summary:        X11 dependent part of aRts
104 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
105 Group:          X11/Libraries
106 Requires:       %{name} = %{epoch}:%{version}-%{release}
107
108 %description X11
109 X11 dependent part of aRts (x11globalcomm module).
110
111 %description X11 -l pl
112 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
113
114 %package qt
115 Summary:        QT dependend part of aRts
116 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
117 Group:          X11/Libraries
118 Requires:       %{name} = %{epoch}:%{version}-%{release}
119 Requires:       qt >= 6:3.2.1-4
120
121 %description qt
122 QT dependend part of aRts (qtmcop library).
123
124 %description qt -l pl
125 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
126
127 %package qt-devel
128 Summary:        Development files for qtmcop library
129 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
130 Group:          X11/Development/Libraries
131 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
132 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
133 Requires:       qt-devel >= 6:3.2.1-4
134
135 %description qt-devel
136 Development files for qtmcop library.
137
138 %description qt-devel -l pl
139 Pliki programistyczne dla biblioteki qtmcop.
140
141 %prep
142 %setup -q
143
144 %build
145 cp /usr/share/automake/config.sub admin
146 %{__make} -f admin/Makefile.common cvs
147
148 %configure \
149         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
150         --%{?debug:en}%{!?debug:dis}able-debug \
151         --disable-rpath \
152         --enable-final \
153         --with-qt-libraries=%{_libdir} \
154         --with%{!?with_alsa:out}-alsa
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 # Debian manpages
165 install -d $RPM_BUILD_ROOT%{_mandir}/man1
166 cd debian
167 for f in *.sgml ; do
168         base="$(basename $f .sgml)"
169         upper="$(echo ${base} | tr a-z A-Z)"
170         db2man $f
171         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
172 done
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %post   X11 -p /sbin/ldconfig
181 %postun X11 -p /sbin/ldconfig
182
183 %post   qt -p /sbin/ldconfig
184 %postun qt -p /sbin/ldconfig
185
186 %files
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/artscat
189 %attr(755,root,root) %{_bindir}/artsd
190 %attr(755,root,root) %{_bindir}/artsdsp
191 %attr(755,root,root) %{_bindir}/artsplay
192 %attr(755,root,root) %{_bindir}/artsrec
193 %attr(755,root,root) %{_bindir}/artsshell
194 %attr(755,root,root) %{_bindir}/artswrapper
195 # shared libraries
196 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
197 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
198 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
199 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
200 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
205 # lt_dlopened modules (*.la needed)
206 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
207 %{_libdir}/libartscbackend.la
208 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
209 %{_libdir}/libartsdsp.la
210 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
211 %{_libdir}/libartsdsp_st.la
212 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
213 %{_libdir}/libartsgslplayobject.la
214 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
215 %{_libdir}/libartswavplayobject.la
216 #
217 %{_libdir}/mcop
218 %{_mandir}/man1/artscat.1*
219 %{_mandir}/man1/artsd.1*
220 %{_mandir}/man1/artsdsp.1*
221 %{_mandir}/man1/artsplay.1*
222 %{_mandir}/man1/artsrec.1*
223 %{_mandir}/man1/artsshell.1*
224 %{_mandir}/man1/artswrapper.1*
225
226 %files devel
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_bindir}/mcopidl
229 %attr(755,root,root) %{_libdir}/libartsflow.so
230 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
231 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
232 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
233 %attr(755,root,root) %{_libdir}/libgmcop.so
234 %attr(755,root,root) %{_libdir}/libkmedia2.so
235 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
236 %attr(755,root,root) %{_libdir}/libmcop.so
237 %attr(755,root,root) %{_libdir}/libmcop_mt.so
238 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
239 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
240 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
241 # shared libraries
242 %{_libdir}/libartsflow.la
243 %{_libdir}/libartsflow_idl.la
244 %{_libdir}/libgmcop.la
245 %{_libdir}/libkmedia2.la
246 %{_libdir}/libkmedia2_idl.la
247 %{_libdir}/libmcop.la
248 %{_libdir}/libmcop_mt.la
249 %{_libdir}/libsoundserver_idl.la
250 #
251 %{_includedir}/arts
252 %exclude %{_includedir}/arts/qiomanager.h
253 %{_mandir}/man1/mcopidl.1*
254
255 %files -n artsc-devel
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_bindir}/artsc-config
258 %attr(755,root,root) %{_libdir}/libartsc.so
259 %attr(755,root,root) %{_libdir}/libartscbackend.so
260 %attr(755,root,root) %{_libdir}/libartsdsp.so
261 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
262 %{_libdir}/libartsc.la
263 %{_includedir}/artsc
264 %{_mandir}/man1/artsc-config.1*
265
266 %files X11
267 %defattr(644,root,root,755)
268 # lt_dlopened module (.la needed)
269 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
270 %{_libdir}/libx11globalcomm.la
271
272 %files qt
273 %defattr(644,root,root,755)
274 # shared library
275 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
276
277 %files qt-devel
278 %defattr(644,root,root,755)
279 %attr(755,root,root) %{_libdir}/libqtmcop.so
280 %{_libdir}/libqtmcop.la
281 %{_includedir}/arts/qiomanager.h
This page took 0.047776 seconds and 3 git commands to generate.