]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- updated to 030329, works, compiles
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5
6 %define         _state          snapshots
7 %define         _ver            030329
8
9 Summary:        aRts sound server
10 Summary(pl):    Serwer d¼wiêku
11 Summary(pt_BR): Servidor de sons usado pelo KDE
12 Name:           arts
13 Version:        1.2
14 Release:        0.%{_ver}.1
15 Epoch:          12
16 License:        LGPL
17 Vendor:         The KDE Team
18 Group:          Libraries
19 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
20 Source0:        http://team.pld.org.pl/~djurban/kde/%{name}-%{_ver}.tar.bz2
21 Patch0:         http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-video-20030314.patch
22 Patch1:         http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-streaming-20030317.patch
23 %ifnarch sparc sparcv9 sparc64
24 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
25 %endif
26 BuildRequires:  audiofile-devel
27 BuildRequires:  glib2-devel >= 2.0.0
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 # not needed, only ./configure check for this
31 #BuildRequires: libvorbis-devel
32 #BuildRequires: mad-devel
33 %{?_with_nas:BuildRequires:     nas-devel}
34 %{!?_with_nas:BuildConflicts:   nas-devel}
35 BuildRequires:  pkgconfig
36 BuildRequires:  qt-devel >= 3.1
37 URL:            http://www.kde.org/
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _htmldir        /usr/share/doc/kde/HTML
41
42 %define         no_install_post_chrpath         1
43
44 %description
45 aRts sound server.
46
47 %description -l pl
48 Serwer d¼wiêku aRts.
49
50 %description -l pt_BR
51 O aRts é um sintetizador analógico em tempo real que é completamente
52 modular. Você pode criar sons e músicas (síntese em tempo real de
53 midi) usando pequenos módulos como oscilador para criar waveforms,
54 vários filtros, mixers, faders, etc. Você pode configurar tudo através
55 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
56 design foi escolhido para permitir que outras aplicações usem o aRts
57 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
58 outros.
59
60 %package X11
61 Summary:        X11 dependent part of aRts
62 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
63 Group:          X11/Libraries
64
65 %description X11
66 X11 dependent part of aRts.
67
68 %description X11 -l pl
69 Czê¶æ aRts wymagaj±ca X11.
70
71 %package qt
72 Summary:        QT dependend part of aRts
73 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
74 Group:          X11/Libraries
75 Requires:       %{name} >= %{version}
76 Requires:       qt >= 3.1
77
78 %description qt
79 QT dependend part of aRts.
80
81 %description qt -l pl
82 Czê¶æ aRts wymagaj±ca QT.
83
84 %package devel
85 Summary:        Sound server - header files
86 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
87 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
88 Group:          Development/Libraries
89 Requires:       qt-devel >= 3.1
90 Requires:       %{name} >= %{version}
91
92 %description devel
93 Header files required to compile programs using arts.
94
95 %description devel -l pl
96 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
97 arts.
98
99 %description devel -l pt_BR
100 Arquivos para desenvolvimento com o o aRts.
101
102 %package glib
103 Summary:        GLib dependend part of aRts
104 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
105 Group:          X11/Libraries
106 Requires:       glib >= 1.2.6
107
108 %description glib
109 GLib dependend part of aRts.
110
111 %description glib -l pl
112 Czê¶æ aRts wymagaj±ca GLib.
113
114 %prep
115 %setup -q -n %{name}-%{_ver}
116 %patch0 -p1
117 %patch1 -p1
118 %build
119 kde_htmldir="%{_htmldir}"; export kde_htmldir
120 kde_icondir="%{_pixmapsdir}"; export kde_icondir
121
122 %configure \
123         --%{?debug:en}%{!?debug:dis}able-debug \
124         --enable-final \
125         --with-xinerama \
126         --with%{?_without_alsa:out}-alsa
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install DESTDIR=$RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %post X11   -p /sbin/ldconfig
139 %postun X11 -p /sbin/ldconfig
140
141 %post qt   -p /sbin/ldconfig
142 %postun qt -p /sbin/ldconfig
143
144 %post glib   -p /sbin/ldconfig
145 %postun glib -p /sbin/ldconfig
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/artscat
153 %attr(755,root,root) %{_bindir}/artsd
154 %attr(755,root,root) %{_bindir}/artsdsp
155 %attr(755,root,root) %{_bindir}/artsplay
156 %attr(755,root,root) %{_bindir}/artsrec
157 %attr(755,root,root) %{_bindir}/artsshell
158 %attr(755,root,root) %{_bindir}/artswrapper
159 ##%attr(755,root,root) %{_bindir}/testdhandle
160 %{_libdir}/lib[!gqx]*.la
161 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
162 %{_libdir}/mcop
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/artsc-config
167 %attr(755,root,root) %{_bindir}/mcopidl
168 %{_libdir}/*.so
169 %{_includedir}/arts
170 %{_includedir}/artsc
171
172 %files X11
173 %defattr(644,root,root,755)
174 %{_libdir}/libx11globalcomm.la
175 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
176
177 %files glib
178 %defattr(644,root,root,755)
179 %{_libdir}/libgmcop.la
180 %attr(755,root,root) %{_libdir}/libgmcop.so.*
181
182 %files qt
183 %defattr(644,root,root,755)
184 %{_libdir}/libqtmcop.la
185 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.05752 seconds and 3 git commands to generate.