]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- Updated to 030428 snap
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5
6 %define         _state          snapshots
7 %define         _ver            1.2
8 %define         _snap           030428
9
10 Summary:        aRts sound server
11 Summary(pl):    Serwer d¼wiêku
12 Summary(pt_BR): Servidor de sons usado pelo KDE
13 Name:           arts
14 Version:        1.2
15 Release:        0.%{_snap}.1
16 Epoch:          12
17 License:        LGPL
18 Group:          Libraries
19 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
20 Source0:        http://team.pld.org.pl/~adgor/kde/%{name}-%{_snap}.tar.bz2
21 Patch0:         http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-video-20030314.patch
22 Patch1:         http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-streaming-20030317.patch
23 %ifnarch sparc sparcv9 sparc64
24 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
25 %endif
26 BuildRequires:  audiofile-devel
27 BuildRequires:  glib2-devel >= 2.0.0
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 # not needed, only ./configure check for this
31 #BuildRequires: libvorbis-devel
32 #BuildRequires: mad-devel
33 %{?_with_nas:BuildRequires:     nas-devel}
34 %{!?_with_nas:BuildConflicts:   nas-devel}
35 BuildRequires:  pkgconfig
36 BuildRequires:  qt-devel >= 3.1
37 URL:            http://www.kde.org/
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _htmldir        %{_docdir}/kde/HTML
41
42 %define         no_install_post_chrpath         1
43
44 %description
45 aRts sound server.
46
47 %description -l pl
48 Serwer d¼wiêku aRts.
49
50 %description -l pt_BR
51 O aRts é um sintetizador analógico em tempo real que é completamente
52 modular. Você pode criar sons e músicas (síntese em tempo real de
53 midi) usando pequenos módulos como oscilador para criar waveforms,
54 vários filtros, mixers, faders, etc. Você pode configurar tudo através
55 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
56 design foi escolhido para permitir que outras aplicações usem o aRts
57 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
58 outros.
59
60 %package X11
61 Summary:        X11 dependent part of aRts
62 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
63 Group:          X11/Libraries
64
65 %description X11
66 X11 dependent part of aRts.
67
68 %description X11 -l pl
69 Czê¶æ aRts wymagaj±ca X11.
70
71 %package qt
72 Summary:        QT dependend part of aRts
73 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
74 Group:          X11/Libraries
75 Requires:       %{name} >= %{version}
76 Requires:       qt >= 3.1
77
78 %description qt
79 QT dependend part of aRts.
80
81 %description qt -l pl
82 Czê¶æ aRts wymagaj±ca QT.
83
84 %package devel
85 Summary:        Sound server - header files
86 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
87 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
88 Group:          Development/Libraries
89 Requires:       qt-devel >= 3.1
90 Requires:       %{name} >= %{version}
91
92 %description devel
93 Header files required to compile programs using arts.
94
95 %description devel -l pl
96 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
97 arts.
98
99 %description devel -l pt_BR
100 Arquivos para desenvolvimento com o o aRts.
101
102 %package glib
103 Summary:        GLib dependend part of aRts
104 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
105 Group:          X11/Libraries
106 Requires:       glib >= 1.2.6
107
108 %description glib
109 GLib dependend part of aRts.
110
111 %description glib -l pl
112 Czê¶æ aRts wymagaj±ca GLib.
113
114 %prep
115 %setup -q -n %{name}-%{_snap}
116 %patch0 -p1
117 %patch1 -p1
118 %build
119 kde_htmldir="%{_htmldir}"; export kde_htmldir
120 kde_icondir="%{_pixmapsdir}"; export kde_icondir
121
122 %configure \
123         --%{?debug:en}%{!?debug:dis}able-debug \
124         --enable-final \
125         --with-xinerama \
126         --with%{?_without_alsa:out}-alsa
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install DESTDIR=$RPM_BUILD_ROOT
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/artscat
141 %attr(755,root,root) %{_bindir}/artsd
142 %attr(755,root,root) %{_bindir}/artsdsp
143 %attr(755,root,root) %{_bindir}/artsplay
144 %attr(755,root,root) %{_bindir}/artsrec
145 %attr(755,root,root) %{_bindir}/artsshell
146 %attr(755,root,root) %{_bindir}/artswrapper
147 ##%attr(755,root,root) %{_bindir}/testdhandle
148 %{_libdir}/lib[!gqx]*.la
149 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
150 %{_libdir}/mcop
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/artsc-config
155 %attr(755,root,root) %{_bindir}/mcopidl
156 %{_libdir}/*.so
157 %{_includedir}/arts
158 %{_includedir}/artsc
159
160 %files X11
161 %defattr(644,root,root,755)
162 %{_libdir}/libx11globalcomm.la
163 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
164
165 %files glib
166 %defattr(644,root,root,755)
167 %{_libdir}/libgmcop.la
168 %attr(755,root,root) %{_libdir}/libgmcop.so.*
169
170 %files qt
171 %defattr(644,root,root,755)
172 %{_libdir}/libqtmcop.la
173 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.04482 seconds and 3 git commands to generate.