]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- release 1 - official tars md5
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5 %ifarch sparc sparcv9 sparc64
6 %define         _without_alsa   1
7 %endif
8 Summary:        aRts sound server
9 Summary(pl):    Serwer d¼wiêku
10 Summary(pt_BR): Servidor de sons usado pelo KDE
11 Name:           arts
12 Version:        1.1.4
13 Release:        1
14 Epoch:          12
15 License:        LGPL
16 Vendor:         The KDE Team
17 Group:          Libraries
18 Source0:        ftp://ftp.kde.org/pub/kde/stable/3.1.4/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  ee04953fe0e983de424430081bb7bc9e
20 URL:            http://www.kde.org/
21 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
22 BuildRequires:  audiofile-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  glib2-devel >= 2.0.0
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libmad-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool >= 2:1.5-2
31 BuildRequires:  libvorbis-devel
32 %{?_with_nas:BuildRequires:     nas-devel}
33 BuildRequires:  pkgconfig
34 BuildRequires:  qt-devel >= 3.1
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _htmldir        /usr/share/doc/kde/HTML
38
39 %description
40 aRts sound server.
41
42 %description -l pl
43 Serwer d¼wiêku aRts.
44
45 %description -l pt_BR
46 O aRts é um sintetizador analógico em tempo real que é completamente
47 modular. Você pode criar sons e músicas (síntese em tempo real de
48 midi) usando pequenos módulos como oscilador para criar waveforms,
49 vários filtros, mixers, faders, etc. Você pode configurar tudo através
50 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
51 design foi escolhido para permitir que outras aplicações usem o aRts
52 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
53 outros.
54
55 %package X11
56 Summary:        X11 dependent part of aRts
57 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
58 Group:          X11/Libraries
59 Requires:       %{name} = %{epoch}:%{version}
60
61 %description X11
62 X11 dependent part of aRts.
63
64 %description X11 -l pl
65 Czê¶æ aRts wymagaj±ca X11.
66
67 %package qt
68 Summary:        QT dependend part of aRts
69 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
70 Group:          X11/Libraries
71 Requires:       %{name} = %{epoch}:%{version}
72 Requires:       qt >= 3.1
73
74 %description qt
75 QT dependend part of aRts.
76
77 %description qt -l pl
78 Czê¶æ aRts wymagaj±ca QT.
79
80 %package devel
81 Summary:        Sound server - header files
82 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
83 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
84 Group:          Development/Libraries
85 Requires:       qt-devel >= 3.1
86 Requires:       %{name} = %{epoch}:%{version}
87 %{?_with_nas:Requires:  nas-devel}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 %package glib
100 Summary:        GLib dependend part of aRts
101 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
102 Group:          Libraries
103 Requires:       %{name} = %{epoch}:%{version}
104 Requires:       glib >= 1.2.6
105
106 %description glib
107 GLib dependend part of aRts.
108
109 %description glib -l pl
110 Czê¶æ aRts wymagaj±ca GLib.
111
112 %prep
113 %setup -q
114
115 %build
116 %{__libtoolize}
117 %{__aclocal}
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %{__perl} admin/am_edit
122
123 kde_htmldir="%{_htmldir}"; export kde_htmldir
124 kde_icondir="%{_pixmapsdir}"; export kde_icondir
125 %configure \
126         --%{?debug:en}%{!?debug:dis}able-debug \
127         --disable-rpath \
128         --enable-final \
129         --with-xinerama \
130         --with%{?_without_alsa:out}-alsa
131
132 %if %{!?_with_nas:1}0
133 # Cannot patch configure.in because it does not rebuild correctly on ac25
134 sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
135         < config.h \
136         > config.h.tmp
137 mv -f config.h{.tmp,}
138 %endif
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %post   X11 -p /sbin/ldconfig
154 %postun X11 -p /sbin/ldconfig
155
156 %post   qt -p /sbin/ldconfig
157 %postun qt -p /sbin/ldconfig
158
159 %post   glib -p /sbin/ldconfig
160 %postun glib -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/artscat
165 %attr(755,root,root) %{_bindir}/artsd
166 %attr(755,root,root) %{_bindir}/artsdsp
167 %attr(755,root,root) %{_bindir}/artsplay
168 %attr(755,root,root) %{_bindir}/artsrec
169 %attr(755,root,root) %{_bindir}/artsshell
170 %attr(755,root,root) %{_bindir}/artswrapper
171 %attr(755,root,root) %{_bindir}/testdhandle
172 # shared libraries
173 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
174 %attr(755,root,root) %{_libdir}/libartsflow*.so.*.*.*
175 %attr(755,root,root) %{_libdir}/libkmedia2*.so.*.*.*
176 %attr(755,root,root) %{_libdir}/libmcop*.so.*.*.*
177 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
178 # lt_dlopened modules (*.la needed)
179 %attr(755,root,root) %{_libdir}/libarts*playobject.so.*.*.*
180 %{_libdir}/libarts*playobject.la
181 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
182 %{_libdir}/libartscbackend.la
183 %attr(755,root,root) %{_libdir}/libartsdsp*.so.*.*.*
184 %{_libdir}/libartsdsp*.la
185 %{_libdir}/mcop
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/artsc-config
190 %attr(755,root,root) %{_bindir}/mcopidl
191 %attr(755,root,root) %{_libdir}/libartsc.so
192 %attr(755,root,root) %{_libdir}/libartsflow*.so
193 %attr(755,root,root) %{_libdir}/libkmedia2*.so
194 %attr(755,root,root) %{_libdir}/libmcop*.so
195 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
196 %attr(755,root,root) %{_libdir}/libgmcop.so
197 %attr(755,root,root) %{_libdir}/libqtmcop.so
198 # some apps (incorrectly?) link with libarts*playobject (gg with -lartswavplayobject only?)
199 %attr(755,root,root) %{_libdir}/libarts*playobject.so
200 %{_libdir}/libartsc.la
201 %{_libdir}/libartsflow*.la
202 %{_libdir}/libkmedia2*.la
203 %{_libdir}/libmcop*.la
204 %{_libdir}/libsoundserver_idl.la
205 %{_libdir}/libgmcop.la
206 %{_libdir}/libqtmcop.la
207 %{_includedir}/arts
208 %{_includedir}/artsc
209
210 %files X11
211 %defattr(644,root,root,755)
212 # lt_dlopened module (.la needed)
213 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
214 %{_libdir}/libx11globalcomm.la
215
216 %files glib
217 %defattr(644,root,root,755)
218 # shared library
219 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
220
221 %files qt
222 %defattr(644,root,root,755)
223 # shared library
224 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.050786 seconds and 3 git commands to generate.