]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- Up to 030403 snap (major fixes)
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5
6 %define         _state          snapshots
7 %define         _ver            1.2
8 %define         _snap           030403
9
10 Summary:        aRts sound server
11 Summary(pl):    Serwer d¼wiêku
12 Summary(pt_BR): Servidor de sons usado pelo KDE
13 Name:           arts
14 Version:        1.2
15 Release:        0.%{_snap}.1
16 Epoch:          12
17 License:        LGPL
18 Vendor:         The KDE Team
19 Group:          Libraries
20 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
21 Source0:        http://team.pld.org.pl/~adgor/kde/%{name}-%{_snap}.tar.bz2
22 Patch0:         http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-video-20030314.patch
23 Patch1:         http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-streaming-20030317.patch
24 %ifnarch sparc sparcv9 sparc64
25 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
26 %endif
27 BuildRequires:  audiofile-devel
28 BuildRequires:  glib2-devel >= 2.0.0
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng-devel
31 # not needed, only ./configure check for this
32 #BuildRequires: libvorbis-devel
33 #BuildRequires: mad-devel
34 %{?_with_nas:BuildRequires:     nas-devel}
35 %{!?_with_nas:BuildConflicts:   nas-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt-devel >= 3.1
38 URL:            http://www.kde.org/
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _htmldir        %{_docdir}/kde/HTML
42
43 %define         no_install_post_chrpath         1
44
45 %description
46 aRts sound server.
47
48 %description -l pl
49 Serwer d¼wiêku aRts.
50
51 %description -l pt_BR
52 O aRts é um sintetizador analógico em tempo real que é completamente
53 modular. Você pode criar sons e músicas (síntese em tempo real de
54 midi) usando pequenos módulos como oscilador para criar waveforms,
55 vários filtros, mixers, faders, etc. Você pode configurar tudo através
56 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
57 design foi escolhido para permitir que outras aplicações usem o aRts
58 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
59 outros.
60
61 %package X11
62 Summary:        X11 dependent part of aRts
63 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
64 Group:          X11/Libraries
65
66 %description X11
67 X11 dependent part of aRts.
68
69 %description X11 -l pl
70 Czê¶æ aRts wymagaj±ca X11.
71
72 %package qt
73 Summary:        QT dependend part of aRts
74 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
75 Group:          X11/Libraries
76 Requires:       %{name} >= %{version}
77 Requires:       qt >= 3.1
78
79 %description qt
80 QT dependend part of aRts.
81
82 %description qt -l pl
83 Czê¶æ aRts wymagaj±ca QT.
84
85 %package devel
86 Summary:        Sound server - header files
87 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
88 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
89 Group:          Development/Libraries
90 Requires:       qt-devel >= 3.1
91 Requires:       %{name} >= %{version}
92
93 %description devel
94 Header files required to compile programs using arts.
95
96 %description devel -l pl
97 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
98 arts.
99
100 %description devel -l pt_BR
101 Arquivos para desenvolvimento com o o aRts.
102
103 %package glib
104 Summary:        GLib dependend part of aRts
105 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
106 Group:          X11/Libraries
107 Requires:       glib >= 1.2.6
108
109 %description glib
110 GLib dependend part of aRts.
111
112 %description glib -l pl
113 Czê¶æ aRts wymagaj±ca GLib.
114
115 %prep
116 %setup -q -n %{name}-%{_snap}
117 %patch0 -p1
118 %patch1 -p1
119 %build
120 kde_htmldir="%{_htmldir}"; export kde_htmldir
121 kde_icondir="%{_pixmapsdir}"; export kde_icondir
122
123 %configure \
124         --%{?debug:en}%{!?debug:dis}able-debug \
125         --enable-final \
126         --with-xinerama \
127         --with%{?_without_alsa:out}-alsa
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install DESTDIR=$RPM_BUILD_ROOT
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/artscat
142 %attr(755,root,root) %{_bindir}/artsd
143 %attr(755,root,root) %{_bindir}/artsdsp
144 %attr(755,root,root) %{_bindir}/artsplay
145 %attr(755,root,root) %{_bindir}/artsrec
146 %attr(755,root,root) %{_bindir}/artsshell
147 %attr(755,root,root) %{_bindir}/artswrapper
148 ##%attr(755,root,root) %{_bindir}/testdhandle
149 %{_libdir}/lib[!gqx]*.la
150 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
151 %{_libdir}/mcop
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/artsc-config
156 %attr(755,root,root) %{_bindir}/mcopidl
157 %{_libdir}/*.so
158 %{_includedir}/arts
159 %{_includedir}/artsc
160
161 %files X11
162 %defattr(644,root,root,755)
163 %{_libdir}/libx11globalcomm.la
164 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
165
166 %files glib
167 %defattr(644,root,root,755)
168 %{_libdir}/libgmcop.la
169 %attr(755,root,root) %{_libdir}/libgmcop.so.*
170
171 %files qt
172 %defattr(644,root,root,755)
173 %{_libdir}/libqtmcop.la
174 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.062598 seconds and 3 git commands to generate.