]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
715307b7964dca13197321597fe5281fbd2cfa5c
[packages/arts.git] / arts.spec
1 %define         _kde_ver        3.0
2 %define         _ver            1.0.0
3 # Set this to rc3 and such.
4 # define                _sub_ver
5 %define         _rel            2
6
7 # Set up version, release and FTP directory.
8 %{?_sub_ver:    %define _version        %{_ver}%{_sub_ver}}
9 %{!?_sub_ver:   %define _version        %{_ver}}
10 %{?_sub_ver:    %define _release        0.%{_sub_ver}.%{_rel}}
11 %{!?_sub_ver:   %define _release        %{_rel}}
12 %{!?_sub_ver:   %define _ftpdir stable}
13 %{?_sub_ver:    %define _ftpdir unstable/kde-%{version}%{_sub_ver}}
14
15 Summary:        aRts sound server
16 Summary(es):    Sound server used by KDE
17 Summary(pl):    Serwer d¼wiêku
18 Summary(pt_BR): Servidor de sons usado pelo KDE
19 Name:           arts
20 Version:        %{_version}
21 Release:        %{_release}
22 Epoch:          8
23 License:        LGPL
24 Vendor:         The KDE Team
25 Group:          Libraries
26 Source0:        ftp://ftp.kde.org/pub/kde/%{_ftpdir}/%{_kde_ver}/src/%{name}-%{version}.tar.bz2
27 BuildRequires:  alsa-lib-devel
28 BuildRequires:  audiofile-devel
29 BuildRequires:  glib2-devel >= 2.0.0
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel >= 1.2.2-2
32 # not needed, only ./configure check for this
33 #BuildRequires: libvorbis-devel
34 #BuildRequires: mad-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  qt-devel >= 3.0.3
37 BuildRequires:  XFree86-devel
38 BuildRequires:  zlib-devel
39 Requires:       qt >= 3.0.3
40 URL:            http://www.kde.org/
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _prefix         /usr/X11R6
44 %define         _htmldir        /usr/share/doc/kde/HTML
45
46 %description
47 aRts sound server.
48
49 %description -l es
50 Sound server and analog analyzer/synthetizer used by KDE.
51
52 %description -l pl
53 Serwer d¼wiêku aRts.
54
55 %description -l pt_BR
56 O aRts é um sintetizador analógico em tempo real que é completamente
57 modular. Você pode criar sons e músicas (síntese em tempo real de
58 midi) usando pequenos módulos como oscilador para criar waveforms,
59 vários filtros, mixers, faders, etc. Você pode configurar tudo através
60 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
61 design foi escolhido para permitir que outras aplicações usem o aRts
62 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
63 outros.
64
65 %package X11
66 Summary:        X11 dependent part of aRts
67 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
68 Group:          X11/Libraries
69 Group(de):      X11/Libraries
70 Group(es):      X11/Bibliotecas
71 Group(fr):      X11/Librairies
72 Group(pl):      X11/Biblioteki
73 Group(pt_BR):   X11/Bibliotecas
74 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
75 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
76
77 %description X11
78 X11 dependent part of aRts.
79
80 %description X11 -l pl
81 Czê¶æ aRts wymagaj±ca X11.
82
83 %package qt
84 Summary:        QT dependend part of aRts
85 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
86 Group:          X11/Libraries
87 Group(de):      X11/Libraries
88 Group(es):      X11/Bibliotecas
89 Group(fr):      X11/Librairies
90 Group(pl):      X11/Biblioteki
91 Group(pt_BR):   X11/Bibliotecas
92 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
93 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
94
95 %description qt
96 QT dependend part of aRts.
97
98 %description qt -l pl
99 Czê¶æ aRts wymagaj±ca QT.
100
101 %package devel
102 Summary:        Sound server - header files
103 Summary(es):    Header files for compiling aRtsd applications
104 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
105 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
106 Group:          Development/Libraries
107 Group(de):      Entwicklung/Libraries
108 Group(es):      Desarrollo/Bibliotecas
109 Group(fr):      Development/Librairies
110 Group(pl):      Programowanie/Biblioteki
111 Group(pt_BR):   Desenvolvimento/Bibliotecas
112 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
113 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
114
115 %description devel
116 Header files required to compile programs using arts.
117
118 %description devel -l es
119 This package includes the header files you will need to compile
120 applications for aRtsd.
121
122 %description devel -l pl
123 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
124 arts.
125
126 %description devel -l pt_BR
127 Arquivos para desenvolvimento com o o aRts.
128
129 %package glib
130 Summary:        GLib dependend part of aRts
131 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
132 Group:          X11/Libraries
133
134 %description glib
135 GLib dependend part of aRts.
136
137 %description glib -l pl
138 Czê¶æ aRts wymagaj±ca GLib.
139
140 %prep
141 %setup -q
142
143 %build
144 kde_htmldir="%{_htmldir}"; export kde_htmldir
145 kde_icondir="%{_pixmapsdir}"; export kde_icondir
146
147 #%{__make} -f Makefile.cvs
148
149 CFLAGS="%{rpmcflags} `pkg-config libpng12 --cflags`"; export CFLAGS
150 CXXFLAGS="%{rpmcflags}"; export CXXFLAGS
151 %configure \
152         --%{?debug:en}%{!?debug:dis}able-debug \
153         --enable-final \
154         --with-xinerama \
155         --with-alsa 
156
157 %{__make}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install DESTDIR=$RPM_BUILD_ROOT
163
164 %post -p /sbin/ldconfig
165 %postun -p /sbin/ldconfig
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %files
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/artscat
173 %attr(755,root,root) %{_bindir}/artsd
174 %attr(755,root,root) %{_bindir}/artsdsp
175 %attr(755,root,root) %{_bindir}/artsplay
176 %attr(755,root,root) %{_bindir}/artsrec
177 %attr(755,root,root) %{_bindir}/artsshell
178 %attr(755,root,root) %{_bindir}/artswrapper
179 %attr(755,root,root) %{_libdir}/lib[am]*.so.*.*
180 %attr(755,root,root) %{_libdir}/libs[!h]*.so.*.*
181 %attr(755,root,root) %{_libdir}/lib[ams]*.la
182 %attr(755,root,root) %{_libdir}/libkmedia*.so.*.*
183 %attr(755,root,root) %{_libdir}/libkmedia*.la
184 %{_libdir}/mcop
185
186 %files X11
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
189 %attr(755,root,root) %{_libdir}/libx11globalcomm.la
190
191 %files qt
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
194 %attr(755,root,root) %{_libdir}/libqtmcop.la
195
196 %files glib
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
199 %attr(755,root,root) %{_libdir}/libgmcop.la
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/artsc-config
204 %attr(755,root,root) %{_bindir}/mcopidl
205 %{_libdir}/lib[mqsxg]*.so
206 %{_libdir}/libarts[!k]*.so
207 %{_libdir}/libkmedia*.so
208 %{_includedir}/arts
209 %{_includedir}/artsc
This page took 0.068398 seconds and 3 git commands to generate.