]> git.pld-linux.org Git - packages/ardour.git/blob - ardour.spec
a33a22d9650d5bc25fd2c1a2fdbb17a108f61f60
[packages/ardour.git] / ardour.spec
1 # TODO
2 # - make it not to parse /proc/cpuinfo
3 Summary:        Multitrack hard disk recorder
4 Summary(pl.UTF-8):      Wielościeżkowy magnetofon nagrywający na twardym dysku
5 Name:           ardour
6 Version:        2.1
7 Release:        0.1
8 License:        GPL
9 Group:          X11/Applications/Sound
10 Source0:        http://ardour.org/files/releases/%{name}-%{version}.tar.bz2
11 # Source0-md5:  18be414a37b832aae23c068ba9fcf8ab
12 Source1:        %{name}.desktop
13 Patch0:         %{name}-c++.patch
14 Patch1:         %{name}-opt.patch
15 Patch2:         %{name}-stdint.patch
16 URL:            http://ardour.org/
17 BuildRequires:  alsa-lib-devel >= 0.9.0
18 BuildRequires:  boost-devel
19 BuildRequires:  gettext-devel
20 # included libsndfile needs patch (wants FLAC__seekable_stream_decoder_set_read_callback)
21 # (in ardour itself only one UI option depends on HAVE_FLAC)
22 BuildRequires:  cairomm-devel
23 BuildRequires:  fftw3-single-devel >= 3
24 BuildRequires:  flac-devel
25 BuildRequires:  glib2-devel >= 1:2.10.1
26 BuildRequires:  gtk+2-devel >= 2:2.8.1
27 BuildRequires:  gtkmm-devel >= 2.8.0
28 BuildRequires:  jack-audio-connection-kit-devel >= 0.103
29 BuildRequires:  libart_lgpl >= 2.3.16
30 BuildRequires:  libgnomecanvas-devel >= 2.0
31 BuildRequires:  libgnomecanvasmm-devel >= 2.12.0
32 BuildRequires:  liblo-devel
33 BuildRequires:  liblrdf-devel >= 0.4.0
34 BuildRequires:  libraptor-devel >= 1.4.2
35 BuildRequires:  libsamplerate-devel >= 0.1.2
36 BuildRequires:  libsigc++-devel >= 2.0
37 # internal one used
38 #BuildRequires: libsndfile-devel >= 1.0.0
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool
41 BuildRequires:  libusb-devel
42 BuildRequires:  libxml2-devel >= 1:2.6.0
43 BuildRequires:  libxslt-devel
44 BuildRequires:  pkgconfig >= 1:0.20
45 BuildRequires:  python >= 2.3.4
46 BuildRequires:  scons >= 0.96
47 BuildRequires:  soundtouch-devel >= 1.3.1
48 Requires:       jack-audio-connection-kit-libs >= 0.103
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 A "professional" multitrack, multichannel audio recorder and DAW for
53 Linux, using ALSA-supported audio interfaces. Supports up to 32 bit
54 samples, 24+ channels at up to 96kHz, full MMC control,
55 non-destructive, non-linear editor, LADSPA plugins.
56
57 %description -l pl.UTF-8
58 "Profesjonalny" wielościeżkowy, wielokanałowy magnetofon oraz DAW dla
59 Linuksa, wykorzystujący interfejsy dźwiękowe obsługiwane przez ALSA.
60 Obsługuje próbki do 32 bitów, 24+ kanałów do 96kHz, pełną kontrolę
61 MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 # NEEDS UPDATE for scons
67 #%patch1 -p1
68 %patch2 -p1
69
70 %build
71 # Make sure we have /proc mounted - it searches for flags from there
72 if [ ! -f /proc/cpuinfo ]; then
73         echo "You need to have /proc mounted in order to build this package!"
74         exit 1
75 fi
76 %scons \
77         PREFIX=%{_prefix} \
78         SYSLIBS=1 \
79 %ifarch %{x8664}
80         DIST_TARGET=x86_64
81 %else
82 %ifarch %{ix86}
83         DIST_TARGET=i386
84 %else
85         DIST_TARGET=none
86 %endif
87 %endif
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_desktopdir}
92
93 %scons install \
94         DESTDIR=$RPM_BUILD_ROOT \
95         PREFIX=%{_prefix} \
96         GTK=yes
97 #       KSI=yes
98
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
100
101 # it shouldn't be there
102 rm -f $RPM_BUILD_ROOT%{_datadir}/ardour/libardour.{la,a}
103
104 %find_lang %{name} --all-name
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files -f %{name}.lang
110 %defattr(644,root,root,755)
111 %doc DOCUMENTATION/{AUTHORS,CONTRIBUTORS,FAQ,README,TODO,TRANSLATORS}
112 %lang(es) %doc DOCUMENTATION/{AUTHORS.es,CONTRIBUTORS.es,README.es}
113 %lang(fr) %doc DOCUMENTATION/README.fr
114 %lang(it) %doc DOCUMENTATION/README.it
115 %lang(ru) %doc DOCUMENTATION/README.ru
116 %dir %{_sysconfdir}/ardour2
117 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/*.conf
118 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/*.rc
119 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/ardour.bindings
120 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ardour2/ardour.menus
121 %attr(755,root,root) %{_bindir}/ardour2
122 %{_datadir}/ardour2
123 %{_desktopdir}/ardour.desktop
124
125 %dir %{_libdir}/ardour2
126 %attr(755,root,root) %{_libdir}/ardour2/ardour-2.1
127 %attr(755,root,root) %{_libdir}/ardour2/libardour.so
128 %attr(755,root,root) %{_libdir}/ardour2/libardour_cp.so
129 %attr(755,root,root) %{_libdir}/ardour2/libgtkmm2ext.so
130 %attr(755,root,root) %{_libdir}/ardour2/libmidi++.so
131 %attr(755,root,root) %{_libdir}/ardour2/libpbd.so
132 %attr(755,root,root) %{_libdir}/ardour2/libsndfile-ardour.so
133 %dir %{_libdir}/ardour2/engines
134 %attr(755,root,root) %{_libdir}/ardour2/engines/libclearlooks.so
135 %dir %{_libdir}/ardour2/surfaces
136 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_genericmidi.so
137 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_mackie.so
138 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_powermate.so
139 %attr(755,root,root) %{_libdir}/ardour2/surfaces/libardour_tranzport.so
This page took 0.088702 seconds and 3 git commands to generate.