]> git.pld-linux.org Git - packages/aqbanking.git/blob - aqbanking.spec
a4e8e1df731761f20f0e1ff9ffd605c6aa8052e7
[packages/aqbanking.git] / aqbanking.spec
1 Summary:        A library for online banking functions and financial data import/export
2 Summary(pl):    Biblioteka do funkcji bankowych online oraz importu/eksportu danych finansowych
3 Name:           aqbanking
4 Version:        1.2.0
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/aqbanking/%{name}-%{version}.tar.gz
9 # Source0-md5:  b6afa0facd32be6f57b3b8f802a2eb6c
10 Patch0:         %{name}-link.patch
11 URL:            http://www.aquamaniac.de/aqbanking/
12 BuildRequires:  autoconf >= 2.56
13 BuildRequires:  automake
14 BuildRequires:  gettext-devel
15 BuildRequires:  gwenhywfar-devel >= 1.14.0
16 BuildRequires:  ktoblzcheck-devel
17 BuildRequires:  libofx-devel >= 0.7.0
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  python-ctypes
21 BuildRequires:  python-devel >= 2.3
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The intention of AqBanking is to provide a middle layer between the
26 program and the various Online Banking libraries (e.g. AqHBCI). The
27 first backend which is already supported is AqHBCI, a library which
28 implements a client for the German HBCI (Home Banking Computer
29 Interface) protocol. Additionally, Aqbanking provides various plugins
30 to simplify import and export of financial data. Currently there are
31 import plugins for the following formats: DTAUS (German financial
32 format), SWIFT (MT940 and MT942).
33
34 %description -l pl
35 Celem projektu AqBanking jest dostarczenie warstwy po¶redniej miêdzy
36 programem a ró¿nymi bibliotekami us³ug bankowych online (np. AqHBCI).
37 Pierwszy ju¿ obs³ugiwany backend to AqHBCI - biblioteka implementuj±ca
38 klienta niemieckiego protoko³u HBCI (Home Baking Computer Interface).
39 Ponadto Aqbanking dostarcza ró¿ne wtyczki upraszczaj±ce importowanie i
40 eksportowanie danych finansowych. Aktualnie istniej± wtyczki do
41 importu nastêpuj±cych formatów: DTAUS (niemiecki format finansowy),
42 SWIFT (MT940 oraz MT942).
43
44 %package devel
45 Summary:        Header files for AqBanking library
46 Summary(pl):    Pliki nag³ówkowe biblioteki AqBanking
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       gwenhywfar-devel >= 1.14.0
50 # for libaqbankingpp only
51 #Requires:      libstdc++-devel
52
53 %description devel
54 Header files for AqBanking library.
55
56 %description devel -l pl
57 Pliki nag³ówkowe biblioteki AqBanking.
58
59 %package static
60 Summary:        Static AqBanking libraries
61 Summary(pl):    Statyczne biblioteki AqBanking
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static AqBanking libraries.
67
68 %description static -l pl
69 Statyczne biblioteki AqBanking.
70
71 %package -n python-%{name}
72 Summary:        Python binding for AqBanking library
73 Summary(pl):    Wi±zanie Pythona do biblioteki AqBanking
74 Group:          Development/Languages/Python
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       python-ctypes
77
78 %description -n python-%{name}
79 Python binding for AqBanking library.
80
81 %description -n python-%{name} -l pl
82 Wi±zanie Pythona do biblioteki AqBanking.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --enable-libofx \
96         --enable-python \
97         --enable-static
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 rm -f $RPM_BUILD_ROOT%{_libdir}/*/plugins/*/*/*.{la,a}
108 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/aqbanking/*.py
109
110 %find_lang %{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc ChangeLog ChangeLog README TODO
121 %attr(755,root,root) %{_bindir}/aqbanking-tool
122 %attr(755,root,root) %{_libdir}/libaqbanking.so.*.*.*
123 %attr(755,root,root) %{_libdir}/libaqbankingpp.so.*.*.*
124 %dir %{_libdir}/aqbanking
125 %dir %{_libdir}/aqbanking/plugins
126 %dir %{_libdir}/aqbanking/plugins/*
127 %dir %{_libdir}/aqbanking/plugins/*/bankinfo
128 %dir %{_libdir}/aqbanking/plugins/*/imexporters
129 %attr(755,root,root) %{_libdir}/aqbanking/plugins/*/*/*.so*
130 %{_libdir}/aqbanking/plugins/*/*/*.xml
131 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/dbio/*.so*
132 %{_libdir}/gwenhywfar/plugins/*/dbio/*.xml
133 %{_datadir}/aqbanking
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/aqbanking-config
138 %attr(755,root,root) %{_libdir}/libaqbanking.so
139 %attr(755,root,root) %{_libdir}/libaqbankingpp.so
140 %{_libdir}/libaqbanking.la
141 %{_libdir}/libaqbankingpp.la
142 %{_includedir}/aqbanking
143 %{_includedir}/aqbanking++
144 %{_aclocaldir}/aqbanking.m4
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libaqbanking.a
149 %{_libdir}/libaqbankingpp.a
150
151 %files -n python-%{name}
152 %defattr(644,root,root,755)
153 %dir %{py_sitescriptdir}/aqbanking
154 %{py_sitescriptdir}/aqbanking/*.py[co]
This page took 0.084125 seconds and 3 git commands to generate.