]> git.pld-linux.org Git - packages/apr.git/blob - apr.spec
3220b96e16db8bcdd5b1e1bce182a617c8183a6a
[packages/apr.git] / apr.spec
1 %define snap    20030913101709
2 Summary:        Apache Portable Runtime
3 Name:           apr
4 Version:        0.9.4
5 Release:        0.%{snap}.2
6 Epoch:          1
7 License:        GPL
8 Group:          Libraries
9 # http://www.apache.org/dist/apr/%{name}-%{version}.tar.gz
10 Source0:        http://cvs.apache.org/snapshots/apr/%{name}_%{snap}.tar.gz
11 # Source0-md5:  d14874964cd7f686594534d9e949eaee
12 URL:            http://apr.apache.org/
13 BuildRequires:  libtool
14 BuildRequires:  autoconf
15 BuildRequires:  perl-base
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _includedir     /usr/include/apr
19 %define         _datadir        /usr/share/apr
20
21 %description
22 The mission of the Apache Portable Runtime (APR) project is to create
23 and maintain software libraries that provide a predictable and
24 consistent interface to underlying platform-specific implementations.
25 The primary goal is to provide an API to which software developers may
26 code and be assured of predictable if not identical behaviour
27 regardless of the platform on which their software is built, relieving
28 them of the need to code special-case conditions to work around or
29 take advantage of platform-specific deficiencies or features.
30
31 %package devel
32 Summary:        Header files and develpment documentation for apr
33 Group:          Development/Libraries
34 Requires:       %{name} = %{epoch}:%{version}
35 Requires:       libtool
36
37 %description devel
38 Header files and develpment documentation for apr.
39
40 %package static
41 Summary:        Static apr library
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{epoch}:%{version}
44
45 %description static
46 Static apr library.
47
48 %prep
49 %setup  -q -n %{name}
50
51 %build
52 ./buildconf
53 %configure \
54         --enable-threads
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
64
65 install build/{*apr*.m4,*.awk,*.sh,config.*}    $RPM_BUILD_ROOT%{_datadir}/build
66
67 perl -pi -e "s#$RPM_BUILD_DIR/%{name}#%{_datadir}#g" $RPM_BUILD_ROOT%{_bindir}/*
68 perl -pi -e "s#$RPM_BUILD_DIR/%{name}.*#%{_datadir}/build#g" $RPM_BUILD_ROOT%{_datadir}/build/*
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CHANGES STATUS docs/*.html
79 %attr(755,root,root) %{_libdir}/lib*.so.*.*
80
81 %files devel
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/*
84 %attr(755,root,root) %{_libdir}/lib*.so
85 %{_libdir}/lib*.la
86 %{_libdir}/apr.exp
87 %{_includedir}
88 %dir %{_datadir}
89 %dir %{_datadir}/build
90 %{_datadir}/build/*.mk
91 %{_datadir}/build/*.m4
92 %{_datadir}/build/*.awk
93 %attr(755,root,root) %{_datadir}/build/config.*
94 %attr(755,root,root) %{_datadir}/build/*.sh
95 %attr(755,root,root) %{_datadir}/build/libtool
96
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/lib*.a
This page took 0.042808 seconds and 3 git commands to generate.