]> git.pld-linux.org Git - packages/apr.git/blob - apr.spec
- updated to 1.2.7
[packages/apr.git] / apr.spec
1 #
2 # Conditional build:
3 %bcond_without  epoll           # don't use epoll() syscall (requires Linux 2.6)
4 %bcond_without  sendfile64      # don't use sendfile64 (requires Linux 2.6 on ppc/sparc*)
5 %bcond_without  tcpnodelaycork  # don't use TCP_NODELAY|TCP_CORK flags (requires Linux 2.6)
6 #
7 Summary:        Apache Portable Runtime
8 Summary(pl):    Apache Portable Runtime - przeno¶na biblioteka uruchomieniowa
9 Name:           apr
10 Version:        1.2.7
11 Release:        1
12 Epoch:          1
13 License:        Apache v2.0
14 Group:          Libraries
15 Source0:        http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
16 # Source0-md5:  e77887dbafc515c63feac84686bcb3bc
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-metuxmpm.patch
19 Patch2:         %{name}-no-epoll.patch
20 Patch3:         %{name}-libtool.patch
21 URL:            http://apr.apache.org/
22 BuildRequires:  autoconf >= 2.13
23 BuildRequires:  automake
24 BuildRequires:  libtool >= 1.3.3
25 BuildRequires:  libuuid-devel
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  python
28 %if %{with epoll} || %{with sendfile64} || %{with tcpnodelaycork}
29 Conflicts:      kernel24
30 Conflicts:      kernel24-smp
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _includedir     /usr/include/apr
35 %define         _datadir        /usr/share/apr
36
37 %description
38 The mission of the Apache Portable Runtime (APR) project is to create
39 and maintain software libraries that provide a predictable and
40 consistent interface to underlying platform-specific implementations.
41 The primary goal is to provide an API to which software developers may
42 code and be assured of predictable if not identical behaviour
43 regardless of the platform on which their software is built, relieving
44 them of the need to code special-case conditions to work around or
45 take advantage of platform-specific deficiencies or features.
46
47 %description -l pl
48 Celem projektu APR (Apache Portable Runtime) jest stworzenie i
49 utrzymywanie bibliotek dostarczaj±cych przewidywalnego i spójnego
50 interfejsu do le¿±cych u podstaw implementacji zale¿nych od platformy.
51 G³ównym celem jest dostarczenie API, którego mog± u¿ywaæ programi¶ci
52 maj±c pewno¶æ, ¿e zachowuje siê w sposób przewidywalny, je¶li nie
53 identyczny, niezale¿nie od platformy na jakiej oprogramowanie jest
54 budowane oraz bez potrzeby kodowania specjalnych warunków do
55 obchodzenia lub wykorzystywania specyficznych dla platform ró¿nic lub
56 mo¿liwo¶ci.
57
58 %package devel
59 Summary:        Header files and development documentation for apr
60 Summary(pl):    Pliki nag³ówkowe i dokumentacja programisty do apr
61 Group:          Development/Libraries
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63 Requires:       libuuid-devel
64 Requires:       automake
65 Requires:       libtool
66
67 %description devel
68 Header files and development documentation for apr.
69
70 %description devel -l pl
71 Pliki nag³ówkowe i dokumentacja programisty do apr.
72
73 %package static
74 Summary:        Static apr library
75 Summary(pl):    Statyczna biblioteka apr
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
78
79 %description static
80 Static apr library.
81
82 %description static -l pl
83 Statyczna biblioteka apr.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %{!?with_epoll:%patch2 -p1}
90 %patch3 -p1
91
92 %build
93 install /usr/share/automake/config.* build
94 ./buildconf
95 %configure \
96         %{!?with_tcpnodelaycork:apr_cv_tcp_nodelay_with_cork=no} \
97         %{!?with_sendfile64:ac_cv_func_sendfile64=no} \
98         --with-devrandom=/dev/urandom \
99 %ifarch %{ix86} %{i8664}
100 %ifnarch i386
101         --enable-nonportable-atomics \
102 %endif
103 %endif
104         --enable-threads
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
114
115 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
116 install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
117 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
118 ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
119 ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
120 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
121
122 sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
123         $RPM_BUILD_ROOT%{_bindir}/apr-1-config
124 sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
125         $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
126 sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc CHANGES docs/*.html
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/*
142 %attr(755,root,root) %{_libdir}/lib*.so
143 %{_libdir}/lib*.la
144 %{_libdir}/apr.exp
145 %{_includedir}
146 %dir %{_datadir}
147 %dir %{_datadir}/build
148 %{_datadir}/build/*.mk
149 %{_datadir}/build/*.m4
150 %{_datadir}/build/*.awk
151 %attr(755,root,root) %{_datadir}/build/config.*
152 %attr(755,root,root) %{_datadir}/build/*.sh
153 %attr(755,root,root) %{_datadir}/build/libtool
154 %attr(755,root,root) %{_datadir}/build/gen-build.py
155 %{_datadir}/build-1
156 %{_pkgconfigdir}/apr-1.pc
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/lib*.a
This page took 0.070968 seconds and 3 git commands to generate.