]> git.pld-linux.org Git - packages/apr.git/blob - apr.spec
04097c61ab009f3b0e9530861a1189d3f75cc42f
[packages/apr.git] / apr.spec
1 Summary:        Apache Portable Runtime
2 Summary(pl.UTF-8):      Apache Portable Runtime - przenośna biblioteka uruchomieniowa
3 Name:           apr
4 Version:        1.3.3
5 Release:        1
6 Epoch:          1
7 License:        Apache v2.0
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
10 # Source0-md5:  2090c21dee4f0eb1512604127dcd158f
11 Patch0:         %{name}-link.patch
12 Patch1:         %{name}-metuxmpm.patch
13 Patch2:         %{name}-libtool.patch
14 URL:            http://apr.apache.org/
15 BuildRequires:  autoconf >= 2.13
16 BuildRequires:  automake
17 %if "%{pld_release}" != "ac"
18 BuildRequires:  libtool >= 2:2.2
19 %else
20 BuildRequires:  libtool
21 %endif
22 BuildRequires:  libuuid-devel
23 BuildRequires:  python
24 BuildRequires:  rpm >= 4.4.9-56
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  sed >= 4.0
27 %if "%{pld_release}" != "ac"
28 BuildRequires:  uname(release) >= 2.6
29 Requires:       uname(release) >= 2.6
30 %endif
31 Conflicts:      kernel24
32 Conflicts:      kernel24-smp
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _includedir     /usr/include/apr
36 %define         _datadir        /usr/share/apr
37
38 %description
39 The mission of the Apache Portable Runtime (APR) project is to create
40 and maintain software libraries that provide a predictable and
41 consistent interface to underlying platform-specific implementations.
42 The primary goal is to provide an API to which software developers may
43 code and be assured of predictable if not identical behaviour
44 regardless of the platform on which their software is built, relieving
45 them of the need to code special-case conditions to work around or
46 take advantage of platform-specific deficiencies or features.
47
48 %description -l pl.UTF-8
49 Celem projektu APR (Apache Portable Runtime) jest stworzenie i
50 utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
51 interfejsu do leżących u podstaw implementacji zależnych od platformy.
52 Głównym celem jest dostarczenie API, którego mogą używać programiści
53 mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
54 identyczny, niezależnie od platformy na jakiej oprogramowanie jest
55 budowane oraz bez potrzeby kodowania specjalnych warunków do
56 obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
57 możliwości.
58
59 %package devel
60 Summary:        Header files and development documentation for apr
61 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programisty do apr
62 Group:          Development/Libraries
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 Requires:       automake
65 %if "%{pld_release}" != "ac"
66 Requires:       libtool >= 2:2.2
67 %else
68 Requires:       libtool
69 %endif
70 Requires:       libuuid-devel
71 Requires:       python-modules
72
73 %description devel
74 Header files and development documentation for apr.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe i dokumentacja programisty do apr.
78
79 %package static
80 Summary:        Static apr library
81 Summary(pl.UTF-8):      Statyczna biblioteka apr
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
84
85 %description static
86 Static apr library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka apr.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96
97 cat >> config.layout <<'EOF'
98 <Layout PLD>
99 sbindir:        %{_sbindir}
100 libexecdir:     %{_libdir}/apr
101 installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
102 localstatedir:  /var/run
103 runtimedir:     /var/run
104 libsuffix:      -${APR_MAJOR_VERSION}
105 </Layout>
106 EOF
107
108 %build
109 install /usr/share/automake/config.* build
110
111 %configure \
112         --enable-layout=PLD \
113 %ifarch %{ix86} %{i8664}
114 %ifnarch i386
115         --enable-nonportable-atomics \
116 %endif
117 %endif
118         --enable-threads \
119         --with-devrandom=/dev/urandom
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
129 install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
130 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
131 ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
132 ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
133 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
134
135 sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
136         $RPM_BUILD_ROOT%{_bindir}/apr-1-config
137 sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
138         $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
139 sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc CHANGES docs/*.html
150 %attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/apr-1-config
156 %attr(755,root,root) %{_libdir}/libapr-1.so
157 %{_libdir}/libapr-1.la
158 %{_libdir}/apr.exp
159 %{_includedir}
160 %dir %{_datadir}
161 %dir %{_datadir}/build
162 %{_datadir}/build/*.mk
163 %{_datadir}/build/*.m4
164 %{_datadir}/build/*.awk
165 %attr(755,root,root) %{_datadir}/build/config.*
166 %attr(755,root,root) %{_datadir}/build/*.sh
167 %attr(755,root,root) %{_datadir}/build/libtool
168 %attr(755,root,root) %{_datadir}/build/gen-build.py
169 %{_datadir}/build-1
170 %{_pkgconfigdir}/apr-1.pc
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libapr-1.a
This page took 0.075298 seconds and 3 git commands to generate.