]> git.pld-linux.org Git - packages/apinger.git/blob - apinger.spec
- adapterized, pl fix
[packages/apinger.git] / apinger.spec
1 Summary:        Alarm Pinger - network monitor with mail notification
2 Summary(pl):    Alarm Pinger - monitor sieci z powiadamianiem poczt±
3 Name:           apinger
4 Version:        0.1
5 Release:        1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.bnet.pl/~jajcus/%{name}/%{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconf
11 Patch0:         %{name}-user.patch
12 URL:            http://www.bnet.pl/~jajcus/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Alarm Pinger is a little tool which monitors various IP devices by
19 simple ICMP echo requests. There are various other tools, that can do
20 this, but most of them are shell or perl scripts, spawning many
21 processes, thus much CPU-expensive, especially when one wants
22 continuous monitoring and fast response on target failure. Alarm
23 Pinger is a single process written in C, so it doesn't need much CPU
24 power even when monitoring many targets with frequent probes. Alarm
25 Pinger supports both IPv4 and IPv6.
26
27 %description -l pl
28 Alarm Pinger to ma³e narzêdzie monitoruj±ce ró¿ne urz±dzenia IP
29 wykorzystuj±c pakiety ICMP echo request/reply (tzw. ping). S± ró¿ne
30 inne narzêdzia, które to potrafi±, ale wiêkszo¶æ z nich to skrypty
31 shella lub perla uruchamiaj±ce wiele procesów, przez co mocno
32 obci±¿aj±ce maszynê, szczególnie gdy kto¶ chce ci±g³ego monitorowania
33 i szybkiej informacji o awarii. Alarm Pinger to pojedynczy proces
34 napisany w C, wiêc nie wymaga wielkiej mocy obliczeniowej, nawet gdy
35 bada wiele urz±dzeñ czêstymi pingami. Alarm Pinger obs³uguje zarówno
36 IPv4 jak i IPv6.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41
42 %build
43 aclocal
44 autoheader
45 %{__autoconf}
46 %configure 
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
52
53 %{__make} install DESTDIR=$RPM_BUILD_ROOT
54 install src/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
55 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
56 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 /sbin/chkconfig --add apinger
63
64 if [ -f /var/lock/subsys/apinger ]; then
65         /etc/rc.d/init.d/apinger restart 1>&2
66 else
67         echo "Type \"/etc/rc.d/init.d/apinger start\" to start named" 1>&2
68 fi
69
70 %preun
71 if [ "$1" = "0" ]; then
72         if [ -f /var/lock/subsys/apinger ]; then
73                 /etc/rc.d/init.d/apinger stop 1>&2
74         fi
75         /sbin/chkconfig --del apinger
76 fi    
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS NEWS TODO README
81 %attr(755,root,root) %{_sbindir}/*
82 %attr(754,root,root) %config(noreplace) /etc/rc.d/init.d/apinger
83 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/apinger
84 %attr(640,root,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
This page took 0.164066 seconds and 4 git commands to generate.