]> git.pld-linux.org Git - packages/apinger.git/blob - apinger.spec
- use %service
[packages/apinger.git] / apinger.spec
1 Summary:        Alarm Pinger - network monitor with mail notification
2 Summary(pl):    Alarm Pinger - monitor sieci z powiadamianiem poczt±
3 Name:           apinger
4 Version:        0.6.1
5 Release:        3
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.bnet.pl/~jajcus/apinger/%{name}-%{version}.tar.gz
9 # Source0-md5:  3505e6503ec06363613f16713501bb33
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconf
12 Patch0:         %{name}-user.patch
13 URL:            http://www.bnet.pl/~jajcus/
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 Requires(post,preun):   /sbin/chkconfig
16 Requires:       rc-scripts
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Alarm Pinger is a little tool which monitors various IP devices by
21 simple ICMP echo requests. There are various other tools, that can do
22 this, but most of them are shell or Perl scripts, spawning many
23 processes, thus much CPU-expensive, especially when one wants
24 continuous monitoring and fast response on target failure. Alarm
25 Pinger is a single process written in C, so it doesn't need much CPU
26 power even when monitoring many targets with frequent probes. Alarm
27 Pinger supports both IPv4 and IPv6.
28
29 %description -l pl
30 Alarm Pinger to ma³e narzêdzie monitoruj±ce ró¿ne urz±dzenia IP
31 wykorzystuj±c pakiety ICMP echo request/reply (tzw. ping). S± ró¿ne
32 inne narzêdzia, które to potrafi±, ale wiêkszo¶æ z nich to skrypty
33 shella lub Perla uruchamiaj±ce wiele procesów, przez co mocno
34 obci±¿aj±ce maszynê, szczególnie gdy kto¶ chce ci±g³ego monitorowania
35 i szybkiej informacji o awarii. Alarm Pinger to pojedynczy proces
36 napisany w C, wiêc nie wymaga wielkiej mocy obliczeniowej, nawet gdy
37 bada wiele urz±dzeñ czêstymi pingami. Alarm Pinger obs³uguje zarówno
38 IPv4 jak i IPv6.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43
44 %build
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 install src/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
56 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
57 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 /sbin/chkconfig --add apinger
64 %service apinger restart
65
66 %preun
67 if [ "$1" = "0" ]; then
68         %service apinger stop
69         /sbin/chkconfig --del apinger
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS NEWS TODO README doc/FAQ.html
75 %attr(755,root,root) %{_sbindir}/*
76 %attr(754,root,root) %config(noreplace) /etc/rc.d/init.d/apinger
77 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/apinger
78 %attr(640,root,daemon) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
This page took 0.06214 seconds and 3 git commands to generate.