]> git.pld-linux.org Git - packages/apache1-mod_watch.git/blob - apache1-mod_watch.spec
- adapterized (sorted %verify attrs)
[packages/apache1-mod_watch.git] / apache1-mod_watch.spec
1 # TODO
2 # - strange error when accessing "/~watch-info":
3 #   [Thu Feb 10 03:16:16 2005] [warn] " 1\n\b" concurrency counter went negative; resetting to zero
4
5 %bcond_without  ipv6            # disable IPv6 support
6
7 %define         mod_name        watch
8 %define         apxs            /usr/sbin/apxs1
9 Summary:        Apache module: Monitoring Interface for MRTG
10 Summary(pl):    Modu³ do apache: Interfejs do monitorowania za pomoc± MRTG
11 Name:           apache1-mod_%{mod_name}
12 Version:        3.18
13 Release:        3
14 License:        BSD
15 Group:          Networking/Daemons
16 Source0:        http://www.snert.com/Software/download/mod_watch%(echo %{version} | tr -d .).tgz
17 # Source0-md5:  1409df800f24214bed16ca753b9967ff
18 Source1:        %{name}.conf
19 Patch0:         %{name}-PLD-v6stuff.patch
20 URL:            http://www.snert.com/Software/mod_watch/
21 BuildRequires:  %{apxs}
22 #{?with_ipv6:BuildRequires:     apache1(ipv6)-devel}
23 BuildRequires:  apache1-devel >= 1.3.33-2
24 Requires:       apache1 >= 1.3.33-2
25 Obsoletes:      apache-mod_%{mod_name} <= %{version}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
29 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
30
31 %description
32 This module will watch and collect the bytes, requests, and documents
33 in & out per virtual host, file owner, remote-ip address, directory or
34 location, and the web server as a whole. This module was designed for
35 use with MRTG, which will make nice graphical representations of the
36 data, but is general enough that it can be applied to other purposes,
37 as the raw data is accessed by a URL. This module supports
38 mod_vhost_alias and mod_gzip.
39
40 %description -l pl
41 Ten modu³ kontroluje i zbiera informacje na temat ilo¶ci przes³anych
42 bajtów (przychodz±cych i wychodz±cych) wg. serwera wirtualnego,
43 w³a¶ciciela plików, zdalnego adresu ip, katalogu lub lokacji oraz
44 serwera jako ca³o¶ci. Modu³ zosta³ zaprojektowany do pracy z MRTG,
45 dziêki czemu otrzymamy ³adn±, graficzn± reprezentacje danych. Modu³
46 wspiera mod_vhost_alias oraz mod_gzip.
47
48 %prep
49 %setup -q -n mod_%{mod_name}-%{version}
50 %{?with_ipv6:%patch -p0}
51
52 mv mod_watch.html mod_watch_pl.html
53
54 %build
55 %{__make} build-dynamic \
56         APXS=%{apxs}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
61
62 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
63 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
64
65 sed -e 's/<!--#/<!--/g' index.shtml > mod_watch.html
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 if [ -f /var/lock/subsys/apache ]; then
72         /etc/rc.d/init.d/apache restart 1>&2
73 else
74         echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
75 fi
76
77 %postun
78 if [ "$1" = "0" ]; then
79         if [ -f /var/lock/subsys/apache ]; then
80                 /etc/rc.d/init.d/apache restart 1>&2
81         fi
82 fi
83
84 %triggerpostun -- %{name} < 3.18-1.1
85 if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
86         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
87         sed -i -e '
88                 /^Include.*mod_%{mod_name}\.conf/d
89         ' /etc/apache/apache.conf
90 else
91         # they're still using old apache.conf
92         sed -i -e '
93                 s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
94         ' /etc/apache/apache.conf
95 fi
96 if [ -f /var/lock/subsys/apache ]; then
97         /etc/rc.d/init.d/apache restart 1>&2
98 fi
99
100 %files
101 %defattr(644,root,root,755)
102 %doc CHANGES* *.html
103 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
104 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.086382 seconds and 3 git commands to generate.