]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blob - apache1-mod_throttle.spec
- confdir enabled apache1
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
1 %bcond_without  ipv6            # disable IPv6 support
2
3 %define         mod_name        throttle
4 %define         apxs            /usr/sbin/apxs1
5 Summary:        Bandwidth & Request Throttling for Apache
6 Summary(cs):    Omezení sí»ového provozu pro Apache
7 Summary(de):    Ein Modul, das die Bandbreiten- und Anforderungseinschränkung für Apache implementiert
8 Summary(es):    Módulo que implementa la gestión de ancho de banda y peticiones para Apache
9 Summary(fr):    Module qui met en oeuvre la bande passante et l'étranglement requis pour Apache
10 Summary(it):    Modulo che implementa la larghezza di banda e la richiesta di throttling per Apache
11 Summary(ja):    Apache ÍÑÂÓ°èÉý¤ª¤è¤ÓÍ׵᥹¥í¥Ã¥È¥ë¤ò¼ÂÁõ¤¹¤ë¥â¥¸¥å¡¼¥ë
12 Summary(pl):    T³umienie przepustowo¶ci i zapytañ dla Apache'a
13 Summary(pt_BR): Descompressão "On-the-fly" de arquivos HTML para o Apache
14 Summary(sv):    En modul som implementerar bandvidd- och begäranbegränsningar i Apache
15 Name:           apache1-mod_%{mod_name}
16 Version:        3.1.2
17 Release:        1.2
18 License:        BSD-like
19 Group:          Networking/Daemons
20 Source0:        http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
21 # Source0-md5:  6edc45c3ea8a0855d4b0b14cf0f76404
22 Patch0:         apache1-mod_throttle-PLD-v6stuff.patch
23 URL:            http://www.snert.com/Software/mod_throttle/
24 BuildRequires:  %{apxs}
25 BuildRequires:  apache1-devel >= 1.3.33-2
26 %{?with_ipv6:BuildRequires:     apache1(ipv6)-devel}
27 Requires(triggerpostun):        %{apxs}
28 Requires:       apache1 >= 1.3.33-2
29 Obsoletes:      apache-mod_%{mod_name} <= %{version}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
33 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
34
35 %description
36 This Apache module is intended to reduce the load on your server &
37 bandwidth generated by popular virtual hosts, directories, locations,
38 or users according to supported polices (see below) that decide when
39 to delay or refuse requests. Also mod_throttle can track and throttle
40 incoming connections by IP address or by authenticated remote user.
41
42 %description -l cs
43 Balíèek mod_throttle obsahuje modul, který umo¾òuje omezit prùtok dat,
44 která odcházejí z WWW serveru Apache. Limity mohou být nastaveny pro
45 jednotlivé virtuální weby, adresáøe, umístìní nebo autentizované
46 u¾ivatele.
47
48 %description -l de
49 Mod_throttle kann verwendet werden, um die Datenmenge zu beschränken,
50 die Ihr Web-Server behandelt. Diese Einschränkungen können für
51 einzelne virtuelle Rechner, Verzeichnisse, Speicherstellen oder
52 authentifizierte Benutzer eingestellt werden.
53
54 %description -l es
55 Mod_throttle puede usarse para limitar la cantidad de datos que su
56 servidor web va a servir. Estos límites se pueden configurar para
57 hosts virtuales individuales, directorios, lugares o usuarios
58 autenticados.
59
60 %description -l fr
61 Mod_throttle peut être utilisé pour limiter la quantité de données
62 servies par votre serveur Web. Ces limites peuvent être définies pour
63 des hôtes virtuels individuels, répertoires, emplacements ou
64 utilisateurs authentifiés.
65
66 %description -l it
67 Mod_throttle può essere usato per limitare la quantità di dati che il
68 server Web dovrà servire. Queste limitazioni possono essere
69 configurate per singoli host virtuali, directory, indirizzi o utenti
70 autenticati.
71
72 %description -l ja
73 Mod_throttle ¤Ë¤è¤Ã¤Æ Web ¥µ¡¼¥Ð¡¼¤¬½èÍý¤¹¤ë¥Ç¡¼¥¿Î̤òÀ©¸Â¤Ç¤­¤Þ¤¹
74 ¤³¤ì¤é¤ÎÀ©¸Â¤Ï¡¢¸Ä¡¹¤Î²¾ÁÛ¥Û¥¹¥È¡¢¥Ç¥£¥ì¥¯¥È¥ê¡¢¾ì½ê¡¢¤Þ¤¿¤Ï
75 ǧ¾Ú¥æ¡¼¥¶¡¼ÍѤˤĤ¤¤ÆÀßÄê¤Ç¤­¤Þ¤¹¡£
76
77 %description -l pl
78 Ten modu³ Apache ma s³u¿yæ do zmniejszania obci±¿enia serwera i ruchu
79 generowanego przez popularne hosty wirtualne, katalogi, pliki lub
80 u¿ytkowników zgodnie z obs³ugiwanymi polisami, które decyduj± kiedy
81 opó¼niæ lub odrzuciæ zapytanie. mod_throttle mo¿e tak¿e ¶ledziæ i
82 t³umiæ po³±czenia przychodz±ce z danego adresu IP lub danego,
83 autentykuj±cego siê, u¿ytkownika.
84
85 %description -l pt_BR
86 Descompressão "On-the-fly" de arquivos HTML para o Apache.
87
88 %description -l sv
89 Mod_throttle kan användas för att begränsa mängden data som din
90 webbserver skickar. Dessa gränser kan sättas för enskilda virtuella
91 värdar, kataloger, platser eller autenticerade användare.
92
93 %prep
94 %setup -q -n mod_%{mod_name}-%{version}
95 %{?with_ipv6:%patch0 -p1}
96
97 %build
98 %{apxs} -o mod_%{mod_name}.so -c mod_%{mod_name}.c
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
103
104 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
105
106 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
107         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
108
109 sed -e 's/<!--#/<!--/g' index.shtml > mod_%{mod_name}.html
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 if [ -f /var/lock/subsys/apache ]; then
116         /etc/rc.d/init.d/apache restart 1>&2
117 else
118         echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
119 fi
120
121 %preun
122 if [ "$1" = "0" ]; then
123         if [ -f /var/lock/subsys/apache ]; then
124                 /etc/rc.d/init.d/apache restart 1>&2
125         fi
126 fi
127
128 %triggerpostun -- apache1-mod_%{mod_name} < 3.1.2-1.1
129 # check that they're not using old apache.conf
130 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
131         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
132 fi
133
134 %files
135 %defattr(644,root,root,755)
136 %doc *.txt *.html
137 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
138 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.09179 seconds and 4 git commands to generate.