]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blob - apache1-mod_throttle.spec
- es,pt_BR translations moved to proper place (apache-mod_gunzip.spec)
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
1 Summary:        Bandwidth & Request Throttling
2 Summary(pl):    T³umienie przepustowo¶ci i zapytañ
3 Name:           apache-mod_throttle
4 Version:        3.1.2
5 Release:        1
6 License:        Anthony Howe
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
11 URL:            http://www.snert.com/Software/mod_throttle/
12 BuildRequires:  apache-devel
13 Requires:       apache >= 1.3.1
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _libexecdir     %{_libdir}/apache
17 %define         _htmldocdir     /home/httpd/manual/mod
18
19 %description
20 This Apache module is intended to reduce the load on your server &
21 bandwidth generated by popular virtual hosts, directories, locations,
22 or users according to supported polices (see below) that decide when
23 to delay or refuse requests. Also mod_throttle can track and throttle
24 incoming connections by IP address or by authenticated remote user.
25
26 %description -l pl
27 Ten modu³ Apache ma s³u¿yæ do zmniejsszania obci±¿enia serwera i ruchu
28 generowanego przez popularne hosty wirtualne, katalogi, pliki lub
29 u¿ytkowników zgodnie z obs³ugiwanymi polisami, które decyduj± kiedy
30 opó¼niæ lub odrzuciæ zapytanie. mod_throttle mo¿e tak¿e ¶ledziæ i
31 t³umiæ po³±czenia przychodz±ce z danego adresu IP lub danego,
32 autentykuj±cego siê, u¿ytkownika.
33
34 %prep
35 %setup -q -n mod_throttle-%{version}
36
37 %build
38 /usr/sbin/apxs -DSUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_throttle.so -c *.c
39 # to don't bother about ssi counter inside
40 mv -f index.shtml index.html
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
45
46 install mod_throttle.so $RPM_BUILD_ROOT%{_libexecdir}
47 install *.html $RPM_BUILD_ROOT%{_htmldocdir}
48
49 gzip -9nf *.txt
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 %{_sbindir}/apxs -e -a -n throttle %{_libexecdir}/mod_throttle.so 1>&2
56 if [ -f /var/lock/subsys/httpd ]; then
57         /etc/rc.d/init.d/httpd restart 1>&2
58 else
59         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
60 fi
61
62 %preun
63 if [ "$1" = "0" ]; then
64         %{_sbindir}/apxs -e -A -n throttle %{_libexecdir}/mod_throttle.so 1>&2
65         if [ -f /var/lock/subsys/httpd ]; then
66                 /etc/rc.d/init.d/httpd restart 1>&2
67         fi
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc *.gz
73 %doc %{_htmldocdir}/index.html
74 %attr(755,root,root) %{_libexecdir}/*
This page took 0.071947 seconds and 4 git commands to generate.