]> git.pld-linux.org Git - packages/apache1-mod_ssl.git/blob - apache1-mod_ssl.spec
- more %%{__make} macros.
[packages/apache1-mod_ssl.git] / apache1-mod_ssl.spec
1 %define         SSLVER 2.6.4
2 %define         APACHEVER 1.3.12
3 Summary:        An SSL module for the Apache Web server
4 Summary(de):    SSL-Modul fuer den Apache-Webserver
5 Summary(fr):    Un module SSL pour le serveur Web Apache
6 Summary(pl):    Modu³ SSL dla webserwera Apache
7 Name:           apache-mod_ssl
8 Version:        %{SSLVER}_%{APACHEVER}
9 Release:        1
10 Group:          Networking/Daemons
11 Group(pl):      Sieciowe/Serwery
12 License:        BSD
13 Source0:        http://www.modssl.org/source/mod_ssl-%{SSLVER}-%{APACHEVER}.tar.gz
14 Source1:        apache-mod_ssl.conf
15 Source2:        apache-mod_ssl-server.crt
16 Source3:        apache-mod_ssl-server.key
17 Source4:        apache-mod_ssl-sxnet.html
18 URL:            http://www.modssl.org/
19 BuildRequires:  apache(EAPI)-devel = %{APACHEVER}
20 BuildRequires:  openssl-devel
21 Requires:       apache(EAPI) = %{APACHEVER}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
25
26 %description
27 The mod_ssl project provides strong cryptography for the Apache 1.3
28 webserver via the Secure Sockets Layer (SSL v2/v3) and Transport Layer
29 Security (TLS v1) protocols by the help of the Open Source SSL/TLS
30 toolkit OpenSSL, which is based on SSLeay from Eric A. Young and Tim
31 J. Hudson.
32
33 The mod_ssl package was created in April 1998 by Ralf S. Engelschall
34 and was originally derived from software developed by Ben Laurie for
35 use in the Apache-SSL HTTP server project. The mod_ssl package is
36 licensed under a BSD-style licence, which basically means that you are
37 free to get and use it for commercial and non-commercial purposes.
38
39 %description -l de
40 Das mod_ssl-Projekt stellt kryptographie für den Apache 1.3-Webserver
41 über Secure Sockets Layer (SSL v2/v3) und Transport Layer Security
42 (TLS v1)-Protokolle zur Verfügung. Dazu wird das Open Source
43 SSL/TLS-Toolkit OpenSSL, das auf SSLeay basiert, verwendet.
44
45 %description -l fr
46 Le projet mod_ssl fournit de la forte cryptographie pour le serveur
47 web Apache 1.3 via les protocoles Secure Sockets Layer (SSL v2/v3) et
48 Transport Layer Security (TLS v1) avec l'aide du kit d'outils Open
49 Source SSL/TLS, OpenSSL, base sur SSLeay d'Eric A. Young et Tim J.
50 Hudson.
51
52 %description -l pl
53 Projekt mod_ssl ma za zadanie zapewniæ serwerowi www Apache 1.3 wysoki
54 poziom szyfrowania dziêki protoko³om Secure Sockets Layer (SSL v2/v3)
55 i Transport Layer Security (TLS v1) przy pomocy pakiety narzêdziowego
56 Open Source SSL/TSL -- OpenSSL, stworzonego na podstawie SSLeay Erica
57 A.Younga i Tima J.Hudsona.
58
59 %package -n apache-mod_sxnet
60 Summary:        Strong Extranet module for mod_ssl and apache
61 Summary(fr):    Module d'Extranet Fort pour Apache et mod_ssl
62 Summary(pl):    Modu³ Strong Extranet dla pakietu mod_ssl i webserwera Apache
63 Group:          Networking/Daemons
64 Group(pl):      Sieciowe/Serwery
65 Requires:       apache = %{APACHEVER}
66
67 %description -n apache-mod_sxnet
68 The Strong Extranet allows you to use digital certificates to
69 authenticate users on your web server. Typically, your users enroll in
70 your Strong Extranet, under your control, through the Thawte Personal
71 Cert System.
72
73 %description -l fr -n apache-mod_sxnet
74 L'Extranet Fort vous permet d'utiliser des certificats numeriques pour
75 authentifier les usagers sur votre serveur web. Typiquement, vos
76 usagers s'enrolent dans votre Extranet Fort, sous votre controle, a
77 travers le Thawte Personal Cert System.
78
79 %description -l pl -n apache-mod_sxnet
80 Pakiet Strong Extranet umo¿liwia u¿ywanie cyfrowych certyfikatów dla
81 uwierzytleniania u¿ytkowników serwera www. Zwykle u¿ytkownicy
82 rejestruj± siê pod opiek± administratora poprzez Thawte Personal Cert
83 System.
84
85 %prep
86 %setup -q -n mod_ssl-%{SSLVER}-%{APACHEVER}
87
88 %build
89 SSL_BASE=SYSTEM
90 LDFLAGs="-s"
91 export SSL_BASE LDFLAGS
92 %configure \
93         --with-apxs=%{_sbindir}/apxs \
94         --enable-shared=ssl \
95         --with-ssl=%{_prefix}
96 %{__make}
97
98 cd pkg.contrib
99 tar xvf sxnet.tar
100 cd sxnet
101 /usr/sbin/apxs -I%{_includedir}/openssl/ -L%{_libdir} -l ssl -l crypto -c mod_sxnet.c
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_libdir}/mod_ssl,%{_pkglibdir}} \
106         $RPM_BUILD_ROOT%{_sysconfdir}/httpd \
107         $RPM_BUILD_ROOT/home/httpd/html/docs
108
109 install pkg.sslmod/libssl.so $RPM_BUILD_ROOT%{_pkglibdir}
110 install pkg.contrib/sxnet/mod_sxnet.so $RPM_BUILD_ROOT%{_pkglibdir}
111
112 install pkg.contrib/*.sh $RPM_BUILD_ROOT%{_libdir}/mod_ssl
113 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/mod_ssl.conf
114 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/server.crt
115 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/server.key
116
117 mv pkg.ssldoc ssl-doc
118 ln -sf %{_docdir}/%{name}-%{version}/ssl-doc \
119         $RPM_BUILD_ROOT/home/httpd/html/docs/ssl-doc
120
121 install %{SOURCE4} sxnet.html
122 ln -sf %{_docdir}/%{name}-%{version}/sxnet.html \
123         $RPM_BUILD_ROOT/home/httpd/html/docs/sxnet.html
124
125 strip --strip-unneeded $RPM_BUILD_ROOT%{_pkglibdir}/*.so
126
127 gzip -9nf ANNOUNCE CHANGES CREDITS NEWS README*
128
129 %post
130 if [ -f %{_sysconfdir}/httpd/httpd.conf ] && \
131    ! grep -q "^Include.*/mod_ssl.conf" %{_sysconfdir}/httpd/httpd.conf; then
132         echo "Include /etc/httpd/mod_ssl.conf" >> %{_sysconfdir}/httpd/httpd.conf
133 fi
134 if [ -f /var/lock/subsys/httpd ]; then
135         /etc/rc.d/init.d/httpd restart 1>&2
136 else
137         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
138 fi
139
140 %postun
141 grep -E -v "^Include.*mod_ssl.conf" /etc/httpd/httpd.conf > \
142         /etc/httpd/httpd.conf.tmp
143 mv /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
144 if [ -f /var/lock/subsys/httpd ]; then
145         /etc/rc.d/init.d/httpd restart 1>&2
146 fi
147
148 %files
149 %defattr(644,root,root,755)
150 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/mod_ssl.conf
151 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/server.crt
152 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/server.key
153 %doc *.gz
154 %doc ssl-doc
155 %doc /home/httpd/html/docs/ssl-doc
156
157 %attr(755,root,root) %{_pkglibdir}/libssl.so
158
159 %{_libdir}/mod_ssl/*.sh
160
161 %files -n apache-mod_sxnet
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_pkglibdir}/mod_sxnet.so
164 %doc sxnet.html
165 %doc /home/httpd/html/docs/sxnet.html
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
This page took 0.054167 seconds and 4 git commands to generate.