]> git.pld-linux.org Git - packages/apache1-mod_ssl.git/blob - apache1-mod_ssl.spec
9bf241af4315aa15d256769db0c58361e6c6af0f
[packages/apache1-mod_ssl.git] / apache1-mod_ssl.spec
1 %define         SSLVER 2.8.6
2 %define         APACHEVER 1.3.23
3 Summary:        An SSL module for the Apache Web server
4 Summary(de):    SSL-Modul fuer den Apache-Webserver
5 Summary(fr):    Un module SSL pour le serveur Web Apache
6 Summary(pl):    Modu³ SSL dla webserwera Apache
7 Name:           apache-mod_ssl
8 Version:        %{SSLVER}_%{APACHEVER}
9 Release:        1
10 License:        BSD
11 Group:          Networking/Daemons
12 Group(cs):      Sí»ové/Démoni
13 Group(de):      Netzwerkwesen/Server
14 Group(es):      Red/Servidores
15 Group(fr):      Réseau/Serveurs
16 Group(pl):      Sieciowe/Serwery
17 Group(pt):      Rede/Servidores
18 Group(ru):      óÅÔÅ×ÙÅ/äÅÍÏÎÙ
19 Source0:        http://www.modssl.org/source/mod_ssl-%{SSLVER}-%{APACHEVER}.tar.gz
20 Source1:        %{name}.conf
21 Source2:        %{name}-server.crt
22 Source3:        %{name}-server.key
23 Source4:        %{name}-sxnet.html
24 Source5:        %{name}.logrotate
25 Patch1:         mod_ssl-cca-openssl-path.patch
26 Patch2:         mod_ssl-db3.patch
27 URL:            http://www.modssl.org/
28 BuildRequires:  apache(EAPI)-devel = %{APACHEVER}
29 BuildRequires:  openssl-devel >= 0.9.6a
30 BuildRequires:  openssl-tools >= 0.9.6a
31 BuildRequires:  db3-devel
32 BuildRequires:  apache(EAPI)-devel = %{APACHEVER}
33 Requires:       apache(EAPI) >= %{APACHEVER}
34 Provides:       mod_ssl
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36 Obsoletes:      mod_ssl
37
38 %define         _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
39
40 %description
41 The mod_ssl project provides strong cryptography for the Apache 1.3
42 webserver via the Secure Sockets Layer (SSL v2/v3) and Transport Layer
43 Security (TLS v1) protocols by the help of the Open Source SSL/TLS
44 toolkit OpenSSL, which is based on SSLeay from Eric A. Young and Tim
45 J. Hudson.
46
47 The mod_ssl package was created in April 1998 by Ralf S. Engelschall
48 and was originally derived from software developed by Ben Laurie for
49 use in the Apache-SSL HTTP server project. The mod_ssl package is
50 licensed under a BSD-style licence, which basically means that you are
51 free to get and use it for commercial and non-commercial purposes.
52
53 %description -l de
54 Das mod_ssl-Projekt stellt kryptographie für den Apache 1.3-Webserver
55 über Secure Sockets Layer (SSL v2/v3) und Transport Layer Security
56 (TLS v1)-Protokolle zur Verfügung. Dazu wird das Open Source
57 SSL/TLS-Toolkit OpenSSL, das auf SSLeay basiert, verwendet.
58
59 %description -l fr
60 Le projet mod_ssl fournit de la forte cryptographie pour le serveur
61 web Apache 1.3 via les protocoles Secure Sockets Layer (SSL v2/v3) et
62 Transport Layer Security (TLS v1) avec l'aide du kit d'outils Open
63 Source SSL/TLS, OpenSSL, base sur SSLeay d'Eric A. Young et Tim J.
64 Hudson.
65
66 %description -l pl
67 Projekt mod_ssl ma za zadanie zapewniæ serwerowi www Apache 1.3 wysoki
68 poziom szyfrowania dziêki protoko³om Secure Sockets Layer (SSL v2/v3)
69 i Transport Layer Security (TLS v1) przy pomocy pakiety narzêdziowego
70 Open Source SSL/TSL -- OpenSSL, stworzonego na podstawie SSLeay Erica
71 A.Younga i Tima J.Hudsona.
72
73 %package -n apache-mod_sxnet
74 Summary:        Strong Extranet module for mod_ssl and apache
75 Summary(fr):    Module d'Extranet Fort pour Apache et mod_ssl
76 Summary(pl):    Modu³ Strong Extranet dla pakietu mod_ssl i webserwera Apache
77 Group:          Networking/Daemons
78 Group(cs):      Sí»ové/Démoni
79 Group(de):      Netzwerkwesen/Server
80 Group(es):      Red/Servidores
81 Group(fr):      Réseau/Serveurs
82 Group(pl):      Sieciowe/Serwery
83 Group(pt):      Rede/Servidores
84 Group(ru):      óÅÔÅ×ÙÅ/äÅÍÏÎÙ
85 Requires:       apache(EAPI) >= %{APACHEVER}
86
87 %description -n apache-mod_sxnet
88 The Strong Extranet allows you to use digital certificates to
89 authenticate users on your web server. Typically, your users enroll in
90 your Strong Extranet, under your control, through the Thawte Personal
91 Cert System.
92
93 %description -l fr -n apache-mod_sxnet
94 L'Extranet Fort vous permet d'utiliser des certificats numeriques pour
95 authentifier les usagers sur votre serveur web. Typiquement, vos
96 usagers s'enrolent dans votre Extranet Fort, sous votre controle, a
97 travers le Thawte Personal Cert System.
98
99 %description -l pl -n apache-mod_sxnet
100 Pakiet Strong Extranet umo¿liwia u¿ywanie cyfrowych certyfikatów dla
101 uwierzytleniania u¿ytkowników serwera www. Zwykle u¿ytkownicy
102 rejestruj± siê pod opiek± administratora poprzez Thawte Personal Cert
103 System.
104
105 %prep
106 %setup -q -n mod_ssl-%{SSLVER}-%{APACHEVER}
107 %patch1 -p1
108 %patch2 -p1
109
110 %build
111 SSL_BASE=SYSTEM
112 export SSL_BASE 
113 %configure \
114         --with-apxs=%{_sbindir}/apxs \
115         --enable-shared=ssl \
116         --with-ssl=%{_prefix}
117 %{__make}
118
119 cd pkg.contrib
120 tar xvf sxnet.tar
121 cd sxnet
122 /usr/sbin/apxs -I%{_includedir}/openssl/ -L%{_libdir} -l ssl -l crypto -c mod_sxnet.c
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{_libdir}/mod_ssl,%{_pkglibdir}} \
127         $RPM_BUILD_ROOT%{_sysconfdir}/httpd \
128         $RPM_BUILD_ROOT/etc/logrotate.d
129
130 install pkg.sslmod/libssl.so $RPM_BUILD_ROOT%{_pkglibdir}
131 install pkg.contrib/sxnet/mod_sxnet.so $RPM_BUILD_ROOT%{_pkglibdir}
132
133 install pkg.contrib/*.sh $RPM_BUILD_ROOT%{_libdir}/mod_ssl
134 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/mod_ssl.conf
135 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/server.crt
136 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/server.key
137 install %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_ssl
138
139 mv -f pkg.ssldoc ssl-doc
140
141 install %{SOURCE4} sxnet.html
142
143 gzip -9nf ANNOUNCE CHANGES CREDITS NEWS README*
144
145 %post
146 if [ -f %{_sysconfdir}/httpd/httpd.conf ] && \
147    ! grep -q "^Include.*/mod_ssl.conf" %{_sysconfdir}/httpd/httpd.conf; then
148         echo "Include /etc/httpd/mod_ssl.conf" >> %{_sysconfdir}/httpd/httpd.conf
149 fi
150 if [ -f /var/lock/subsys/httpd ]; then
151         /etc/rc.d/init.d/httpd restart 1>&2
152 else
153         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
154 fi
155
156 %preun
157 if [ "$1" = "0" ]; then
158         grep -E -v "^Include.*mod_ssl.conf" %{_sysconfdir}/httpd/httpd.conf > \
159                 %{_sysconfdir}/httpd/httpd.conf.tmp
160         mv -f %{_sysconfdir}/httpd/httpd.conf.tmp %{_sysconfdir}/httpd/httpd.conf
161         if [ -f /var/lock/subsys/httpd ]; then
162                 /etc/rc.d/init.d/httpd restart 1>&2
163         fi
164 fi
165
166 %files
167 %defattr(644,root,root,755)
168 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/mod_ssl.conf
169 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/server.crt
170 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/server.key
171 %attr(640,root,root) %config(noreplace) /etc/logrotate.d/*
172 %doc *.gz
173 %doc ssl-doc
174
175 %attr(755,root,root) %{_pkglibdir}/libssl.so
176
177 %dir %{_libdir}/mod_ssl
178 %attr(755,root,root) %{_libdir}/mod_ssl/*.sh
179
180 %files -n apache-mod_sxnet
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_pkglibdir}/mod_sxnet.so
183 %doc sxnet.html
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
This page took 0.032836 seconds and 3 git commands to generate.