]> git.pld-linux.org Git - packages/apache1-mod_ntlm.git/blob - apache1-mod_ntlm.spec
- obsoletes with constant version
[packages/apache1-mod_ntlm.git] / apache1-mod_ntlm.spec
1 # TODO: review security issues
2 %define         mod_name        ntlm
3 %define         apxs            /usr/sbin/apxs1
4 Summary:        This is the NTLM authentication module for Apache
5 Summary(pl):    Modu³ uwierzytelnienia NTLM dla Apache
6 Name:           apache1-mod_%{mod_name}
7 Version:        0.4
8 Release:        0.3
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  5e9b8d1abf872926d6ff01a05a7deb2a
14 Patch0:         %{name}-security.patch
15 URL:            http://modntlm.sourceforge.net/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache1-devel >= 1.3.33-2
18 Requires:       apache1 >= 1.3.33-2
19 Obsoletes:      apache-mod_%{mod_name} <= 1:0.4
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
24
25 %description
26 This is an authentication module for Apache that allows you to
27 authenticate HTTP clients using samba or windows-like server (using
28 NTLM protocol).
29
30 %description -l pl
31 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
32 uwierzytelnianie klientów HTTP poprzez sambê lub serwer na Windows (z
33 u¿yciem protoko³u NTLM).
34
35 %prep
36 %setup -q -n mod_%{mod_name}-%{version}
37 %patch -p1
38
39 %build
40 %{__make} APXS=%{apxs}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
45
46 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
47
48 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
49         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 if [ -f /var/lock/subsys/apache ]; then
56         /etc/rc.d/init.d/apache restart 1>&2
57 fi
58
59 %postun
60 if [ "$1" = "0" ]; then
61         if [ -f /var/lock/subsys/apache ]; then
62                 /etc/rc.d/init.d/apache restart 1>&2
63         fi
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
69 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.060128 seconds and 3 git commands to generate.