]> git.pld-linux.org Git - packages/apache1-mod_cvs.git/blob - apache1-mod_cvs.spec
- use %service
[packages/apache1-mod_cvs.git] / apache1-mod_cvs.spec
1 %define         mod_name        cvs
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: Automatically updates files in a CVS-based webtree
4 Summary(pl):    Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
5 Name:           apache1-mod_%{mod_name}
6 Version:        0.5
7 Release:        2
8 License:        GPL
9 Group:          Networking/Daemons
10 # working URL: http://www.sub.nu/mod_cvs/src/
11 # (but only separate files here, no tarball)
12 Source0:        ftp://ftp.sub.nu/pub/mod_cvs/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  e2cfe7818337915e6cbaffa45852012f
14 URL:            http://www.sub.nu/mod_cvs/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache1-devel >= 1.3.33-2
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 BuildRequires:  zlib-devel
19 Requires(triggerpostun):        %{apxs}
20 Requires:       apache1 >= 1.3.33-2
21 Obsoletes:      apache-mod_cvs <= %{version}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
26
27 %description
28 Apache module: Automatically updates files in a CVS-based webtree.
29
30 %description -l pl
31 Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS.
32
33 %prep
34 %setup -q -n mod_%{mod_name}-%{version}
35
36 %build
37 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
42
43 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44
45 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
46         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %service -q apache restart
53
54 %postun
55 if [ "$1" = "0" ]; then
56         %service -q apache restart
57 fi
58
59 %triggerpostun -- apache1-mod_%{mod_name} < 0.5-1.1
60 # check that they're not using old apache.conf
61 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
62         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
69 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.06953 seconds and 4 git commands to generate.