]> git.pld-linux.org Git - packages/apache1-mod_cvs.git/blob - apache1-mod_cvs.spec
4eaeb1a4a42e631b0dabd827731141af21560088
[packages/apache1-mod_cvs.git] / apache1-mod_cvs.spec
1 %define         mod_name        cvs
2 Summary:        Apache module: Automatically updates files in a CVS-based webtree
3 Summary(pl):    Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
4 Name:           apache-mod_%{mod_name}
5 Version:        0.4
6 Release:        2
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        ftp://ftp.sub.nu/pub/mod_cvs/mod_%{mod_name}-%{version}.tar.gz
12 URL:            http://www.sub.nu/mod_cvs/
13 BuildRequires:  /usr/sbin/apxs
14 BuildRequires:  apache-devel
15 BuildRequires:  zlib-devel
16 Prereq:         /usr/sbin/apxs
17 Requires:       apache
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
21
22 %description
23 Apache module: Automatically updates files in a CVS-based webtree.
24
25 %description -l pl
26 Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS.
27
28 %prep 
29 %setup -q -n mod_%{mod_name}-%{version}
30
31 %build
32 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_pkglibdir}
37
38 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %post
44 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
45 if [ -f /var/lock/subsys/httpd ]; then
46         /etc/rc.d/init.d/httpd restart 1>&2
47 fi
48
49 %preun
50 if [ "$1" = "0" ]; then
51         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52         if [ -f /var/lock/subsys/httpd ]; then
53                 /etc/rc.d/init.d/httpd restart 1>&2
54         fi
55 fi
56
57 %files
58 %defattr(644,root,root,755)
59 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.070374 seconds and 3 git commands to generate.