]> git.pld-linux.org Git - packages/apache1-mod_auth_samba.git/blob - apache1-mod_auth_samba.spec
- fixed Source0:
[packages/apache1-mod_auth_samba.git] / apache1-mod_auth_samba.spec
1 %define         mod_name        auth_samba
2 %define         apxs    /usr/sbin/apxs
3 Summary:        This is the samba authentication module for Apache
4 Summary(pl):    Modu³ autentykacji samba dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        1.1
7 Release:        5
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/modauthsamba/mod_%{mod_name}-%{version}.tar.gz
11 Patch0:         %{name}-symbol_fix.patch
12 URL:            http://modauthsamba.sourceforge.net/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache(EAPI)-devel
15 BuildRequires:  gdbm-devel
16 BuildRequires:  pam-devel
17 BuildRequires:  pam_smb
18 Prereq:         %{_sbindir}/apxs
19 Requires:       pam_smb
20 Requires:       apache(EAPI)
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24
25 %description
26 This is an authentication module for Apache that allows you to
27 authenticate HTTP clients using user entries in an samba directory.
28
29 %description -l pl
30 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
31 klientów HTTP z u¿yciem wpisów w katalogu samby.
32
33 %prep
34 %setup -q -n mod_%{mod_name}
35 %patch0 -p1
36
37 %build
38 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lgdbm -lcrypt -lpam /lib/security/pam_smb_auth.so
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_pkglibdir}
43
44 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51 if [ -f /var/lock/subsys/httpd ]; then
52         /etc/rc.d/init.d/httpd restart 1>&2
53 fi
54
55 %preun
56 if [ "$1" = "0" ]; then
57         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
58         if [ -f /var/lock/subsys/httpd ]; then
59                 /etc/rc.d/init.d/httpd restart 1>&2
60         fi
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc *.html
66 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.04981 seconds and 4 git commands to generate.