]> git.pld-linux.org Git - packages/apache1-mod_auth_samba.git/blob - apache1-mod_auth_samba.spec
05bba72a5df1979275541a454ff8270ec50028ed
[packages/apache1-mod_auth_samba.git] / apache1-mod_auth_samba.spec
1 %define         mod_name        auth_samba
2 Summary:        This is the samba authentication module for Apache
3 Summary(pl):    Modu³ autentykacji samba dla Apache
4 Name:           apache-mod_%{mod_name}
5 Version:        1.1
6 Release:        3
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        ftp://download.sourceforge.net/pub/sourceforge/modauthsamba/mod_%{mod_name}-%{version}.tar.gz
12 Patch0:         %{name}-symbol_fix.patch
13 URL:            http://modauthsamba.sourceforge.net/
14 BuildRequires:  /usr/sbin/apxs
15 BuildRequires:  apache(EAPI)-devel
16 BuildRequires:  gdbm-devel
17 BuildRequires:  pam-devel
18 BuildRequires:  pam_smb
19 Prereq:         /usr/sbin/apxs
20 Prereq:         pam_smb
21 Requires:       apache(EAPI)
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
25
26 %description
27 This is an authentication module for Apache that allows you to
28 authenticate HTTP clients using user entries in an samba directory.
29
30 %description -l pl
31 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
32 klientów HTTP z u¿yciem wpisów w katalogu samby.
33
34 %prep 
35 %setup -q -n mod_%{mod_name}
36 %patch0 -p1
37
38 %build
39 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lgdbm -lcrypt -lpam /lib/security/pam_smb_auth.so
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_pkglibdir}
44
45 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52 if [ -f /var/lock/subsys/httpd ]; then
53         /etc/rc.d/init.d/httpd restart 1>&2
54 fi
55
56 %preun
57 if [ "$1" = "0" ]; then
58         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
59         if [ -f /var/lock/subsys/httpd ]; then
60                 /etc/rc.d/init.d/httpd restart 1>&2
61         fi
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc *.html
67 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.066938 seconds and 3 git commands to generate.