]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blob - apache1-mod_auth_pgsql.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da.UTF-8):      Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es.UTF-8):      Autenticación vía PostgreSQL para Apache
8 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it.UTF-8):      Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja.UTF-8):      PostgreSQL データベースを使った Apache Web サーバーへの基本認証
11 Summary(nb.UTF-8):      Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl.UTF-8):      Moduł uwierzytelnienia PostgreSQL dla Apache
13 Summary(pt_BR.UTF-8):   Autenticação via PostgreSQL para o Apache
14 Summary(sv.UTF-8):      Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache1-mod_%{mod_name}
16 Version:        0.9.12
17 Release:        4
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  7be403b7487c13cdb023cc526ee2e13a
22 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
23 BuildRequires:  apache1-devel >= 1.3.39
24 BuildRequires:  postgresql-devel >= 7
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires(triggerpostun):        %{apxs}
27 Requires:       apache1(EAPI)
28 Obsoletes:      apache-mod_auth_pgsql <= 0.9.12
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
33
34 %description
35 This is an authentication module for Apache that allows you to
36 authenticate HTTP clients using PostgreSQL RDBMS.
37
38 %description -l cs.UTF-8
39 Balíček mod_auth_pgsql slouží pro omezení přístupu k dokumentům, které
40 poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
41 PostgreSQL.
42
43 %description -l de.UTF-8
44 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
45 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
46 einer Tabelle in einer PostgresQL-Datenbank prüft.
47
48 %description -l es.UTF-8
49 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
50 servidos desde un servidor web verificando datos en una base de datos
51 PostgreSQL.
52
53 %description -l fr.UTF-8
54 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
55 servis par un serveur Web en vérifiant des champs dans une table d'une
56 base de données PostgresQL.
57
58 %description -l it.UTF-8
59 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
60 serviti da un server Web controllando i campi di una tabella in un
61 database PostgresQL.
62
63 %description -l ja.UTF-8
64 Mod_auth_pgsql は、PostgresQL データベースのテーブルの中のフィールドを
65 チェックすることによって、Web サーバーが提供する文書へのアクセスを
66 制限できます。
67
68 %description -l pl.UTF-8
69 To jest moduł uwierzytelnienia dla Apache pozwalający na
70 uwierzytelnianie klientów HTTP z użyciem bazy danych PostgreSQL.
71
72 %description -l pt_BR.UTF-8
73 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
74 PostgreSQL.
75
76 %description -l sv.UTF-8
77 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
78 servade av en webbserver genom att kontrollera data i en
79 PostgreSQL-databas.
80
81 %prep
82 %setup -q -n mod_%{mod_name}-%{version}
83
84 %build
85 %{apxs} \
86         -I%{_includedir}/postgresql \
87         -lpq \
88         -c mod_%{mod_name}.c \
89         -o mod_%{mod_name}.so
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
94
95 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
96
97 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
98         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 %service -q apache restart
105
106 %postun
107 if [ "$1" = "0" ]; then
108         %service -q apache restart
109 fi
110
111 %triggerpostun -- apache1-mod_%{mod_name} < 0.9.12-1.1
112 # check that they're not using old apache.conf
113 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
114         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
115 fi
116
117 %files
118 %defattr(644,root,root,755)
119 %doc *.html
120 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
121 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.156508 seconds and 4 git commands to generate.