]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blob - apache1-mod_auth_mysql.spec
4ff150707a152c1106a247b33a0dda1da0834534
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ uwierzytelnienia MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache1-mod_%{mod_name}
16 Version:        2.20
17 Release:        1.2
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://www.diegonet.com/support/mod_auth_mysql-%{version}.tar.gz
21 # Source0-md5:  3e88c23aabf2089fc753b2631a938f53
22 Patch0:         %{name}-mysql-API.patch
23 URL:            http://www.diegonet.com/support/mod_auth_mysql.shtml
24 BuildRequires:  apache1-devel >= 1.3.33-2
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  mysql-devel
28 BuildRequires:  %{apxs}
29 Requires:       apache1 >= 1.3.33-2
30 Requires:       apache1-mod_auth
31 Obsoletes:      apache-mod_%{mod_name} <= %{version}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
35 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
36
37 %description
38 This is an authentication module for Apache that allows you to
39 authenticate HTTP clients using MySQL RDBMS.
40
41 %description -l cs
42 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
43 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
44 MySQL.
45
46 %description -l de
47 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
48 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
49 einer MySQL-Datenbank prüft.
50
51 %description -l es
52 mod_auth_mysql puede usarse para limitar el acceso a documentos
53 servidos por un servidor web verificando datos en una base de datos
54 MySQL.
55
56 %description -l fr
57 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
58 servis par un serveur Web en vérifiant les données dans une base de
59 données MySQL.
60
61 %description -l it
62 mod_auth_mysql può essere usato per limitare l'accesso a documenti
63 serviti da un server Web controllando i dati in un database MySQL.
64
65 %description -l ja
66 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
67 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
68 ¤¬¤Ç¤­¤Þ¤¹¡£
69
70 %description -l pl
71 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
72 uwierzytelnianie klientów HTTP z u¿yciem bazy danych MySQL.
73
74 %description -l pt_BR
75 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
76 MySQL.
77
78 %description -l sv
79 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
80 servade av en webbserver genom att kontrollera data i en
81 MySQL-databas.
82
83 %prep
84 %setup -q -n mod_%{mod_name}-%{version}
85 %patch0 -p1
86
87 %build
88 %{__aclocal}
89 %{__autoconf}
90 %configure \
91         --with-apxs=%{apxs} \
92         --with-mysql=%{_prefix}
93
94 ln -sf config.h auth_mysql_config.h
95 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
100
101 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
102
103 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
104         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 if [ -f /var/lock/subsys/apache ]; then
111         /etc/rc.d/init.d/apache restart 1>&2
112 fi
113
114 %preun
115 if [ "$1" = "0" ]; then
116         if [ -f /var/lock/subsys/apache ]; then
117                 /etc/rc.d/init.d/apache restart 1>&2
118         fi
119 fi
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README* USAGE
124 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
125 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.060124 seconds and 2 git commands to generate.