]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blob - apache1-mod_auth_mysql.spec
- added md5, rel. 4 to rebuild with new mysql
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ autentykacji MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        2.20a
17 Release:        4
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://web.oyvax.com/src/mod_auth_mysql-%{version}.tar.gz
21 # Source0-md5:  49ca2a43f04939d31512616437f4fbb3
22 URL:            http://www.diegonet.com/support/mod_auth_mysql.shtml
23 BuildRequires:  mysql-devel
24 BuildRequires:  %{apxs}
25 BuildRequires:  apache(EAPI)-devel
26 Requires(post,preun):   %{_sbindir}/apxs
27 Requires:       apache(EAPI)
28 Requires:       apache-mod_auth
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30 Obsoletes:      mod_auth_mysql
31
32 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
33
34 %description
35 This is an authentication module for Apache that allows you to
36 authenticate HTTP clients using mysql RDBMS.
37
38 %description -l cs
39 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
40 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
41 MySQL.
42
43 %description -l de
44 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
45 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
46 einer MySQL-Datenbank prüft.
47
48 %description -l es
49 mod_auth_mysql puede usarse para limitar el acceso a documentos
50 servidos por un servidor web verificando datos en una base de datos
51 MySQL.
52
53 %description -l fr
54 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
55 servis par un serveur Web en vérifiant les données dans une base de
56 données MySQL.
57
58 %description -l it
59 mod_auth_mysql può essere usato per limitare l'accesso a documenti
60 serviti da un server Web controllando i dati in un database MySQL.
61
62 %description -l ja
63 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
64 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
65 ¤¬¤Ç¤­¤Þ¤¹¡£
66
67 %description -l pl
68 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
69 klientów HTTP z u¿yciem bazy danych mysql.
70
71 %description -l pt_BR
72 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
73 MySQL.
74
75 %description -l sv
76 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
77 servade av en webbserver genom att kontrollera data i en
78 MySQL-databas.
79
80 %prep
81 %setup -q -n mod_%{mod_name}-%{version}
82
83 %build
84 aclocal
85 %{__autoconf}
86 %configure \
87         --with-apxs=%{apxs} \
88         --with-mysql=%{_prefix}
89
90 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_pkglibdir}
95
96 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
103 if [ -f /var/lock/subsys/httpd ]; then
104         /etc/rc.d/init.d/httpd restart 1>&2
105 fi
106
107 %preun
108 if [ "$1" = "0" ]; then
109         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
110         if [ -f /var/lock/subsys/httpd ]; then
111                 /etc/rc.d/init.d/httpd restart 1>&2
112         fi
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc README* USAGE
118 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.380785 seconds and 3 git commands to generate.