]> git.pld-linux.org Git - packages/apache-mod_proxy_html.git/blob - apache-mod_proxy_html.spec
cc35b8060b4143c29a63f45f12416abb787df230
[packages/apache-mod_proxy_html.git] / apache-mod_proxy_html.spec
1 %define         mod_name        proxy_html
2 %define         apxs            /usr/sbin/apxs
3 Summary:        mod_proxy_html - additional proxy module for rewriting HTML links
4 Summary(pl):    mod_proxy_html - dodatkowy modu³ proxy do przepisywania odno¶ników HTML
5 Name:           apache-mod_%{mod_name}
6 Version:        2.3
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://apache.webthing.com/mod_proxy_html/mod_proxy_html.c
11 # Source0-md5:  b1211dff5343d75ac376ef836557f11f
12 URL:            http://apache.webthing.com/mod_proxy_html/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.0.44
15 BuildRequires:  apr-devel >= 1:0.9.4-1
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libxml2-devel >= 2.5.10
19 Requires(post,preun):   %{apxs}
20 Requires:       apache >= 2.0.44
21 Requires:       apache-mod_proxy >= 2.0.44
22 Requires:       libxml2 >= 2.5.10
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
27
28 %description
29 mod_proxy_html is additional proxy module for rewriting HTML links so
30 that they don't break in a reverse proxy.
31
32 %description -l pl
33 mod_proxy_html to dodatkowy modu³ proxy do przepisywania odno¶ników
34 HTML w ten sposób, by nie by³y uszkadzane przez odwrotne proxy.
35
36 %prep
37 %setup -q -c -T
38 cp %{SOURCE0} .
39
40 %build
41 %{apxs} \
42         -c -o mod_%{mod_name}.la \
43         $(%{_bindir}/xml2-config --cflags --libs) \
44         mod_%{mod_name}.c
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
49
50 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
51 cat <<EOF > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/35_mod_%{mod_name}.conf
52 LoadModule proxy_html_module    modules/mod_proxy_html.so
53
54 # You will find configuration instructions here:
55 # http://apache.webthing.com/mod_proxy_html/config.html
56 EOF
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 if [ -f /var/lock/subsys/httpd ]; then
63         /etc/rc.d/init.d/httpd restart 1>&2
64 fi
65
66 %preun
67 if [ "$1" = "0" ]; then
68         if [ -f /var/lock/subsys/httpd ]; then
69                 /etc/rc.d/init.d/httpd restart 1>&2
70         fi
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*
76 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.048364 seconds and 3 git commands to generate.