]> git.pld-linux.org Git - packages/apache-mod_perl.git/blob - apache-mod_perl.spec
- release 2: mod_perl-common added to Obsoletes for allow upgrade from MDK.
[packages/apache-mod_perl.git] / apache-mod_perl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A Perl interpreter for the Apache Web server
3 Summary(pl):    Interpreter perla dla serwera WWW Apache
4 Name:           apache-mod_perl
5 Version:        1.26
6 Release:        2
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
12 Patch0:         apache-perl-rh.patch
13 # from ftp://ftp.kddlabs.co.jp/Linux/packages/Kondara/pub/Jirai/
14 Patch1:         mod_perl-v6.patch
15 BuildRequires:  apache(EAPI)-devel
16 BuildRequires:  gdbm-devel
17 BuildRequires:  perl >= 5.6.1
18 BuildRequires:  perl-B-Graph
19 BuildRequires:  perl-BSD-Resource
20 BuildRequires:  perl-Devel-Symdump
21 BuildRequires:  perl-HTML-Parser
22 BuildRequires:  perl-MIME-Base64
23 BuildRequires:  perl-URI
24 BuildRequires:  perl-libwww
25 BuildRequires:  rpm-perlprov >= 3.0.3-16
26 Prereq:         apache(EAPI)
27 Provides:       perl(mod_perl_hooks)
28 Provides:       mod_perl
29 Obsoletes:      mod_perl
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31 Obsoletes:      mod_perl
32 Obsoletes:      mod_perl-common
33
34 %description
35 Mod_perl incorporates a Perl interpreter into the Apache web server,
36 so that the Apache web server can directly execute Perl code. Mod_perl
37 links the Perl runtime library into the Apache web server and provides
38 an object-oriented Perl interface for Apache's C language API. The end
39 result is a quicker CGI script turnaround process, since no external
40 Perl interpreter has to be started.
41
42 %description -l pl
43 Mod_perl jest modu³em, który wyposa¿a serwer Apache w interpreter
44 perla, umo¿liwiaj±c w ten sposób bezpo¶rednie wykonywanie kodu perla
45 przez serwer bez potrzeby anga¿owania zewnêtrznego interpretera, co
46 przyspiesza procesy zwi±zane z uruchamianiem skryptów CGI.
47
48 %prep
49 %setup  -q -n mod_perl-%{version}
50 %patch0 -p1
51 %patch1 -p1
52
53 %build
54 perl Makefile.PL \
55         USE_APXS=1 \
56         WITH_APXS=/usr/sbin/apxs \
57         EVERYTHING=1 \
58         PERL_STACKED_HANDLERS=1
59
60 (cd apaci; ln -s ../src/modules .; chmod +x find_source)
61 %{__make}
62
63 (cd faq; make)
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_libdir}/apache,/home/httpd/manual/mod}
68
69 %{__make} pure_install DESTDIR=$RPM_BUILD_ROOT
70         
71 install apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache
72 install htdocs/manual/mod/mod_perl.html \
73         $RPM_BUILD_ROOT/home/httpd/manual/mod
74
75 gzip -9nf README INSTALL ToDo
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 /usr/sbin/apxs -e -a -n perl %{_libexecdir}/libperl.so 1>&2
82 if [ -f /var/lock/subsys/httpd ]; then
83         /etc/rc.d/init.d/httpd restart 1>&2
84 else
85         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
86 fi
87
88 %preun
89 if [ "$1" = "0" ]; then
90         /usr/sbin/apxs -e -A -n perl %{_libexecdir}/libperl.so 1>&2
91         if [ -f /var/lock/subsys/httpd ]; then
92                 /etc/rc.d/init.d/httpd stop 1>&2
93         fi
94 fi
95
96
97 %files
98 %defattr(644,root,root,755)
99 %doc *.gz faq/*.html apache-modlist.html eg
100 %doc /home/httpd/manual/mod/*html
101
102 %attr(755,root,root) %{_libdir}/apache/*.so
103
104 %{perl_sitearch}/*.pm
105 %{perl_sitearch}/*.PL
106
107 %{perl_sitearch}/Apache/*.pm
108 %{perl_sitearch}/Apache/Constants
109 %{perl_sitearch}/auto/mod_perl
110 %dir %{perl_sitearch}/auto/Apache/Leak
111 %dir %{perl_sitearch}/auto/Apache/Symbol
112
113 %{perl_sitearch}/auto/*/*/*.bs
114 %attr(755,root,root) %{perl_sitearch}/auto/*/*/*.so
115
116 %{_mandir}/man3/[Acm]*
This page took 0.092451 seconds and 3 git commands to generate.