]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- release 0.1: these modules contain security flaws
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 # TODO: review security issues
2 %define         mod_name        ntlm
3 %define         apxs            /usr/sbin/apxs
4 Summary:        This is the NTLM authentication module for Apache
5 Summary(pl):    Modu³ uwierzytelnienia NTLM dla Apache
6 Name:           apache-mod_%{mod_name}
7 Version:        0.1
8 Release:        0.1
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/modntlm/mod_%{mod_name}2-%{version}.tgz
13 # Source0-md5:  8abe4f235af6825f723412e187cac96b
14 #Patch0:                %{name}-security.patch
15 URL:            http://modntlm.sourceforge.net/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel
18 Requires(post,preun):   %{apxs}
19 Requires:       apache
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
23
24 %description
25 This is an authentication module for Apache that allows you to
26 authenticate HTTP clients using samba or windows-like server (using
27 NTLM protocol).
28
29 %description -l pl
30 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
31 uwierzytelnianie klientów HTTP poprzez sambê lub serwer na Windows (z
32 u¿yciem protoko³u NTLM).
33
34 %prep
35 %setup -q -n mod_%{mod_name}2-%{version}
36 #%patch -p1
37
38 %build
39 %{__make} APXS=%{apxs}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_pkglibdir}
44
45 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52 if [ -f /var/lock/subsys/httpd ]; then
53         /etc/rc.d/init.d/httpd restart 1>&2
54 fi
55
56 %preun
57 if [ "$1" = "0" ]; then
58         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
59         if [ -f /var/lock/subsys/httpd ]; then
60                 /etc/rc.d/init.d/httpd restart 1>&2
61         fi
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.060853 seconds and 4 git commands to generate.