]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
- updated Source0 md5
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1 #
2 # TODO:
3 # - figure out how to kill mod-mono-server.exe process
4 #   when apache is restarted
5 #
6 %define         mod_name        mono
7 %define         apxs            /usr/sbin/apxs
8 Summary:        Mono module for Apache 2
9 Summary(pl):    Modu³ Mono dla serwera Apache 2
10 Name:           apache-mod_%{mod_name}
11 Version:        1.0.1
12 Release:        0.9
13 Epoch:          1
14 License:        Apache
15 Group:          Networking/Daemons
16 Source0:        http://mono2.ximian.com/archive/%{version}/%{mod_name}-%{version}.tar.gz
17 # Source0-md5:  e569c5b5a9153dfe10811c17bfefd884
18 # Source0-size: 18245041
19 Patch0:         %{name}-apu-config.patch
20 URL:            http://www.mono-project.com/
21 BuildRequires:  apache-devel >= 2.0
22 BuildRequires:  %{apxs}
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  libtool
26 BuildRequires:  mono-csharp >= 1.0
27 Requires:       xsp
28 Requires:       apache >= 2.0
29 Requires:       mono-csharp >= 1.0
30 Obsoletes:      mod_mono
31 ExcludeArch:    alpha
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _httpdir        /home/services/httpd
35 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
36 %define         _pkglibdir      %(%{apxs} -q SYSCONFDIR)
37
38 %description
39 This is an experimental module that allows you to run ASP.NET pages on
40 Unix with Apache and Mono.
41
42 %description -l pl
43 Ten eksperymentalny modu³ umo¿liwia uruchamianie stron ASP.NET na
44 Uniksie z serwerem Apache i Mono.
45
46 %package -n dotnet-xsp
47 Summary:        Mono ASP.NET Standalone Web Server
48 Summary(pl):    Server HTTP obs³uguj±cy ASP.NET
49 Group:          Networking/Daemons
50 Requires:       %{name} = %{epoch}:%{version}-%{release}
51 Requires:       mono-csharp >= 1.0
52
53 %description -n dotnet-xsp
54 Provides a minimalistic web server which hosts the ASP.NET runtime and
55 can be used to test and debug web applications that use the System.Web
56 facilities in Mono.
57
58 %prep
59 %setup -q -n %{mod_name}-%{version}
60 %patch0 -p1
61
62 %build
63 rm -rf $RPM_BUILD_ROOT
64 # Build Apache Module
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__automake}
69
70 %configure \
71         --with-apxs=%{apxs} \
72         --with-apr-config=%{_bindir}/apr-config \
73         --with-apu-config=%{_bindir}/apu-config
74
75 %{__make} \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # Build Mono DLL
79 %{__make} -C src -f makedll.mak
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd.conf,%{_pkglibdir},%{_mandir}/man8}
84
85 install src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
86 install src/ModMono.dll $RPM_BUILD_ROOT%{_libdir}
87 install man/mod_%{mod_name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
88
89 cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf <<EOF
90 LoadModule mono_module modules/mod_%{mod_name}.so
91 MonoApplications "/asp_net:%{_httpdir}/asp_net"
92 Alias /asp_net "%{_httpdir}/asp_net"
93 <Location /asp_net>
94     SetHandler mono
95 </Location>
96 EOF
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*
104 %doc ChangeLog INSTALL NEWS README
105 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
106 %attr(755,root,root) %{_libdir}/ModMono.dll
107 %{_mandir}/man8/*
This page took 0.077696 seconds and 4 git commands to generate.