]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
- some small changes, inpired by kloczek
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1 %define xsp_version 0.4
2 Summary:        Mono module for Apache 2
3 Summary(pl):    Modu³ Mono dla serwera Apache 2
4 Name:           mod_mono
5 Version:        0.3
6 Release:        2
7 Epoch:          1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://www.apacheworld.org/modmono/%{name}-%{version}.tar.gz
11 # Source0-md5:  c28a82496cf87de3c91450e47a4efcf1
12 Source1:        http://go-mono.com/archive/xsp-%{xsp_version}.tar.gz
13 # Source1-md5:  aacb2d6b0dc3f54382c09be0976f6a7f
14 Source2:        mono.conf
15 URL:            http://www.apacheworld.org/modmono/
16 BuildRequires:  apache-devel >= 2.0
17 BuildRequires:  autoconf
18 BuildRequires:  mono
19 Requires:       apache >= 2.0
20 #Requires:      httpd-mmn = %(cat %{_includedir}/httpd/.mmn)
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         httpdir         /home/services/httpd
24 %define         htmldir         %{httpdir}/html
25 %define         moddir          /usr/lib/apache
26
27 %description
28 This is an experimental module that allows you to run ASP.NET pages on
29 Unix with Apache and Mono.
30
31 %description -l pl
32 Ten eksperymentalny modu³ umo¿liwia uruchamianie stron ASP.NET na
33 Uniksie z serwerem Apache i Mono.
34
35 %prep
36 %setup -q -n %{name}-%{version} -a 1
37
38 %build
39 # Build sample ASP.NET pages from xsp distribution
40 cd xsp-%{xsp_version}
41 %{__make}
42 %{__make} install
43 cd ..
44
45 # Build Apache Module
46 %{__autoconf}
47 %configure \
48         --with-apxs=%{_sbindir}/apxs
49 %{__make}
50
51 # Build Mono DLL
52 %{__make} -C src -f makedll.mak
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/conf.d,%{moddir}} \
57         $RPM_BUILD_ROOT%{htmldir}/{mono,.wapi}
58
59 cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
60 install src/.libs/libmod_mono.so $RPM_BUILD_ROOT%{moddir}
61 install src/ModMono.dll $RPM_BUILD_ROOT%{_libdir}
62 cp -r xsp-%{xsp_version}/server/test/* $RPM_BUILD_ROOT%{htmldir}/mono
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog INSTALL NEWS README
70 %attr(755,root,root) %{moddir}/libmod_mono.so
71 %{_libdir}/ModMono.dll
72 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/conf.d/mono.conf
73 # FIXME
74 %defattr(-,http,http)
75 %{htmldir}/mono
76 %{httpdir}/.wapi
This page took 0.068309 seconds and 4 git commands to generate.