]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
- massive attack: adding Source-md5
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1 %define pkg_version 0.3
2 %define xsp_version 0.3
3 Summary:        Mono module for Apache 2
4 Summary(pl):    Modu³ Mono dla serwera Apache 2
5 Name:           mod_mono
6 Version:        0.3.6
7 Release:        1
8 License:        The Apache License
9 Group:          Networking/Daemons
10 Source0:        http://www.apacheworld.org/modmono/%{name}-%{pkg_version}.tar.gz
11 # Source0-md5:  c28a82496cf87de3c91450e47a4efcf1
12 Source1:        xsp-%{xsp_version}.tar.gz
13 Source2:        mono.conf
14 BuildRequires:  autoconf
15 BuildRequires:  apache-devel
16 BuildRequires:  mono
17 Requires:       apache
18 #Requires:      httpd-mmn = %(cat %{_includedir}/httpd/.mmn)
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         httpdir         /home/services/httpd
22 %define         htmldir         %{httpdir}/html
23 %define         moddir          /usr/lib/apache
24
25 %description
26 This module allows you to run ASP.NET pages on Unix with Apache and
27 Mono.
28
29 %description -l pl
30 Ten modu³ umo¿liwia uruchamianie stron ASP.NET na Uniksie z serwerem
31 Apache i Mono.
32
33 %prep
34 %setup -q -n %{name}-%{pkg_version} -a 1
35
36 %build
37 # Build sample ASP.NET pages from xsp distribution
38 cd xsp-%{xsp_version}
39 %{__make}
40 %{__make} install
41 cd ..
42
43 # Build Apache Module
44 %{__autoconf}
45 %configure \
46         --with-apxs=%{_sbindir}/apxs
47 %{__make}
48
49 # Build Mono DLL
50 %{__make} -C src -f makedll.mak
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
55 install -d $RPM_BUILD_ROOT%{moddir}
56 install -d $RPM_BUILD_ROOT%{htmldir}/mono
57 install -d $RPM_BUILD_ROOT%{httpdir}/.wapi
58
59 cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
60 install src/.libs/libmod_mono.so $RPM_BUILD_ROOT%{moddir}
61 install src/ModMono.dll $RPM_BUILD_ROOT%{_libdir}
62 cp -r xsp-%{xsp_version}/server/test/* $RPM_BUILD_ROOT%{htmldir}/mono
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog COPYING INSTALL NEWS README
70 %attr(755,root,root) %{moddir}/libmod_mono.so
71 %{_libdir}/ModMono.dll
72 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/conf.d/mono.conf
73 # FIXME
74 %defattr(-,http,http)
75 %{htmldir}/mono
76 %{httpdir}/.wapi
This page took 0.049294 seconds and 4 git commands to generate.