]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blob - apache-mod_auth_kerb.spec
- 5.0rc6 (Mariusz Kryński)
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
1 %define         mod_name        auth_kerb
2 %define         apxs    /usr/sbin/apxs
3 Summary:        This is the Kerberos authentication module for Apache
4 Summary(pl):    Modu³ uwierzytelnienia Kerberos dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        5.0
7 %define pre rc6
8 Release:        0.%{pre}.1
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}-%{pre}.tar.gz
13 # Source0-md5:  274edfb950af20ce6ef0ddcb7c20263a
14 Source1:        %{name}.conf
15 Patch1:         %{name}-aprfix.patch
16 URL:            http://modauthkerb.sourceforge.net/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel
19 BuildRequires:  gdbm-devel
20 BuildRequires:  heimdal-devel
21 Requires(post,preun):   %{apxs}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
25
26 %description
27 This is an authentication module for Apache that allows you to
28 authenticate HTTP clients using user entries in an Kerberos directory.
29
30 %description -l pl
31 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
32 uwierzytelnianie klientów HTTP z u¿yciem wpisów w katalogu Kerberosa.
33
34 %prep
35 %setup -q -n mod_%{mod_name}-%{version}-%{pre}
36 %patch1 -p1
37
38 %build
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd/httpd.conf}
45
46 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
47 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/20_%{mod_name}.conf
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 if [ -f /var/lock/subsys/httpd ]; then
54         /etc/rc.d/init.d/httpd restart 1>&2
55 fi
56
57 %preun
58 if [ "$1" = "0" ]; then
59         if [ -f /var/lock/subsys/httpd ]; then
60                 /etc/rc.d/init.d/httpd restart 1>&2
61         fi
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %attr(755,root,root) %{_pkglibdir}/*
68 %{_sysconfdir}/httpd/httpd.conf/20_%{mod_name}.conf
This page took 0.095579 seconds and 4 git commands to generate.