]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
- openssl support is gone, enable gnutls by default
[packages/anubis.git] / anubis.spec
1 #
2 # Conditional build:
3 %bcond_without  gnutls          # TLS support using GnuTLS library
4 %bcond_without  gpgme           # signing/encrypting with gnupg using gpgme library
5 %bcond_without  pam             # PAM authentication
6 %bcond_without  pcre            # PCRE library support
7 %bcond_without  tcp_wrappers    # tcp_wrappers for access control
8 %bcond_with     mysql           # MySQL support
9 %bcond_with     pgsql           # PostgreSQL support
10 #
11 Summary:        An outgoing mail processor, and the SMTP tunnel
12 Summary(pl.UTF-8):      Procesor wychodzącej poczty i tunel SMTP
13 Name:           anubis
14 Version:        4.3
15 Release:        1
16 License:        GPL v3+
17 Group:          Applications/Mail
18 Source0:        https://ftp.gnu.org/gnu/anubis/%{name}-%{version}.tar.bz2
19 # Source0-md5:  32dc9adf1d0daa54bff70f10b4e289b5
20 Source1:        %{name}.init
21 Source2:        %{name}.pamd
22 Patch0:         %{name}-info.patch
23 Patch1:         %{name}-nolibnsl.patch
24 Patch2:         %{name}-pl.po-update.patch
25 URL:            http://www.gnu.org/software/anubis/
26 BuildRequires:  autoconf >= 2.64
27 BuildRequires:  automake >= 1:1.16
28 BuildRequires:  bison
29 BuildRequires:  flex
30 BuildRequires:  gdbm-devel
31 BuildRequires:  gettext-tools >= 0.21
32 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
33 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:1.0.0}
34 BuildRequires:  gsasl-devel >= 0.2.3
35 BuildRequires:  guile-devel >= 5:2.2.0
36 BuildRequires:  libgcrypt-devel >= 1.7.0
37 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
38 %{?with_mysql:BuildRequires:    mysql-devel}
39 %{?with_pam:BuildRequires:      pam-devel}
40 BuildRequires:  pcre-devel
41 %{?with_pgsql:BuildRequires:    postgresql-devel}
42 BuildRequires:  rpm-perlprov
43 BuildRequires:  rpmbuild(macros) >= 1.268
44 BuildRequires:  texinfo
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       identserver
47 Requires:       libgcrypt >= 1.7.0
48 Requires:       pam >= 0.77.3
49 Requires:       rc-scripts
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 GNU Anubis is an outgoing mail processor. It goes between the MUA
54 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
55 on the fly various sorts of processing and conversion on the outgoing
56 mail in accord with the sender's specified rules, based on a highly
57 configurable regular expressions system. It operates as a proxy
58 server, independently from mail user agents. GNU Anubis can edit
59 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
60 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
61 using the TLS/SSL encryption even if your mail user agent doesn't
62 support it, or tunnel a connection through a SOCKS proxy. Moreover,
63 GNU Anubis supports the remailers (it allows sending mail in an
64 anonymous way).
65
66 Remember, that to use per-user configuration files ident server has to
67 be running. Without it only system-wide configuration file is used.
68
69 If you want to use GNU Anubis with mutt mail client, install msg2smtp
70 package.
71
72 %description -l pl.UTF-8
73 GNU Anubis zajmuje się przetwarzaniem poczty wychodzącej. Znajduje się
74 on pomiędzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i może
75 wykonywać w locie różne rodzaje przetwarzania i konwersji poczty
76 wychodzącej zależnie od podanych reguł, bazujących na wysoce
77 konfigurowalnym systemie wyrażeń regularnych. GNU Anubis działa jako
78 serwer proxy, niezależnie od programów pocztowych. Potrafi on zmieniać
79 nagłówki listów, szyfrować lub podpisywać jest przy pomocy GNU Privacy
80 Guard, tworzyć bezpieczne tunele SMTP używając szyfrowania TLS/SSL
81 nawet, gdy Twój program pocztowy nie ma takich możliwości. Możliwe
82 jest też tunelowanie połączeń przez SOCKS proxy. Co więcej, GNU Anubis
83 wspiera także remailery (czyli pozawala na anonimowe wysyłanie
84 poczty).
85
86 Pamiętaj, że aby używać plików konfiguracyjnych użytkowników, serwer
87 ident musi być aktywny. Inaczej, użyty będzie tylko główny plik
88 konfiguracyjny.
89
90 Jeśli chcesz używać GNU Anubis z klientem poczty mutt, zainstaluj
91 pakiet msg2smtp.
92
93 %package -n msg2smtp
94 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
95 Summary(pl.UTF-8):      msg2smtp wysyła pocztę przyjmowaną na wejściu do serwera SMTP
96 Group:          Applications/Mail
97
98 %description -n msg2smtp
99 The msg2smtp script is a bridge between MUA programs which use
100 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
101 particularly useful when used in connection with GNU Anubis mail
102 processor.
103
104 %description -n msg2smtp -l pl.UTF-8
105 Skrypt msg2smtp jest pomostem między programami pocztowymi używającymi
106 polecenia "sendmail" do wysyłania listów (np. Mutt), a serwerem smtp.
107 Jest on szczególnie przydatny w połączeniu z procesorem poczty GNU
108 Anubis.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114 %patch2 -p1
115
116 %{__rm} po/stamp-po
117
118 %build
119 %{__gettextize}
120 %{__aclocal} -I m4 -I am -I gint -I doc/imprimatur
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --disable-dependency-tracking \
126         --disable-silent-rules \
127         %{!?with_gnutls:--without-gnutls} \
128         %{!?with_gpgme:--without-gpgme} \
129         %{?with_mysql:--with-mysql} \
130         %{?with_pam:--with-pam} \
131         %{?with_pcre:--with-pcre} \
132         %{?with_pgsql:--with-postgres} \
133         %{?with_tcp_wrappers:--with-tcp-wrappers}
134
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
145 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
146 cp -p ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
147 %{?with_pam:cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
148 cp -pf ./examples/1anubisrc examples/anubisrc
149
150 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
151
152 %find_lang %{name}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 /sbin/chkconfig --add anubis
159 %service anubis restart
160 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
161
162
163 %preun
164 if [ "$1" = "0" ]; then
165         %service anubis stop
166         /sbin/chkconfig --del anubis
167 fi
168
169 %postun -p      /sbin/postshell
170 -/usr/sbin/fix-info-dir -c %{_infodir}
171
172 %files -f %{name}.lang
173 %defattr(644,root,root,755)
174 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc %{?with_pam:examples/pam}
175 %attr(754,root,root) /etc/rc.d/init.d/anubis
176 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/anubisrc
177 %if %{with pam}
178 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/anubis
179 %endif
180 %if %{with gnutls}
181 %attr(755,root,root) %{_bindir}/anubisusr
182 %endif
183 %attr(755,root,root) %{_sbindir}/anubis
184 %attr(755,root,root) %{_sbindir}/anubisadm
185 %{_datadir}/anubis
186 %{_mandir}/man1/anubis.1*
187 %{_infodir}/anubis.info*
188
189 %files -n msg2smtp
190 %defattr(644,root,root,755)
191 %doc contrib/msg2smtp.txt
192 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.143666 seconds and 3 git commands to generate.