]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
- updated files
[packages/anubis.git] / anubis.spec
1 #
2 # Conditional build:
3 %bcond_with     gnutls          # GnuTLS library instead of OpenSSL
4 %bcond_without  gpgme           # signing/encrypting with gnupg using gpgme library
5 %bcond_without  pam             # PAM authentication
6 %bcond_without  pcre            # PCRE library support
7 %bcond_without  tcp_wrappers    # tcp_wrappers for access control
8 %bcond_with     mysql           # MySQL support
9 %bcond_with     pgsql           # PostgreSQL support
10 #
11 Summary:        An outgoing mail processor, and the SMTP tunnel
12 Summary(pl.UTF-8):      Procesor wychodzącej poczty i tunel SMTP
13 Name:           anubis
14 Version:        4.3
15 Release:        1
16 License:        GPL v3+
17 Group:          Applications/Mail
18 Source0:        https://ftp.gnu.org/gnu/anubis/%{name}-%{version}.tar.bz2
19 # Source0-md5:  32dc9adf1d0daa54bff70f10b4e289b5
20 Source1:        %{name}.init
21 Source2:        %{name}.pamd
22 Patch0:         %{name}-info.patch
23 Patch1:         %{name}-nolibnsl.patch
24 Patch2:         %{name}-pl.po-update.patch
25 URL:            http://www.gnu.org/software/anubis/
26 BuildRequires:  autoconf >= 2.64
27 BuildRequires:  automake >= 1:1.16
28 BuildRequires:  bison
29 BuildRequires:  flex
30 BuildRequires:  gdbm-devel
31 BuildRequires:  gettext-tools >= 0.21
32 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
33 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:1.0.0}
34 BuildRequires:  gsasl-devel >= 0.2.3
35 BuildRequires:  guile-devel >= 5:2.2.0
36 BuildRequires:  libgcrypt-devel >= 1.7.0
37 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
38 %{?with_mysql:BuildRequires:    mysql-devel}
39 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
40 %{?with_pam:BuildRequires:      pam-devel}
41 BuildRequires:  pcre-devel
42 %{?with_pgsql:BuildRequires:    postgresql-devel}
43 BuildRequires:  rpm-perlprov
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 BuildRequires:  texinfo
46 Requires(post,preun):   /sbin/chkconfig
47 Requires:       identserver
48 Requires:       libgcrypt >= 1.7.0
49 Requires:       pam >= 0.77.3
50 Requires:       rc-scripts
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 GNU Anubis is an outgoing mail processor. It goes between the MUA
55 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
56 on the fly various sorts of processing and conversion on the outgoing
57 mail in accord with the sender's specified rules, based on a highly
58 configurable regular expressions system. It operates as a proxy
59 server, independently from mail user agents. GNU Anubis can edit
60 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
61 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
62 using the TLS/SSL encryption even if your mail user agent doesn't
63 support it, or tunnel a connection through a SOCKS proxy. Moreover,
64 GNU Anubis supports the remailers (it allows sending mail in an
65 anonymous way).
66
67 Remember, that to use per-user configuration files ident server has to
68 be running. Without it only system-wide configuration file is used.
69
70 If you want to use GNU Anubis with mutt mail client, install msg2smtp
71 package.
72
73 %description -l pl.UTF-8
74 GNU Anubis zajmuje się przetwarzaniem poczty wychodzącej. Znajduje się
75 on pomiędzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i może
76 wykonywać w locie różne rodzaje przetwarzania i konwersji poczty
77 wychodzącej zależnie od podanych reguł, bazujących na wysoce
78 konfigurowalnym systemie wyrażeń regularnych. GNU Anubis działa jako
79 serwer proxy, niezależnie od programów pocztowych. Potrafi on zmieniać
80 nagłówki listów, szyfrować lub podpisywać jest przy pomocy GNU Privacy
81 Guard, tworzyć bezpieczne tunele SMTP używając szyfrowania TLS/SSL
82 nawet, gdy Twój program pocztowy nie ma takich możliwości. Możliwe
83 jest też tunelowanie połączeń przez SOCKS proxy. Co więcej, GNU Anubis
84 wspiera także remailery (czyli pozawala na anonimowe wysyłanie
85 poczty).
86
87 Pamiętaj, że aby używać plików konfiguracyjnych użytkowników, serwer
88 ident musi być aktywny. Inaczej, użyty będzie tylko główny plik
89 konfiguracyjny.
90
91 Jeśli chcesz używać GNU Anubis z klientem poczty mutt, zainstaluj
92 pakiet msg2smtp.
93
94 %package -n msg2smtp
95 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
96 Summary(pl.UTF-8):      msg2smtp wysyła pocztę przyjmowaną na wejściu do serwera SMTP
97 Group:          Applications/Mail
98
99 %description -n msg2smtp
100 The msg2smtp script is a bridge between MUA programs which use
101 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
102 particularly useful when used in connection with GNU Anubis mail
103 processor.
104
105 %description -n msg2smtp -l pl.UTF-8
106 Skrypt msg2smtp jest pomostem między programami pocztowymi używającymi
107 polecenia "sendmail" do wysyłania listów (np. Mutt), a serwerem smtp.
108 Jest on szczególnie przydatny w połączeniu z procesorem poczty GNU
109 Anubis.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %{__rm} po/stamp-po
118
119 %build
120 %{__gettextize}
121 %{__aclocal} -I m4 -I am -I gint -I doc/imprimatur
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         --disable-dependency-tracking \
127         --disable-silent-rules \
128         %{!?with_gnutls:--without-gnutls} \
129         %{!?with_gpgme:--without-gpgme} \
130         %{?with_mysql:--with-mysql} \
131         %{!?with_gnutls:--with-openssl} \
132         %{?with_pam:--with-pam} \
133         %{?with_pcre:--with-pcre} \
134         %{?with_pgsql:--with-postgres} \
135         %{?with_tcp_wrappers:--with-tcp-wrappers}
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
147 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
148 cp -p ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
149 %{?with_pam:cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
150 cp -pf ./examples/1anubisrc examples/anubisrc
151
152 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
153
154 %find_lang %{name}
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post
160 /sbin/chkconfig --add anubis
161 %service anubis restart
162 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
163
164
165 %preun
166 if [ "$1" = "0" ]; then
167         %service anubis stop
168         /sbin/chkconfig --del anubis
169 fi
170
171 %postun -p      /sbin/postshell
172 -/usr/sbin/fix-info-dir -c %{_infodir}
173
174 %files -f %{name}.lang
175 %defattr(644,root,root,755)
176 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc %{?with_pam:examples/pam}
177 %attr(754,root,root) /etc/rc.d/init.d/anubis
178 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/anubisrc
179 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/anubis}
180 %attr(755,root,root) %{_sbindir}/anubis
181 %attr(755,root,root) %{_sbindir}/anubisadm
182 %{_datadir}/anubis
183 %{_mandir}/man1/anubis.1*
184 %{_infodir}/anubis.info*
185
186 %files -n msg2smtp
187 %defattr(644,root,root,755)
188 %doc contrib/msg2smtp.txt
189 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.106324 seconds and 3 git commands to generate.