]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
2b7037b770b27fcaff5444fc6d44d4952958e7e5
[packages/anubis.git] / anubis.spec
1 #
2 # Conditional build:
3 %bcond_with     gnutls          # use GnuTLS library instead of OpenSSL
4 %bcond_without  tcp_wrappers    # disable using tcp_wrappers for access control
5 %bcond_without  pam             # disable using of PAM authentcation
6 %bcond_without  gpgme           # disable using gpgme library for signing/encrypting with gnupg
7 %bcond_without  pcre            # disable using pcre library
8 %bcond_with     mysql
9 %bcond_with     postgres
10 #
11 %include        /usr/lib/rpm/macros.perl
12 Summary:        An outgoing mail processor, and the SMTP tunnel
13 Summary(pl):    Procesor wychodz±cej poczty i tunel SMTP
14 Name:           anubis
15 Version:        3.9.94
16 Release:        0.8
17 License:        GPL
18 Group:          Applications/Mail
19 Source0:        ftp://mirddin.farlep.net/pub/alpha/anubis/%{name}-%{version}.tar.gz
20 # Source0-md5:  1557c499d73265aac1f87c61c5695b50
21 Source1:        %{name}.init
22 Source2:        %{name}.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-configure_gpgme.patch
25 Patch2:         %{name}-boundary.patch
26 Patch3:         %{name}-nolibnsl.patch
27 Patch4:         %{name}-securityfixes.patch
28 URL:            http://www.gnu.org/software/anubis/
29 BuildRequires:  gettext-devel >= 0.12.1
30 BuildRequires:  autoconf >= 2.54
31 BuildRequires:  automake >= 1.7
32 BuildRequires:  bison
33 %{?with_gnutls:BuildRequires:   gnutls-devel}
34 %{?with_gpgme:BuildRequires:    gpgme-devel >= 0.3.12}
35 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
36 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
37 %{?with_postgres:BuildRequires: postgres-devel}
38 %{?with_mysql:BuildRequires:    mysql-devel}
39 BuildRequires:  rpm-perlprov
40 BuildRequires:  texinfo
41 PreReq:         rc-scripts
42 Requires(post,preun):   /sbin/chkconfig
43 Requires:       identserver
44 Requires:       pam >= 0.77.3
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 GNU Anubis is an outgoing mail processor. It goes between the MUA
49 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
50 on the fly various sorts of processing and conversion on the outgoing
51 mail in accord with the sender's specified rules, based on a highly
52 configurable regular expressions system. It operates as a proxy
53 server, independently from mail user agents. GNU Anubis can edit
54 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
55 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
56 using the TLS/SSL encryption even if your mail user agent doesn't
57 support it, or tunnel a connection through a SOCKS proxy. Moreover,
58 GNU Anubis supports the remailers (it allows sending mail in an
59 anonymous way).
60
61 Remember, that to use per-user configuration files ident server has to
62 be running. Without it only system-wide configuration file is used.
63
64 If you want to use GNU Anubis with mutt mail client, install msg2smtp
65 package.
66
67 %description -l pl
68 GNU Anubis zajmuje siê przetwarzaniem poczty wychodz±cej. Znajduje siê
69 on pomiêdzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i mo¿e
70 wykonywaæ w locie ró¿ne rodzaje przetwarzania i konwersji poczty
71 wychodz±cej zale¿nie od podanych regu³, bazuj±cych na wysoce
72 konfigurowalnym systemie wyra¿eñ regularnych. GNU Anubis dzia³a jako
73 serwer proxy, niezale¿nie od programów pocztowych. Potrafi on zmieniaæ
74 nag³ówki listów, szyfrowaæ lub podpisywaæ jest przy pomocy GNU Privacy
75 Guard, tworzyæ bezpieczne tunele SMTP u¿ywaj±c szyfrowania TLS/SSL
76 nawet, gdy Twój program pocztowy nie ma takich mo¿liwo¶ci. Mo¿liwe
77 jest te¿ tunelowanie po³±czeñ przez SOCKS proxy.
78 Co wiêcej, GNU Anubis wspiera tak¿e remailery (czyli pozawala na
79 anonimowe wysy³anie poczty).
80
81 Pamiêtaj, ¿e aby u¿ywaæ plików konfiguracyjnych u¿ytkowników, serwer
82 ident musi byæ aktywny. Inaczej, u¿yty bêdzie tylko g³ówny plik
83 konfiguracyjny.
84
85 Je¶li chcesz u¿ywaæ GNU Anubis z klientem poczty mutt, zainstaluj
86 pakiet msg2smtp.
87
88 %package -n msg2smtp
89 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
90 Summary(pl):    msg2smtp wysy³a pocztê przyjmowan± na wej¶ciu do serwera SMTP
91 Group:          Applications/Mail
92
93 %description -n msg2smtp
94 The msg2smtp script is a bridge between MUA programs which use
95 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
96 particularly useful when used in connection with GNU Anubis mail
97 processor.
98
99 %description -n msg2smtp -l pl
100 Skrypt msg2smtp jest pomostem miêdzy programami pocztowymi u¿ywaj±cymi
101 polecenia "sendmail" do wysy³ania listów (np. Mutt), a serwerem smtp.
102 Jest on szczególnie przydatny w po³±czeniu z procesorem poczty GNU
103 Anubis.
104
105 %prep
106 %setup -q
107 #%patch0 -p1
108 #%patch1 -p1
109 #%patch2 -p1
110 #%patch3 -p1
111 #%patch4 -p1
112
113 %build
114 %{__gettextize}
115 %{__aclocal} -I m4
116 %{__autoconf}
117 %{__automake}
118 %configure \
119 %{!?with_gnutls:        --without-gnutls} \
120 %{!?with_gnutls:        --with-openssl} \
121 %{?with_pam:            --with-pam} \
122 %{?with_pcre:           --with-pcre} \
123 %{!?with_gpgme:         --without-gpgme} \
124 %{?with_mysql:          --with-mysql} \
125 %{?with_postgres:       --with-postgres} \
126 %{?with_tcp_wrappers:   --with-tcp-wrappers} \
127         --disable-dependency-tracking
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
139 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
140 install ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
141 %{?with_pam:install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
142 cp -f ./examples/1anubisrc examples/anubisrc
143
144 %find_lang %{name}
145
146 %clean
147 rm -fr $RPM_BUILD_ROOT
148
149 %post
150 /sbin/chkconfig --add anubis
151 if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
152         /etc/rc.d/init.d/anubis restart >&2
153 else
154         echo "Run \"/etc/rc.d/init.d/anubis start\" to start anubis." >&2
155 fi
156 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
157
158
159 %preun
160 if [ "$1" = "0" ]; then
161         if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
162                 /etc/rc.d/init.d/anubis stop
163         fi
164         /sbin/chkconfig --del anubis
165 fi
166
167 %postun
168 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
169
170 %files -f %{name}.lang
171 %defattr(644,root,root,755)
172 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc
173 %{?with_pam:%doc examples/pam}
174 %attr(754,root,root) /etc/rc.d/init.d/anubis
175 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/anubisrc
176 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/anubis}
177 %attr(755,root,root) %{_sbindir}/anubis
178 %{_mandir}/man1/*
179 %{_infodir}/*info*
180
181 %files -n msg2smtp
182 %defattr(644,root,root,755)
183 %doc contrib/msg2smtp.txt
184 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.085981 seconds and 3 git commands to generate.