]> git.pld-linux.org Git - packages/anonftp.git/blob - anonftp.spec
05b62799481e180da9289f8519990ab338a7b6e6
[packages/anonftp.git] / anonftp.spec
1 Summary:        A program which enables anonymous FTP access.
2 Name:           anonftp
3 Version:        2.8
4 Release:        1
5 License:        GPL
6 Group:          System Environment/Daemons
7 BuildRoot:      /tmp/%{name}-%{version}-root
8 AutoReqProv:    0
9 Requires:       ftpserver
10
11 %description
12 The anonftp package contains the files you need in order to
13 allow anonymous FTP access to your machine. Anonymous FTP access allows
14 anyone to download files from your machine without having a user account. 
15 Anonymous FTP is a popular way of making programs available via the
16 Internet.
17
18 You should install anonftp if you would like to enable anonymous FTP
19 downloads from your machine.
20
21 %prep
22 rm -rf $RPM_BUILD_ROOT
23
24 %install
25 rm -rf $RPM_BUILD_ROOT
26 install -d $RPM_BUILD_ROOT/home/ftp
27 install -d $RPM_BUILD_ROOT/home/ftp/pub
28 install -d $RPM_BUILD_ROOT/home/ftp/etc
29 install -d $RPM_BUILD_ROOT/home/ftp/bin
30 install -d $RPM_BUILD_ROOT/home/ftp/lib
31
32 cat > $RPM_BUILD_ROOT/home/ftp/etc/passwd <<EOF
33 root:*:0:0:::
34 bin:*:1:1:::
35 operator:*:11:0:::
36 ftp:*:14:50:::
37 nobody:*:99:99:::
38 EOF
39
40 cat > $RPM_BUILD_ROOT/home/ftp/etc/group <<EOF
41 root::0:
42 bin::1:
43 daemon::2:
44 sys::3:
45 adm::4:
46 ftp::50:
47 EOF
48
49 install /etc/ld.so.cache $RPM_BUILD_ROOT/home/ftp/etc
50 install /lib/{libc-*.so,ld-*.so,libnss_files-*.so,libnsl-*.so} \
51         $RPM_BUILD_ROOT/home/ftp/lib
52
53 install /bin/{ls,cpio,gzip,tar}                 $RPM_BUILD_ROOT/home/ftp/bin
54 install /bin/ash                                $RPM_BUILD_ROOT/home/ftp/bin/sh
55 install /usr/bin/compress                       $RPM_BUILD_ROOT/home/ftp/bin/compress
56 ln -sf gzip                                     $RPM_BUILD_ROOT/home/ftp/bin/zcat
57
58 strip $RPM_BUILD_ROOT/home/ftp/lib/*
59 strip $RPM_BUILD_ROOT/home/ftp/bin/{ls,cpio,gzip,tar}
60
61 %post 
62 /sbin/ldconfig /home/ftp/lib
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %attr(0444,root,root) %config /home/ftp/etc/passwd
70 %attr(0444,root,root) %config /home/ftp/etc/group
71 %attr(0444,root,root) /home/ftp/etc/ld.so.cache
72 %attr(0755,root,root) %dir /home/ftp
73 %attr(0111,root,root) %dir /home/ftp/bin
74 %attr(0111,root,root) %dir /home/ftp/etc
75 %attr(2755,root,ftp) %dir /home/ftp/pub
76 %attr(0755,root,root) %dir /home/ftp/lib
77 %attr(0111,root,root) /home/ftp/bin/*
78 %attr(0555,root,root) /home/ftp/lib/*
This page took 0.043534 seconds and 2 git commands to generate.