]> git.pld-linux.org Git - packages/amavis-stats.git/blob - amavis-stats.spec
b5b6a98365266deed5cf801b7b553a125c2c7143
[packages/amavis-stats.git] / amavis-stats.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Simple amavisd-new statistics generator
3 Summary(pl):    Prosty generator statystyk dla amavisd-new
4 Name:           amavis-stats
5 Version:        0.1.12
6 Release:        3
7 License:        GPL
8 Group:          Applications/System
9 Source0:        http://rekudos.net/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  b85063b3bb8ecdb03d1b7aebf0c0a6cd
11 Source1:        %{name}.cron
12 Patch0:         %{name}-gzip.patch
13 Patch1:         %{name}-more_ac.patch
14 URL:            http://rekudos.net/amavis-stats/
15 BuildArch:      noarch
16 Provides:       %{name}-%{version}-%{release}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir              /var/lib/%{name}
20 %define         _phpdir                 /usr/share/%{name}
21
22 %description
23 amavis-stats is a simple amavis statistics generator based on rrdtool.
24 It produces graphs from amavisd-new log entries of infections broken
25 down by virus.
26
27 %description -l pl
28 amavis-stats jest prostym generatorem statystyk opartym na rrdtool.
29 Tworzy wykresy zainfekowanych wiadomo¶ci, w rozbiciu na poszczególne
30 wirusy, na podstawie logów amavisd-new.
31
32 %package php
33 Summary:        PHP interface for amavis-stats
34 Summary(pl):    Interfejs PHP dla amavis-stats
35 Group:          Applications/System
36 Requires:       %{name}-%{version}-%{release}
37 Requires:       php-pcre
38
39 %description php
40 PHP interface for amavis-stats.
41
42 %description php -l pl
43 Interfejs PHP dla amavis-stats.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48 %patch1 -p0
49
50 %build
51 %configure
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT/etc/cron.d
57 user=`id -u`
58 group=`id -g`
59
60 %{__make} install \
61         install_prefix=$RPM_BUILD_ROOT \
62         amavis_user=$user \
63         amavis_group=$group \
64         web_user=$user \
65         web_group=$group
66         
67 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amavis-stats
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post php
73 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*/etc/%{name}/apache.conf" /etc/httpd/httpd.conf; then
74         echo "Include /etc/%{name}/apache.conf" >> /etc/httpd/httpd.conf
75 fi
76 if [ -f /var/lock/subsys/httpd ]; then
77         /usr/sbin/apachectl restart 1>&2
78 fi
79
80 %preun php
81 if [ "$1" = "0" ]; then
82         umask 027
83         grep -v "^Include.*/etc/%{name}/apache.conf" /etc/httpd/httpd.conf > \
84                 etc/httpd/httpd.conf.tmp
85         mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
86         if [ -f /var/lock/subsys/httpd ]; then
87                 /usr/sbin/apachectl restart 1>&2
88         fi
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README
94 %attr(755,root,root) %{_sbindir}/amavis-stats
95 %dir %{_pkglibdir}
96 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/cron.d/amavis-stats
97 %{_mandir}/man1/*
98
99 %files php
100 %defattr(644,root,root,755)
101 %dir /etc/%{name}
102 %attr(640,root,root) %config(noreplace) /etc/%{name}/apache.conf
103 %dir %{_phpdir}
104 %dir %attr(755,http,root) %{_phpdir}/img
105 %{_phpdir}/%{name}.php
106 %{_phpdir}/index.php
107 %attr(755,http,http) %dir %{_pkglibdir}/img
This page took 0.096878 seconds and 3 git commands to generate.