]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- 1.4.4
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 #
9 # Conditional builds:
10 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable support for zeroconf
15 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
16 %bcond_without  helix           # disable HelixPlayer engine
17 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable MySQL support
20 %bcond_with     pgsql           # enable PostgreSQL support
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25
26 Summary:        A KDE audio player
27 Summary(pl):    Odtwarzacz audio dla KDE
28 Name:           amarok
29 Version:        1.4.4
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
34 Source0:        http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
35 # Source0-md5:  56a9aec42088c338b81252f8e0651781
36 Patch0:         %{name}-helixplayer-morearchs.patch
37 Patch1:         %{name}-libnjb.patch
38 Patch2:         kde-ac260-lt.patch
39 URL:            http://amarok.kde.org/
40 BuildRequires:  SDL-devel
41 BuildRequires:  alsa-lib-devel
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  dbus-glib-devel
45 BuildRequires:  gettext-devel
46 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
47 BuildRequires:  kdebase-devel
48 %{?with_akode:BuildRequires:    kdemultimedia-akode}
49 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
50 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
51 %{?with_mp3players:BuildRequires:       libifp-devel}
52 %{?with_mp3players:BuildRequires:       libmtp-devel}
53 %{?with_mp3players:BuildRequires:       libnjb-devel}
54 BuildRequires:  libltdl-devel
55 %{?with_pgsql:BuildRequires:            libpqxx-devel}
56 BuildRequires:  libtunepimp-devel >= 0.5.1-6
57 BuildRequires:  libvisual-devel >= 0.4.0
58 BuildRequires:  mpeg4ip-devel
59 %{?with_mysql:BuildRequires:            mysql-devel}
60 BuildRequires:  pcre-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  rpm-pythonprov
63 BuildRequires:  rpmbuild(macros) >= 1.129
64 BuildRequires:  ruby-devel >= 1.8
65 BuildRequires:  sed >= 4.0
66 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
67 BuildRequires:  taglib-devel >= 1.4
68 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
69 %{?with_xmms:BuildRequires:     xmms-devel}
70 Requires(post): /sbin/ldconfig
71 Requires:       %{name}-plugin = %{version}-%{release}
72 Requires:       kdebase-core >= 9:3.1.93
73 Requires:       kdemultimedia-audiocd >= 9:3.1.93
74 Obsoletes:      amarok-arts
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
78 %define         filterout_ld    -Wl,--as-needed
79
80 %description
81 A KDE audio player.
82
83 %description -l pl
84 Odtwarzacz audio dla KDE.
85
86 %package akode
87 Summary:        Plugin akode
88 Summary(pl):    Wtyczka akode
89 Group:          X11/Applications/Multimedia
90 Requires:       %{name} = %{version}-%{release}
91 Provides:       %{name}-plugin = %{version}-%{release}
92
93 %description akode
94 Plugin akode.
95
96 %description akode -l pl
97 Wtyczka akode.
98
99 %package helix
100 Summary:        Helix/Realplayer playback support for amarok
101 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
102 Group:          X11/Applications/Multimedia
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       helix-core
105 Provides:       %{name}-plugin = %{version}-%{release}
106
107 %description helix
108 Helix/Realplayer playback support for amarok.
109
110 %description helix -l pl
111 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
112
113 %package gstreamer
114 Summary:        Plugin gstreamer
115 Summary(pl):    Wtyczka gstreamer
116 Group:          X11/Applications/Multimedia
117 # deps, to get it working:
118 # mp3 decoder:  gstreamer-mad
119 # ogg decoder:  gstreamer-vorbis
120 # audio output driver:  gstreamer-audiosink-alsa
121 # from gstreamer-audio-effects to control volume, etc
122 # needed libs:
123 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
124 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
125 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
126 # gstreamer-musicbrainz for being able to edit id3 tags on files.
127 Requires:       %{name} = %{version}-%{release}
128 Requires:       gstreamer-audio-effects
129 Requires:       gstreamer-audiosink
130 Requires:       gstreamer-mad
131 Requires:       gstreamer-musicbrainz
132 Requires:       gstreamer-vorbis
133 Provides:       %{name}-plugin = %{version}-%{release}
134
135 %description gstreamer
136 Plugin gstreamer.
137
138 %description gstreamer -l pl
139 Wtyczka gstreamer.
140
141 %package xine
142 Summary:        Plugin xine
143 Summary(pl):    Wtyczka xine
144 Group:          X11/Applications/Multimedia
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       xine-plugin-audio
147 Provides:       %{name}-plugin = %{version}-%{release}
148
149 %description xine
150 Plugin xine.
151
152 %description xine -l pl
153 Wtyczka xine.
154
155 %package xmms
156 Summary:        Xmms wrapper
157 Summary(pl):    Wrapper xmms
158 Group:          X11/Applications/Multimedia
159 Requires:       %{name} = %{version}-%{release}
160
161 %description xmms
162 Xmms wrapper.
163
164 %description xmms -l pl
165 Wrapper xmms.
166
167 %package zeroconf
168 Summary:        Zeroconf data
169 Summary(pl):    Dane dla zeroconf
170 Group:          X11/Applications/Multimedia
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       kdenetwork-kdnssd
173 Provides:       %{name}-plugin = %{version}-%{release}
174
175 %description zeroconf
176 Zeroconf data.
177
178 %description zeroconf -l pl
179 Dane dla zeroconf.
180
181 %package scripts
182 Summary:        amaroK scripts
183 Summary(pl):    Skrypty amaroKa
184 Group:          X11/Applications/Multimedia
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       kdebase-kdialog
187 Requires:       python-PyQt
188 Requires:       ruby-modules
189
190 %description scripts
191 amaroK scripts allow you extend amaroK functionality.
192
193 You can learn more about scripts in amaroK from here:
194 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
195
196 %description scripts -l pl
197 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
198
199 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
200 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
201
202 %prep
203 %setup -q
204 %patch0 -p1
205 %patch1 -p1
206 %patch2 -p1
207
208 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
209         amarok/src/amarok.desktop \
210
211 # see kde bug #110909
212 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
213
214 # kill env, call interpreter directly, so rpm automatics could rule
215 %{__sed} -i -e '
216         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
217         1s,#!.*bin/env.*python,#!%{_bindir}/python,
218         1s,#!.*bin/env.*bash,#!/bin/bash,
219 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
220
221 %build
222 cp -f /usr/share/automake/config.sub admin
223 %{__make} -f admin/Makefile.common cvs
224
225 # hack: passing something other than "no" or "yes" to --with-helix allows
226 # us to pass HELIX_LIBS
227 %configure \
228         HELIX_LIBS=%{_libdir}/helixplayer \
229         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
230         --disable-rpath \
231         --with%{!?with_mas:out}-mas \
232         --with%{!?with_xine:out}-xine \
233         --with%{!?with_gstreamer:out}-gstreamer10 \
234         --with%{!?with_akode:out}-akode \
235         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
236         --with%{!?with_nmm:out}-nmm \
237         --with%{!?with_xmms:out}-xmms \
238         --with%{!?with_mp3players:out}-libgpod \
239         --with%{!?with_mp3players:out}-libnjb \
240         --with%{!?with_mp3players:out}-libmtp \
241         --with%{!?with_mp3players:out}-ifp \
242         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
243         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
244         --disable-final \
245         --with-mp4v2 \
246         --with-qt-libraries=%{_libdir} \
247         --with%{!?with_included_sqlite:out}-included-sqlite
248
249 %{__make}
250
251 %install
252 rm -rf $RPM_BUILD_ROOT
253
254 %{__make} install \
255         DESTDIR=$RPM_BUILD_ROOT \
256         kde_htmldir=%{_kdedocdir} \
257         kde_libs_htmldir=%{_kdedocdir}
258
259 # remove bogus dir
260 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
261
262 %find_lang amarok --all-name --with-kde
263
264 %clean
265 rm -rf $RPM_BUILD_ROOT
266
267 %post
268 /sbin/ldconfig
269 if [ "$1" = 1 ]; then
270         echo "Remember to install libvisual-plugins-* packages if you"
271         echo "want to have a visualizations in amaroK."
272 fi
273
274 %postun -p /sbin/ldconfig
275
276 %files -f %{name}.lang
277 %defattr(644,root,root,755)
278 %doc AUTHORS ChangeLog README
279 %attr(755,root,root) %{_bindir}/amarok
280 %attr(755,root,root) %{_bindir}/amarokapp
281 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
282 %attr(755,root,root) %{_bindir}/amarok_libvisual
283 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
284 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
285 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
286 %{_libdir}/kde3/konqsidebar_universalamarok.la
287 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
288 %{_libdir}/kde3/libamarok_generic-mediadevice.la
289 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
290 %{_libdir}/kde3/libamarok_void-engine_plugin.la
291 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
292 %{_libdir}/libamarok.la
293 %{_libdir}/kde3/libamarok_daap-mediadevice.la
294 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
295 %{_libdir}/kde3/libamarok_massstorage-device.la
296 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
297 %{_libdir}/kde3/libamarok_nfs-device.la
298 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
299 %{_libdir}/kde3/libamarok_smb-device.la
300 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
301 %{_libdir}/ruby_lib/http11.rb
302 %{_libdir}/ruby_lib/libhttp11.la
303 %attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
304 %dir %{_datadir}/apps/amarok
305 %dir %{_datadir}/apps/amarok/scripts
306 %{_datadir}/apps/amarok/ruby_lib
307 %{_datadir}/apps/amarok/*.rc
308 %{_datadir}/apps/amarok/data
309 %{_datadir}/apps/amarok/icons
310 %{_datadir}/apps/amarok/images
311 %{_datadir}/apps/amarok/themes
312 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
313 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
314 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
315 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
316 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
317 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
318 %{_datadir}/apps/profiles/amarok.profile.xml
319 %{_datadir}/config/amarokrc
320 %{_datadir}/config.kcfg/amarok.kcfg
321 %{_datadir}/services/amarok_generic-mediadevice.desktop
322 %{_datadir}/services/amarok_void-engine_plugin.desktop
323 %{_datadir}/services/amarok_daap-mediadevice.desktop
324 %{_datadir}/services/amarok_massstorage-device.desktop
325 %{_datadir}/services/amarok_nfs-device.desktop
326 %{_datadir}/services/amarok_smb-device.desktop
327 %{_datadir}/services/amaroklastfm.protocol
328 %{_datadir}/services/amarokitpc.protocol
329 %{_datadir}/services/amarokpcast.protocol
330 %{_datadir}/servicetypes/amarok_codecinstall.desktop
331 %{_datadir}/servicetypes/amarok_plugin.desktop
332 %{_desktopdir}/kde/amarok.desktop
333 %{_iconsdir}/*/*/apps/amarok.*
334 # TODO: move to subpackage
335 %if %{with mp3players}
336 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
337 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
338 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
339 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
340 %{_libdir}/kde3/libamarok_mtp-mediadevice.la
341 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
342 %{_libdir}/kde3/libamarok_njb-mediadevice.la
343 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
344 %{_datadir}/services/amarok_ifp-mediadevice.desktop
345 %{_datadir}/services/amarok_ipod-mediadevice.desktop
346 %{_datadir}/services/amarok_mtp-mediadevice.desktop
347 %{_datadir}/services/amarok_njb-mediadevice.desktop
348 %endif
349
350 %if %{with akode}
351 %files akode
352 %defattr(644,root,root,755)
353 %{_libdir}/kde3/libamarok_aKode-engine.la
354 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
355 %{_datadir}/services/amarok_aKode-engine.desktop
356 %endif
357
358 %if %{with gstreamer}
359 %files gstreamer
360 %defattr(644,root,root,755)
361 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
362 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
363 %{_datadir}/config.kcfg/gstconfig.kcfg
364 %{_datadir}/services/amarok_gst10engine_plugin.desktop
365 %endif
366
367 %if %{with helix}
368 %files helix
369 %defattr(644,root,root,755)
370 %{_libdir}/kde3/libamarok_helixengine_plugin.la
371 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
372 %{_datadir}/config.kcfg/helixconfig.kcfg
373 %{_datadir}/services/amarok_helixengine_plugin.desktop
374 %endif
375
376 %if %{with xine}
377 %files xine
378 %defattr(644,root,root,755)
379 %{_libdir}/kde3/libamarok_xine-engine.la
380 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
381 %{_datadir}/config.kcfg/xinecfg.kcfg
382 %{_datadir}/services/amarok_xine-engine.desktop
383 %endif
384
385 %if %{with xmms}
386 %files xmms
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
389 %endif
390
391 %if 0
392 %if %{with zeroconf}
393 %files zeroconf
394 %defattr(644,root,root,755)
395 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
396 %endif
397 %endif
398
399 %files scripts
400 %defattr(644,root,root,755)
401 %dir %{_datadir}/apps/amarok/scripts/common
402 %{_datadir}/apps/amarok/scripts/common/Publisher.py
403 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
404
405 %dir %{_datadir}/apps/amarok/scripts/templates
406 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
407 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
408 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
409
410 # amarok searches for executable programs for scripts
411 # to figure out which files need to have execute permission, use this
412 # find command:
413 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
414
415 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
416 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
417 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
418
419 %dir %{_datadir}/apps/amarok/scripts/playlist2html
420 %{_datadir}/apps/amarok/scripts/playlist2html/README
421 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
422 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
423 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
424
425 %dir %{_datadir}/apps/amarok/scripts/webcontrol
426 %{_datadir}/apps/amarok/scripts/webcontrol/README
427 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
428 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
429 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
430 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
431 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
432 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
433 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
434 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
435 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
436 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
437 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
438 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
439 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
440 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
441 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
442 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
443 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
444 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
445 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
446
447 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
448 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
449 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
450 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
451 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
452
453 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
454 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
455 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
456 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
457 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
458
459 %dir %{_datadir}/apps/amarok/scripts/score_default
460 %{_datadir}/apps/amarok/scripts/score_default/COPYING
461 %{_datadir}/apps/amarok/scripts/score_default/README
462 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
463 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
464 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
465 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
466 %{_datadir}/apps/amarok/scripts/score_impulsive/README
467 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
468 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
469
470 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
471 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
472
473 %if 0
474 %dir %{_datadir}/apps/amarok/scripts/amarok_live
475 %{_datadir}/apps/amarok/scripts/amarok_live/README
476 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
477 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
478 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
479 %endif
This page took 0.054909 seconds and 4 git commands to generate.