]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- added R: libvisual-plugins
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 %bcond_with     mysql           # enable mysql support
8 #
9
10 %define         _beta   beta3
11 Summary:        A KDE audio player
12 Summary(pl):    Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        1.2.%{_beta}
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Applications/Multimedia
18 Source0:        http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
19 # Source0-md5:  e6379b144cdec4eca0556619a03f294c
20 URL:            http://amarok.kde.org/
21 Buildrequires:  alsa-lib-devel
22 Buildrequires:  arts-qt-devel
23 Buildrequires:  automake
24 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
25 BuildRequires:  kdebase-devel
26 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
27 Buildrequires:  libmusicbrainz-devel
28 Buildrequires:  libvisual-devel >= 0.2.0
29 Buildrequires:  pcre-devel
30 BuildRequires:  rpmbuild(macros) >= 1.129
31 BuildRequires:  sed >= 4.0
32 BuildRequires:  sqlite3-devel
33 BuildRequires:  taglib-devel >= 1.3.1
34 BuildRequires:  unsermake >= 040511
35 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
36 %{?with_xmms:BuildRequires:             xmms-devel}
37 %{?with_mysql:BuildRequires:            mysql-devel}
38 #BuildRequires: kdebindings-kjsembed-devel 
39 Requires:       %{name}-plugin = %{version}-%{release}
40 Requires:       kdebase-core >= 9:3.1.93
41 Requires:       kdemultimedia-audiocd >= 9:3.1.93
42 Requires:       libvisual-plugins >= 0.2.0
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A KDE audio player.
47
48 %description -l pl
49 Odtwarzacz audio dla KDE.
50
51 %package arts
52 Summary:        Plugin arts
53 Summary(pl):    Wtyczka arts
54 Group:          X11/Applications/Multimedia
55 Requires:       %{name} = %{version}-%{release}
56 Provides:       %{name}-plugin = %{version}-%{release}
57
58 %description arts
59 Plugin arts.
60
61 %description arts -l pl
62 Wtyczka arts.
63
64 %package gstreamer
65 Summary:        Plugin gstreamer
66 Summary(pl):    Wtyczka gstreamer
67 Group:          X11/Applications/Multimedia
68 Requires:       %{name} = %{version}-%{release}
69 Provides:       %{name}-plugin = %{version}-%{release}
70
71 %description gstreamer
72 Plugin gstreamer.
73
74 %description gstreamer -l pl
75 Wtyczka gstreamer.
76
77 %package xine
78 Summary:        Plugin xine
79 Summary(pl):    Wtyczka xine
80 Group:          X11/Applications/Multimedia
81 Requires:       %{name} = %{version}-%{release}
82 Provides:       %{name}-plugin = %{version}-%{release}
83
84 %description xine
85 Plugin xine.
86
87 %description xine -l pl
88 Wtyczka xine.
89
90 %prep
91 %setup -q -n %{name}-1.2-%{_beta}
92
93 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
94         amarok/src/amarok.desktop \
95
96 %build
97 cp -f %{_datadir}/automake/config.sub admin
98
99 export UNSERMAKE=%{_datadir}/unsermake/unsermake
100
101 %{__make} -f admin/Makefile.common cvs
102
103 %configure \
104         --disable-rpath \
105         %{!?with_arts:--without-arts} \
106         %{!?with_xine:--without-xine} \
107         %{!?with_gstreamer:--without-gstreamer} \
108         %{?with_mysql:--with-mysql} \
109         --disable-final \
110         --with-qt-libraries=%{_libdir} \
111         --without-included-sqlite
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         kde_htmldir=%{_kdedocdir} \
121         kde_libs_htmldir=%{_kdedocdir}
122
123 # remove bogus dir
124 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
125
126 %find_lang amarok --all-name --with-kde
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog README TODO
134 %attr(755,root,root) %{_bindir}/amarok
135 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
136 %attr(755,root,root) %{_bindir}/amarokapp
137 %attr(755,root,root) %{_bindir}/amarok_libvisual
138 %attr(755,root,root) %{_bindir}/release_amarok
139 %{_libdir}/kde3/libamarok_void-engine_plugin.la
140 %{_libdir}/kde3/konqsidebar_universalamarok.la
141 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
142 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
143 %{_datadir}/apps/amarok
144 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
145 %{_datadir}/config.kcfg/amarok.kcfg
146 %{_datadir}/services/amarok_void-engine_plugin.desktop
147 %{_datadir}/servicetypes/amarok_plugin.desktop
148 %{_desktopdir}/kde/amarok.desktop
149 %{_iconsdir}/*/*/apps/amarok.png
150 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
151 %{_datadir}/config/*
152
153 %if %{with arts}
154 %files arts
155 %defattr(644,root,root,755)
156 %{_libdir}/kde3/libamarok_artsengine_plugin.la
157 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
158 %{_libdir}/libamarokarts.la
159 %attr(755,root,root) %{_libdir}/libamarokarts.so
160 %{_libdir}/mcop/Amarok
161 %{_libdir}/mcop/amarokarts.mcopclass
162 %{_libdir}/mcop/amarokarts.mcoptype
163 %{_datadir}/services/amarok_artsengine_plugin.desktop
164 %endif
165
166 %if %{with gstreamer}
167 %files gstreamer
168 %defattr(644,root,root,755)
169 %{_libdir}/kde3/libamarok_gstengine_plugin.la
170 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
171 %{_datadir}/config.kcfg/gstconfig.kcfg
172 %{_datadir}/services/amarok_gstengine_plugin.desktop
173 %endif
174
175 %if %{with xine}
176 %files xine
177 %defattr(644,root,root,755)
178 %{_libdir}/kde3/libamarok_xine-engine.la
179 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
180 %{_datadir}/services/amarok_xine-engine.desktop
181 %{_datadir}/services/amarok_xineengine_plugin.desktop
182 %endif
This page took 0.042496 seconds and 4 git commands to generate.