]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- updated to 1.3beta2
[packages/amarok.git] / amarok.spec
1 #
2 # TODO:
3 #       * postgresql support alongside mysql
4 #       * NMM, MAS audio backend support
5 #       * make descriptions less useless
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  xine            # disable xine engine
11 %bcond_without  xmms            # disable xmms wrapping
12 %bcond_without  zeroconf        # disbale suport for zeroconf
13 %bcond_with     mysql           # enable mysql support
14 #
15 %define _beta   beta2
16 Summary:        A KDE audio player
17 Summary(pl):    Odtwarzacz audio dla KDE
18 Name:           amarok
19 Version:        1.3
20 Release:        0.%{_beta}.1
21 License:        GPL
22 Group:          X11/Applications/Multimedia
23 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
24 # Source0-md5:  ca7b22074dab6107c61b3b92dadbe26e
25 Patch0:         kde-common-gcc4.patch
26 URL:            http://amarok.kde.org/
27 BuildRequires:  SDL-devel
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  arts-qt-devel
30 BuildRequires:  automake
31 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
32 BuildRequires:  kdebase-devel
33 BuildRequires:  kdemultimedia-akode
34 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
35 BuildRequires:  libltdl-devel
36 BuildRequires:  libmusicbrainz-devel
37 BuildRequires:  libvisual-devel >= 0.2.0
38 BuildRequires:  pcre-devel
39 BuildRequires:  rpmbuild(macros) >= 1.129
40 BuildRequires:  sed >= 4.0
41 BuildRequires:  sqlite3-devel
42 BuildRequires:  taglib-devel >= 1.3.1
43 #BuildRequires: unsermake >= 040511
44 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
45 %{?with_xmms:BuildRequires:             xmms-devel}
46 %{?with_mysql:BuildRequires:            mysql-devel}
47 #BuildRequires: kdebindings-kjsembed-devel
48 Requires:       %{name}-plugin = %{version}-%{release}
49 Requires:       kdebase-core >= 9:3.1.93
50 Requires:       kdemultimedia-audiocd >= 9:3.1.93
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 A KDE audio player.
55
56 %description -l pl
57 Odtwarzacz audio dla KDE.
58
59 %package arts
60 Summary:        Plugin arts
61 Summary(pl):    Wtyczka arts
62 Group:          X11/Applications/Multimedia
63 Requires:       %{name} = %{version}-%{release}
64 Provides:       %{name}-plugin = %{version}-%{release}
65
66 %description arts
67 Plugin arts.
68
69 %description arts -l pl
70 Wtyczka arts.
71
72
73 %package akode
74 Summary:        Plugin akode
75 Summary(pl):    Wtyczka akode
76 Group:          X11/Applications/Multimedia
77 Requires:       %{name} = %{version}-%{release}
78 Provides:       %{name}-plugin = %{version}-%{release}
79
80 %description akode
81 Plugin akode.
82
83 %description akode -l pl
84 Wtyczka akode.
85
86
87 %package gstreamer
88 Summary:        Plugin gstreamer
89 Summary(pl):    Wtyczka gstreamer
90 Group:          X11/Applications/Multimedia
91 # needed libs
92 # at least /usr/lib/gstreamer-0.8/libgstresample.so
93 # probably /usr/lib/gstreamer-0.8/libgstadder.so
94 # and probably /usr/lib/gstreamer-0.8/libgstvolume.so
95 Requires:       gstreamer-audio-effects
96 Requires:       %{name} = %{version}-%{release}
97 Provides:       %{name}-plugin = %{version}-%{release}
98
99 %description gstreamer
100 Plugin gstreamer.
101
102 %description gstreamer -l pl
103 Wtyczka gstreamer.
104
105 %package xine
106 Summary:        Plugin xine
107 Summary(pl):    Wtyczka xine
108 Group:          X11/Applications/Multimedia
109 Requires:       %{name} = %{version}-%{release}
110 Provides:       %{name}-plugin = %{version}-%{release}
111
112 %description xine
113 Plugin xine.
114
115 %description xine -l pl
116 Wtyczka xine.
117
118 %package zeroconf
119 Summary:        Zeroconf data
120 Summary(pl):    Dane dla zeroconf
121 Group:          X11/Applications/Multimedia
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       kdenetwork-kdnssd
124 Provides:       %{name}-plugin = %{version}-%{release}
125
126 %description zeroconf
127 Zeroconf data.
128
129 %description zeroconf -l pl
130 Zeroconf data.
131
132
133 %prep
134 %setup -q -n %{name}-%{version}-%{_beta}
135 %patch0 -p1
136 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
137         amarok/src/amarok.desktop \
138
139 %build
140 cp -f /usr/share/automake/config.sub admin
141
142 #export UNSERMAKE=/usr/share/unsermake/unsermake
143
144 %{__make} -f admin/Makefile.common cvs
145
146 %configure \
147         --disable-rpath \
148         %{!?with_arts:--without-arts} \
149         %{!?with_xine:--without-xine} \
150         %{!?with_gstreamer:--without-gstreamer} \
151         %{?with_mysql:--with-mysql} \
152         --disable-final \
153         --with-qt-libraries=%{_libdir} \
154         --without-included-sqlite
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT \
163         kde_htmldir=%{_kdedocdir} \
164         kde_libs_htmldir=%{_kdedocdir}
165
166 # remove bogus dir
167 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
168
169 #find_lang amarok --all-name --with-kde
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post
175 echo "Remember to install libvisual-plugins-* packages if you"
176 echo "want to have a visualizations in amarok."
177
178 %files
179 %defattr(644,root,root,755)
180 # -f %{name}.lang
181 %defattr(644,root,root,755)
182 %doc AUTHORS ChangeLog README TODO
183 %attr(755,root,root) %{_bindir}/amarok
184 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
185 %attr(755,root,root) %{_bindir}/amarokapp
186 %attr(755,root,root) %{_bindir}/amarok_libvisual
187 #%attr(755,root,root) %{_bindir}/release_amarok
188 %{_libdir}/kde3/konqsidebar_universalamarok.la
189 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
190 %{_libdir}/kde3/libamarok_void-engine_plugin.la
191 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
192 %{_datadir}/apps/amarok
193 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
194 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
195 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
196 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
197 %{_datadir}/apps/profiles/amarok.profile.xml
198 %{_datadir}/config/amarokrc
199 %{_datadir}/config.kcfg/amarok.kcfg
200 %{_datadir}/services/amarok_void-engine_plugin.desktop
201 %{_datadir}/servicetypes/amarok_plugin.desktop
202 %{_desktopdir}/kde/amarok.desktop
203 %{_iconsdir}/*/*/apps/amarok.*
204
205 %if %{with arts}
206 %files arts
207 %defattr(644,root,root,755)
208 %{_libdir}/kde3/libamarok_artsengine_plugin.la
209 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
210 %{_libdir}/libamarokarts.la
211 %attr(755,root,root) %{_libdir}/libamarokarts.so
212 %{_libdir}/mcop/Amarok
213 %{_libdir}/mcop/amarokarts.mcopclass
214 %{_libdir}/mcop/amarokarts.mcoptype
215 %{_datadir}/services/amarok_artsengine_plugin.desktop
216 %endif
217
218 %files akode
219 %defattr(644,root,root,755)
220 %{_libdir}/kde3/libamarok_aKode-engine.la
221 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
222 %{_datadir}/services/amarok_aKode-engine.desktop
223
224 %if %{with gstreamer}
225 %files gstreamer
226 %defattr(644,root,root,755)
227 %{_libdir}/kde3/libamarok_gstengine_plugin.la
228 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
229 %{_datadir}/config.kcfg/gstconfig.kcfg
230 %{_datadir}/services/amarok_gstengine_plugin.desktop
231 %endif
232
233 %if %{with xine}
234 %files xine
235 %defattr(644,root,root,755)
236 %{_libdir}/kde3/libamarok_xine-engine.la
237 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
238 %{_datadir}/services/amarok_xine-engine.desktop
239 #%{_datadir}/services/amarok_xineengine_plugin.desktop
240 %endif
241
242 %if %{with zeroconf}
243 %files zeroconf
244 %defattr(644,root,root,755)
245 %{_datadir}/apps/zeroconf/_shoutcast._tcp
246 %endif
This page took 0.046732 seconds and 4 git commands to generate.