]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- add helix engine, rel.4
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3.5
25 Release:        4
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  faac790ea432a784fa7d1ac6a34ee410
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         %{name}-lyricsurl.patch
32 Patch2:         %{name}-desktop.patch
33 URL:            http://amarok.kde.org/
34 #BuildRequires: kdebindings-kjsembed-devel
35 #BuildRequires: unsermake >= 040511
36 BuildRequires:  SDL-devel
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  arts-qt-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
42 BuildRequires:  kdebase-devel
43 %{?with_akode:BuildRequires:    kdemultimedia-akode}
44 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
45 BuildRequires:  libltdl-devel
46 BuildRequires:  libmusicbrainz-devel
47 BuildRequires:  libvisual-devel >= 0.2.0
48 %{?with_mysql:BuildRequires:            mysql-devel}
49 %{?with_pgsql:BuildRequires:            libpqxx-devel}
50 BuildRequires:  pcre-devel
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.129
53 BuildRequires:  sed >= 4.0
54 %{?with_helix:BuildRequires:helix-core}
55 %{?!with_included_sqlite:BuildRequires: sqlite3-devel}
56 BuildRequires:  taglib-devel >= 1.4
57 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
58 %{?with_xmms:BuildRequires:             xmms-devel}
59 Requires:       %{name}-plugin = %{version}-%{release}
60 Requires:       kdebase-core >= 9:3.1.93
61 Requires:       kdemultimedia-audiocd >= 9:3.1.93
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 A KDE audio player.
66
67 %description -l pl
68 Odtwarzacz audio dla KDE.
69
70 %package arts
71 Summary:        Plugin arts
72 Summary(pl):    Wtyczka arts
73 Group:          X11/Applications/Multimedia
74 Requires:       %{name} = %{version}-%{release}
75 Provides:       %{name}-plugin = %{version}-%{release}
76
77 %description arts
78 Plugin arts.
79
80 %description arts -l pl
81 Wtyczka arts.
82
83 %package akode
84 Summary:        Plugin akode
85 Summary(pl):    Wtyczka akode
86 Group:          X11/Applications/Multimedia
87 Requires:       %{name} = %{version}-%{release}
88 Provides:       %{name}-plugin = %{version}-%{release}
89
90 %description akode
91 Plugin akode.
92
93 %description akode -l pl
94 Wtyczka akode.
95
96 %package helix
97 Summary:        Helix/Realplayer playback support for amarok
98 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
99 Group:          X11/Applications/Multimedia
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       helix-core
102 Provides:       %{name}-plugin = %{version}-%{release}
103
104 %description helix
105 Helix/Realplayer playback support for amarok.
106
107 %description helix -l pl
108 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
109
110
111 %package gstreamer
112 Summary:        Plugin gstreamer
113 Summary(pl):    Wtyczka gstreamer
114 Group:          X11/Applications/Multimedia
115 # deps, to get it working:
116 # mp3 decoder: gstreamer-mad
117 # ogg decoder: gstreamer-vorbis
118 # audio output driver: gstreamer-audiosink-alsa
119 # from gstreamer-audio-effects to control volume, etc
120 # needed libs:
121 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
122 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
123 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
124 # gstreamer-musicbrainz for being able to edit id3 tags on files.
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       gstreamer-audio-effects
127 Requires:       gstreamer-audiosink
128 Requires:       gstreamer-mad
129 Requires:       gstreamer-musicbrainz
130 Requires:       gstreamer-vorbis
131 Provides:       %{name}-plugin = %{version}-%{release}
132
133 %description gstreamer
134 Plugin gstreamer.
135
136 %description gstreamer -l pl
137 Wtyczka gstreamer.
138
139 %package xine
140 Summary:        Plugin xine
141 Summary(pl):    Wtyczka xine
142 Group:          X11/Applications/Multimedia
143 Requires:       %{name} = %{version}-%{release}
144 Requires:       xine-plugin-audio
145 Provides:       %{name}-plugin = %{version}-%{release}
146
147 %description xine
148 Plugin xine.
149
150 %description xine -l pl
151 Wtyczka xine.
152
153 %package zeroconf
154 Summary:        Zeroconf data
155 Summary(pl):    Dane dla zeroconf
156 Group:          X11/Applications/Multimedia
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       kdenetwork-kdnssd
159 Provides:       %{name}-plugin = %{version}-%{release}
160
161 %description zeroconf
162 Zeroconf data.
163
164 %description zeroconf -l pl
165 Dane dla zeroconf.
166
167 %package scripts
168 Summary:        amaroK scripts
169 Summary(pl):    Skrypty amaroKa
170 Group:          X11/Applications/Multimedia
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       kdebase-kdialog
173 Requires:       python-PyQt
174
175 %description scripts
176 amaroK scripts allow you extend amaroK functionality.
177
178 You can learn more about scripts in amaroK from here:
179 <http://amarok.kde.org/wiki/index.php/Scripts>.
180
181 %description scripts -l pl
182 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
183
184 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
185 <http://amarok.kde.org/wiki/index.php/Scripts>.
186
187 %prep
188 %setup -q
189 %patch0 -p1
190 %{?with_altlyrics:%patch1 -p1}
191 %patch2 -p1
192 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
193         amarok/src/amarok.desktop \
194
195 # see kde bug #110909
196 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
197
198 %build
199 cp -f /usr/share/automake/config.sub admin
200
201 #export UNSERMAKE=/usr/share/unsermake/unsermake
202
203 %{__make} -f admin/Makefile.common cvs
204
205 %configure \
206         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
207         --disable-rpath \
208         --with%{!?with_arts:out}-arts \
209         --with%{!?with_mas:out}-mas \
210         --with%{!?with_xine:out}-xine \
211         --with%{!?with_gstreamer:out}-gstreamer \
212         --with%{!?with_akode:out}-akode \
213         --with%{!?with_helix:out}-helix \
214         --with%{!?with_nmm:out}-nmm \
215         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
216         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
217         --disable-final \
218         --with-qt-libraries=%{_libdir} \
219         --with%{!?with_included_sqlite:out}-included-sqlite
220
221 %{__make}
222
223 %install
224 rm -rf $RPM_BUILD_ROOT
225
226 %{__make} install \
227         DESTDIR=$RPM_BUILD_ROOT \
228         kde_htmldir=%{_kdedocdir} \
229         kde_libs_htmldir=%{_kdedocdir}
230
231 # remove bogus dir
232 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
233
234 %find_lang amarok --all-name --with-kde
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %post
240 if [ "$1" = 1 ]; then
241         echo "Remember to install libvisual-plugins-* packages if you"
242         echo "want to have a visualizations in amaroK."
243 fi
244
245 %files -f %{name}.lang
246 %defattr(644,root,root,755)
247 %doc AUTHORS ChangeLog README
248 %attr(755,root,root) %{_bindir}/amarok
249 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
250 %attr(755,root,root) %{_bindir}/amarokapp
251 %attr(755,root,root) %{_bindir}/amarok_libvisual
252 #%attr(755,root,root) %{_bindir}/release_amarok
253 %{_libdir}/kde3/konqsidebar_universalamarok.la
254 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
255 %{_libdir}/kde3/libamarok_void-engine_plugin.la
256 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
257 %dir %{_datadir}/apps/amarok
258 %dir %{_datadir}/apps/amarok/scripts
259 %{_datadir}/apps/amarok/*.rc
260 %{_datadir}/apps/amarok/data
261 %{_datadir}/apps/amarok/icons
262 %{_datadir}/apps/amarok/images
263 %{_datadir}/apps/amarok/themes
264 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
265 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
266 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
267 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
268 %{_datadir}/apps/profiles/amarok.profile.xml
269 %{_datadir}/config/amarokrc
270 %{_datadir}/config.kcfg/amarok.kcfg
271 %{_datadir}/services/amarok_void-engine_plugin.desktop
272 %{_datadir}/servicetypes/amarok_plugin.desktop
273 %{_desktopdir}/kde/amarok.desktop
274 %{_iconsdir}/*/*/apps/amarok.*
275
276 %if %{with arts}
277 %files arts
278 %defattr(644,root,root,755)
279 %{_libdir}/kde3/libamarok_artsengine_plugin.la
280 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
281 %{_libdir}/libamarokarts.la
282 %attr(755,root,root) %{_libdir}/libamarokarts.so
283 %{_libdir}/mcop/Amarok
284 %{_libdir}/mcop/amarokarts.mcopclass
285 %{_libdir}/mcop/amarokarts.mcoptype
286 %{_datadir}/services/amarok_artsengine_plugin.desktop
287 %endif
288
289 %if %{with akode}
290 %files akode
291 %defattr(644,root,root,755)
292 %{_libdir}/kde3/libamarok_aKode-engine.la
293 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
294 %{_datadir}/services/amarok_aKode-engine.desktop
295 %endif
296
297 %if %{with gstreamer}
298 %files gstreamer
299 %defattr(644,root,root,755)
300 %{_libdir}/kde3/libamarok_gstengine_plugin.la
301 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
302 %{_datadir}/config.kcfg/gstconfig.kcfg
303 %{_datadir}/services/amarok_gstengine_plugin.desktop
304 %endif
305
306 %if %{with helix}
307 %files helix
308 %defattr(644,root,root,755)
309 %{_libdir}/kde3/libamarok_helixengine_plugin.la
310 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
311 %{_datadir}/config.kcfg/helixconfig.kcfg
312 %{_datadir}/services/amarok_helixengine_plugin.desktop
313 %endif
314
315 %if %{with xine}
316 %files xine
317 %defattr(644,root,root,755)
318 %{_libdir}/kde3/libamarok_xine-engine.la
319 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
320 %{_datadir}/config.kcfg/xinecfg.kcfg
321 %{_datadir}/services/amarok_xine-engine.desktop
322 #%{_datadir}/services/amarok_xineengine_plugin.desktop
323 %endif
324
325 %if %{with zeroconf}
326 %files zeroconf
327 %defattr(644,root,root,755)
328 %{_datadir}/apps/zeroconf/_shoutcast._tcp
329 %endif
330
331 %files scripts
332 %defattr(644,root,root,755)
333
334 %dir %{_datadir}/apps/amarok/scripts/alarm
335 %{_datadir}/apps/amarok/scripts/alarm/README
336 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
337
338 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
339 %{_datadir}/apps/amarok/scripts/graphequalizer/README
340 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
341
342 %dir %{_datadir}/apps/amarok/scripts/playlist2html
343 %{_datadir}/apps/amarok/scripts/playlist2html/README
344 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
345 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
346 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
347
348 %dir %{_datadir}/apps/amarok/scripts/templates
349 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
350 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
351 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
352
353 %dir %{_datadir}/apps/amarok/scripts/webcontrol
354 %{_datadir}/apps/amarok/scripts/webcontrol/README
355 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
356 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
357 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
358 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
359 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
360 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
361 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
362 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
363 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
364 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
365 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
366 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
367 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
368 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
369 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
370 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
371
372 %dir %{_datadir}/apps/amarok/scripts/common
373 %{_datadir}/apps/amarok/scripts/common/Publisher.py
374 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
375
376 %dir %{_datadir}/apps/amarok/scripts/shouter
377 %{_datadir}/apps/amarok/scripts/shouter/README
378 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
379 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
380 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
381 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
382 %{_datadir}/apps/amarok/scripts/shouter/Services.py
383 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
384 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
385 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
386 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
387 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
388 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
389 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
390 %{_datadir}/apps/amarok/scripts/shouter/debug.py
391 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
392 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
393 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
394 %dir %{_datadir}/apps/amarok/scripts/shouter/test
395 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
396 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
397
398 %if 0
399 %dir %{_datadir}/apps/amarok/scripts/amarok_live
400 %{_datadir}/apps/amarok/scripts/amarok_live/README
401 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
402 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
403 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
404 %endif
This page took 0.06671 seconds and 4 git commands to generate.