]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- pl for -scripts
[packages/amarok.git] / amarok.spec
1 # This file does not like to be adapterized!
2 # - or at least rpm is broken, as it doesn't build without rpm-pythonprov
3 #
4 # TODO:
5 #       * postgresql support alongside mysql
6 #       * NMM audio backend support (fix build - propably some BRs)
7 #       * make descriptions less useless
8 #       * HelixPlayer engine (fix build - propably some BRs)
9 #
10 # Conditional builds:
11 %bcond_without  arts            # disable arts engine
12 %bcond_without  gstreamer       # disable gstreamer
13 %bcond_without  mas             # disable MAS audio backend
14 %bcond_without  xine            # disable xine engine
15 %bcond_without  xmms            # disable xmms wrapping
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_with     helix           # enable HelixPlayer engine
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable mysql support
20 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
21 %bcond_with     altlyrics       # use alternative lyrics provider
22 Summary:        A KDE audio player
23 Summary(pl):    Odtwarzacz audio dla KDE
24 Name:           amarok
25 Version:        1.3
26 Release:        1.4
27 License:        GPL
28 Group:          X11/Applications/Multimedia
29 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
30 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
31 Patch0:         kde-common-gcc4.patch
32 Patch1:         http://websvn.kde.org/trunk/extragear/multimedia/amarok/src/playlistbrowseritem.h?rev=449581&r1=449054&r2=449581&makepatch=1&diff_format=u
33 Patch2:         %{name}-lyricsurl.patch
34 URL:            http://amarok.kde.org/
35 BuildRequires:  SDL-devel
36 BuildRequires:  alsa-lib-devel
37 BuildRequires:  arts-qt-devel
38 BuildRequires:  automake
39 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
40 BuildRequires:  kdebase-devel
41 %{?with_akode:BuildRequires:    kdemultimedia-akode}
42 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
43 BuildRequires:  libltdl-devel
44 BuildRequires:  libmusicbrainz-devel
45 BuildRequires:  libvisual-devel >= 0.2.0
46 BuildRequires:  pcre-devel
47 BuildRequires:  rpmbuild(macros) >= 1.129
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  sqlite3-devel
51 BuildRequires:  taglib-devel >= 1.4
52 #BuildRequires: unsermake >= 040511
53 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
54 %{?with_xmms:BuildRequires:             xmms-devel}
55 %{?with_mysql:BuildRequires:            mysql-devel}
56 #BuildRequires: kdebindings-kjsembed-devel
57 Requires:       %{name}-plugin = %{version}-%{release}
58 Requires:       kdebase-core >= 9:3.1.93
59 Requires:       kdemultimedia-audiocd >= 9:3.1.93
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 A KDE audio player.
64
65 %description -l pl
66 Odtwarzacz audio dla KDE.
67
68 %package arts
69 Summary:        Plugin arts
70 Summary(pl):    Wtyczka arts
71 Group:          X11/Applications/Multimedia
72 Requires:       %{name} = %{version}-%{release}
73 Provides:       %{name}-plugin = %{version}-%{release}
74
75 %description arts
76 Plugin arts.
77
78 %description arts -l pl
79 Wtyczka arts.
80
81 %package akode
82 Summary:        Plugin akode
83 Summary(pl):    Wtyczka akode
84 Group:          X11/Applications/Multimedia
85 Requires:       %{name} = %{version}-%{release}
86 Provides:       %{name}-plugin = %{version}-%{release}
87
88 %description akode
89 Plugin akode.
90
91 %description akode -l pl
92 Wtyczka akode.
93
94 %package gstreamer
95 Summary:        Plugin gstreamer
96 Summary(pl):    Wtyczka gstreamer
97 Group:          X11/Applications/Multimedia
98 # deps, to get it working:
99 # mp3 decoder: gstreamer-mad
100 # ogg decoder: gstreamer-vorbis
101 # audio output driver: gstreamer-audiosink-alsa
102 # from gstreamer-audio-effects to control volume, etc
103 # needed libs:
104 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
105 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
106 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
107 # gstreamer-musicbrainz for being able to edit id3 tags on files.
108 Requires:       gstreamer-audio-effects
109 Requires:       gstreamer-audiosink
110 Requires:       gstreamer-mad
111 Requires:       gstreamer-vorbis
112 Requires:       gstreamer-musicbrainz
113 Requires:       %{name} = %{version}-%{release}
114 Provides:       %{name}-plugin = %{version}-%{release}
115
116 %description gstreamer
117 Plugin gstreamer.
118
119 %description gstreamer -l pl
120 Wtyczka gstreamer.
121
122 %package xine
123 Summary:        Plugin xine
124 Summary(pl):    Wtyczka xine
125 Group:          X11/Applications/Multimedia
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       xine-plugin-audio
128 Provides:       %{name}-plugin = %{version}-%{release}
129
130 %description xine
131 Plugin xine.
132
133 %description xine -l pl
134 Wtyczka xine.
135
136 %package zeroconf
137 Summary:        Zeroconf data
138 Summary(pl):    Dane dla zeroconf
139 Group:          X11/Applications/Multimedia
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       kdenetwork-kdnssd
142 Provides:       %{name}-plugin = %{version}-%{release}
143
144 %description zeroconf
145 Zeroconf data.
146
147 %description zeroconf -l pl
148 Dane dla zeroconf.
149
150 %package scripts
151 Summary:        amaroK scripts
152 Summary(pl):    Skrypty amaroKa
153 Group:          X11/Applications/Multimedia
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       kdebase-kdialog
156 Requires:       python-PyQt
157
158 %description scripts
159 amaroK scripts allow you extend amaroK functionality.
160
161 You can learn more about scripts in amaroK from here:
162 <http://amarok.kde.org/wiki/index.php/Scripts>.
163
164 %description scripts -l pl
165 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
166
167 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
168 <http://amarok.kde.org/wiki/index.php/Scripts>.
169
170 %prep
171 %setup -q
172 %patch0 -p1
173 %patch1 -p3
174 %{?with_altlyrics:%patch2 -p1}
175 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
176         amarok/src/amarok.desktop \
177
178 %build
179 cp -f /usr/share/automake/config.sub admin
180
181 #export UNSERMAKE=/usr/share/unsermake/unsermake
182
183 %{__make} -f admin/Makefile.common cvs
184
185 %configure \
186         --disable-rpath \
187         %{!?with_arts:--without-arts} \
188         %{?with_mas:--with-mas} \
189         %{!?with_xine:--without-xine} \
190         %{!?with_gstreamer:--without-gstreamer} \
191         %{!?with_akode:--without-akode} \
192         %{?with_helix:--with-helix} \
193         %{?with_nmm:--with-nmm} \
194         %{?with_mysql:--with-mysql} \
195         --disable-final \
196         --with-qt-libraries=%{_libdir} \
197         --without-included-sqlite
198
199 %{__make}
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203
204 %{__make} install \
205         DESTDIR=$RPM_BUILD_ROOT \
206         kde_htmldir=%{_kdedocdir} \
207         kde_libs_htmldir=%{_kdedocdir}
208
209 # remove bogus dir
210 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
211
212 %find_lang amarok --all-name --with-kde
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post
218 if [ "$1" = 1 ]; then
219         echo "Remember to install libvisual-plugins-* packages if you"
220         echo "want to have a visualizations in amaroK."
221 fi
222
223 %files -f %{name}.lang
224 %defattr(644,root,root,755)
225 %doc AUTHORS ChangeLog README TODO
226 %attr(755,root,root) %{_bindir}/amarok
227 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
228 %attr(755,root,root) %{_bindir}/amarokapp
229 %attr(755,root,root) %{_bindir}/amarok_libvisual
230 #%attr(755,root,root) %{_bindir}/release_amarok
231 %{_libdir}/kde3/konqsidebar_universalamarok.la
232 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
233 %{_libdir}/kde3/libamarok_void-engine_plugin.la
234 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
235 %dir %{_datadir}/apps/amarok
236 %dir %{_datadir}/apps/amarok/scripts
237 %{_datadir}/apps/amarok/*.rc
238 %{_datadir}/apps/amarok/data
239 %{_datadir}/apps/amarok/icons
240 %{_datadir}/apps/amarok/images
241 %{_datadir}/apps/amarok/themes
242 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
243 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
244 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
245 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
246 %{_datadir}/apps/profiles/amarok.profile.xml
247 %{_datadir}/config/amarokrc
248 %{_datadir}/config.kcfg/amarok.kcfg
249 %{_datadir}/services/amarok_void-engine_plugin.desktop
250 %{_datadir}/servicetypes/amarok_plugin.desktop
251 %{_desktopdir}/kde/amarok.desktop
252 %{_iconsdir}/*/*/apps/amarok.*
253
254 %if %{with arts}
255 %files arts
256 %defattr(644,root,root,755)
257 %{_libdir}/kde3/libamarok_artsengine_plugin.la
258 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
259 %{_libdir}/libamarokarts.la
260 %attr(755,root,root) %{_libdir}/libamarokarts.so
261 %{_libdir}/mcop/Amarok
262 %{_libdir}/mcop/amarokarts.mcopclass
263 %{_libdir}/mcop/amarokarts.mcoptype
264 %{_datadir}/services/amarok_artsengine_plugin.desktop
265 %endif
266
267 %if %{with akode}
268 %files akode
269 %defattr(644,root,root,755)
270 %{_libdir}/kde3/libamarok_aKode-engine.la
271 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
272 %{_datadir}/services/amarok_aKode-engine.desktop
273 %endif
274
275 %if %{with gstreamer}
276 %files gstreamer
277 %defattr(644,root,root,755)
278 %{_libdir}/kde3/libamarok_gstengine_plugin.la
279 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
280 %{_datadir}/config.kcfg/gstconfig.kcfg
281 %{_datadir}/services/amarok_gstengine_plugin.desktop
282 %endif
283
284 %if %{with xine}
285 %files xine
286 %defattr(644,root,root,755)
287 %{_libdir}/kde3/libamarok_xine-engine.la
288 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
289 %{_datadir}/config.kcfg/xinecfg.kcfg
290 %{_datadir}/services/amarok_xine-engine.desktop
291 #%{_datadir}/services/amarok_xineengine_plugin.desktop
292 %endif
293
294 %if %{with zeroconf}
295 %files zeroconf
296 %defattr(644,root,root,755)
297 %{_datadir}/apps/zeroconf/_shoutcast._tcp
298 %endif
299
300 %files scripts
301 %defattr(644,root,root,755)
302
303 %dir %{_datadir}/apps/amarok/scripts/alarm
304 %{_datadir}/apps/amarok/scripts/alarm/README
305 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
306
307 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
308 %{_datadir}/apps/amarok/scripts/graphequalizer/README
309 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
310
311 %dir %{_datadir}/apps/amarok/scripts/playlist2html
312 %{_datadir}/apps/amarok/scripts/playlist2html/README
313 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
314 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
315 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
316
317 %dir %{_datadir}/apps/amarok/scripts/templates
318 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
319 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
320 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
321
322 %dir %{_datadir}/apps/amarok/scripts/webcontrol
323 %{_datadir}/apps/amarok/scripts/webcontrol/README
324 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
325 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
326 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
327 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
328 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
329 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
330 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
331 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
332 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
333 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
334 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
335 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
336 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
337 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
338 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
339 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
340
341 %dir %{_datadir}/apps/amarok/scripts/common
342 %{_datadir}/apps/amarok/scripts/common/Publisher.py
343 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
344
345 %dir %{_datadir}/apps/amarok/scripts/shouter
346 %{_datadir}/apps/amarok/scripts/shouter/README
347 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
348 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
349 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
350 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
351 %{_datadir}/apps/amarok/scripts/shouter/Services.py
352 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
353 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
354 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
355 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
356 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
357 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
358 %{_datadir}/apps/amarok/scripts/shouter/debug.py
359 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
360 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
361 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-128.mp3
362 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-160.mp3
363 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-192.mp3
364 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-224.mp3
365 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-256.mp3
366 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-320.mp3
367 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
368 %dir %{_datadir}/apps/amarok/scripts/shouter/test
369 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
370 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
371
372 %dir %{_datadir}/apps/amarok/scripts/amarok_live
373 %{_datadir}/apps/amarok/scripts/amarok_live/README
374 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
375 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
376 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
This page took 0.061879 seconds and 4 git commands to generate.