]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- commented out amarok_libvisual from %files, but not sure of this...
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 #
8
9 %define         _beta   beta1
10 Summary:        A KDE audio player
11 Summary(pl):    Odtwarzacz audio dla KDE
12 Name:           amarok
13 Version:        1.2.%{_beta}
14 Release:        0.1
15 License:        GPL
16 Group:          X11/Applications/Multimedia
17 Source0:        http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
18 # Source0-md5:  4477bf2c90f3afe4ae343f07978e59a5
19 URL:            http://amarok.kde.org/
20 Buildrequires:  alsa-lib-devel
21 Buildrequires:  arts-qt-devel
22 Buildrequires:  automake
23 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.8.1}
24 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
25 Buildrequires:  libmusicbrainz-devel
26 Buildrequires:  libvisual-devel >= 0.1.6-1
27 BuildRequires:  mysql-devel
28 Buildrequires:  pcre-devel
29 BuildRequires:  rpmbuild(macros) >= 1.129
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  sqlite3-devel
32 BuildRequires:  taglib-devel >= 1.3
33 BuildRequires:  unsermake >= 040511
34 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.0-0.rc5.0}
35 %{?with_xmms:Buildrequires:     xmms-devel}
36 #BuildRequires: kdebindings-kjsembed-devel 
37 Requires:       %{name}-plugin = %{version}-%{release}
38 Requires:       kdebase-core >= 9:3.1.93
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A KDE audio player.
43
44 %description -l pl
45 Odtwarzacz audio dla KDE.
46
47 %package arts
48 Summary:        Plugin arts
49 Summary(pl):    Wtyczka arts
50 Group:          X11/Applications/Multimedia
51 Requires:       %{name} = %{version}-%{release}
52 Provides:       %{name}-plugin = %{version}-%{release}
53
54 %description arts
55 Plugin arts.
56
57 %description arts -l pl
58 Wtyczka arts.
59
60 %package gstreamer
61 Summary:        Plugin gstreamer
62 Summary(pl):    Wtyczka gstreamer
63 Group:          X11/Applications/Multimedia
64 Requires:       %{name} = %{version}-%{release}
65 Provides:       %{name}-plugin = %{version}-%{release}
66
67 %description gstreamer
68 Plugin gstreamer.
69
70 %description gstreamer -l pl
71 Wtyczka gstreamer.
72
73 %package xine
74 Summary:        Plugin xine
75 Summary(pl):    Wtyczka xine
76 Group:          X11/Applications/Multimedia
77 Requires:       %{name} = %{version}-%{release}
78 Provides:       %{name}-plugin = %{version}-%{release}
79
80 %description xine
81 Plugin xine.
82
83 %description xine -l pl
84 Wtyczka xine.
85
86 %prep
87 %setup -q -n %{name}-1.2-%{_beta}
88
89 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
90         amarok/src/amarok.desktop \
91
92 %build
93 cp -f %{_datadir}/automake/config.sub admin
94
95 export UNSERMAKE=%{_datadir}/unsermake/unsermake
96
97 %{__make} -f admin/Makefile.common cvs
98
99 %configure \
100         --disable-rpath \
101         %{!?with_arts:--without-arts} \
102         %{!?with_xine:--without-xine} \
103         %{!?with_gstreamer:--without-gstreamer} \
104         --with-qt-libraries=%{_libdir} \
105         --without-included-sqlite
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         kde_htmldir=%{_kdedocdir} \
115         kde_libs_htmldir=%{_kdedocdir}
116
117 # remove bogus dir
118 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
119
120 %find_lang amarok --all-name --with-kde
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog README TODO
128 %attr(755,root,root) %{_bindir}/amarok
129 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
130 %attr(755,root,root) %{_bindir}/amarokapp
131 #%attr(755,root,root) %{_bindir}/amarok_libvisual
132 %attr(755,root,root) %{_bindir}/release_amarok
133 %{_libdir}/kde3/libamarok_void-engine_plugin.la
134 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
135 %{_datadir}/apps/amarok
136 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
137 %{_datadir}/config.kcfg/amarok.kcfg
138 %{_datadir}/services/amarok_void-engine_plugin.desktop
139 %{_datadir}/servicetypes/amarok_plugin.desktop
140 %{_desktopdir}/kde/amarok.desktop
141 %{_iconsdir}/*/*/apps/amarok.png
142 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
143 %{_datadir}/config/*
144
145 %if %{with arts}
146 %files arts
147 %defattr(644,root,root,755)
148 %{_libdir}/kde3/libamarok_artsengine_plugin.la
149 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
150 %{_libdir}/libamarokarts.la
151 %attr(755,root,root) %{_libdir}/libamarokarts.so
152 %{_libdir}/mcop/Amarok
153 %{_libdir}/mcop/amarokarts.mcopclass
154 %{_libdir}/mcop/amarokarts.mcoptype
155 %{_datadir}/services/amarok_artsengine_plugin.desktop
156 %endif
157
158 %if %{with gstreamer}
159 %files gstreamer
160 %defattr(644,root,root,755)
161 %{_libdir}/kde3/libamarok_gstengine_plugin.la
162 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
163 %{_datadir}/config.kcfg/gstconfig.kcfg
164 %{_datadir}/services/amarok_gstengine_plugin.desktop
165 %endif
166
167 %if %{with xine}
168 %files xine
169 %defattr(644,root,root,755)
170 %{_libdir}/kde3/libamarok_xine-engine.la
171 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
172 %{_datadir}/services/amarok_xine-engine.desktop
173 %{_datadir}/services/amarok_xineengine_plugin.desktop
174 %endif
This page took 0.075488 seconds and 4 git commands to generate.