]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- updated to 1.2-beta1
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 #
8
9 %define         _beta   beta1
10 Summary:        A KDE audio player
11 Summary(pl):    Odtwarzacz audio dla KDE
12 Name:           amarok
13 Version:        1.2.%{_beta}
14 Release:        0.1
15 License:        GPL
16 Group:          X11/Applications/Multimedia
17 Source0:        http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
18 # Source0-md5:  4477bf2c90f3afe4ae343f07978e59a5
19 URL:            http://amarok.kde.org/
20 Buildrequires:  alsa-lib-devel
21 Buildrequires:  arts-qt-devel
22 Buildrequires:  automake
23 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.8.1}
24 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
25 Buildrequires:  libmusicbrainz-devel
26 Buildrequires:  libvisual-devel >= 0.1.6-1
27 Buildrequires:  pcre-devel
28 BuildRequires:  rpmbuild(macros) >= 1.129
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  sqlite3-devel
31 BuildRequires:  taglib-devel >= 1.3
32 BuildRequires:  unsermake >= 040511
33 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.0-0.rc5.0}
34 %{?with_xmms:Buildrequires:     xmms-devel}
35 #BuildRequires: kdebindings-kjsembed-devel 
36 Requires:       %{name}-plugin = %{version}-%{release}
37 Requires:       kdebase-core >= 9:3.1.93
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A KDE audio player.
42
43 %description -l pl
44 Odtwarzacz audio dla KDE.
45
46 %package arts
47 Summary:        Plugin arts
48 Summary(pl):    Wtyczka arts
49 Group:          X11/Applications/Multimedia
50 Requires:       %{name} = %{version}-%{release}
51 Provides:       %{name}-plugin = %{version}-%{release}
52
53 %description arts
54 Plugin arts.
55
56 %description arts -l pl
57 Wtyczka arts.
58
59 %package gstreamer
60 Summary:        Plugin gstreamer
61 Summary(pl):    Wtyczka gstreamer
62 Group:          X11/Applications/Multimedia
63 Requires:       %{name} = %{version}-%{release}
64 Provides:       %{name}-plugin = %{version}-%{release}
65
66 %description gstreamer
67 Plugin gstreamer.
68
69 %description gstreamer -l pl
70 Wtyczka gstreamer.
71
72 %package xine
73 Summary:        Plugin xine
74 Summary(pl):    Wtyczka xine
75 Group:          X11/Applications/Multimedia
76 Requires:       %{name} = %{version}-%{release}
77 Provides:       %{name}-plugin = %{version}-%{release}
78
79 %description xine
80 Plugin xine.
81
82 %description xine -l pl
83 Wtyczka xine.
84
85 %prep
86 %setup -q -n %{name}-1.2-%{_beta}
87
88 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
89         amarok/src/amarok.desktop \
90
91 %build
92 cp -f %{_datadir}/automake/config.sub admin
93
94 export UNSERMAKE=%{_datadir}/unsermake/unsermake
95
96 %{__make} -f admin/Makefile.common cvs
97
98 %configure \
99         --disable-rpath \
100         %{!?with_arts:--without-arts} \
101         %{!?with_xine:--without-xine} \
102         %{!?with_gstreamer:--without-gstreamer} \
103         --with-qt-libraries=%{_libdir} \
104         --without-included-sqlite
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         kde_htmldir=%{_kdedocdir} \
114         kde_libs_htmldir=%{_kdedocdir}
115
116 # remove bogus dir
117 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
118
119 %find_lang amarok --all-name --with-kde
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README TODO
127 %attr(755,root,root) %{_bindir}/amarok
128 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
129 %attr(755,root,root) %{_bindir}/amarokapp
130 %attr(755,root,root) %{_bindir}/amarok_libvisual
131 %attr(755,root,root) %{_bindir}/release_amarok
132 %{_libdir}/kde3/libamarok_void-engine_plugin.la
133 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
134 %{_datadir}/apps/amarok
135 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
136 %{_datadir}/config.kcfg/amarok.kcfg
137 %{_datadir}/services/amarok_void-engine_plugin.desktop
138 %{_datadir}/servicetypes/amarok_plugin.desktop
139 %{_desktopdir}/kde/amarok.desktop
140 %{_iconsdir}/*/*/apps/amarok.png
141 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
142 %{_datadir}/config/*
143
144 %if %{with arts}
145 %files arts
146 %defattr(644,root,root,755)
147 %{_libdir}/kde3/libamarok_artsengine_plugin.la
148 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
149 %{_libdir}/libamarokarts.la
150 %attr(755,root,root) %{_libdir}/libamarokarts.so
151 %{_libdir}/mcop/Amarok
152 %{_libdir}/mcop/amarokarts.mcopclass
153 %{_libdir}/mcop/amarokarts.mcoptype
154 %{_datadir}/services/amarok_artsengine_plugin.desktop
155 %endif
156
157 %if %{with gstreamer}
158 %files gstreamer
159 %defattr(644,root,root,755)
160 %{_libdir}/kde3/libamarok_gstengine_plugin.la
161 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
162 %{_datadir}/config.kcfg/gstconfig.kcfg
163 %{_datadir}/services/amarok_gstengine_plugin.desktop
164 %endif
165
166 %if %{with xine}
167 %files xine
168 %defattr(644,root,root,755)
169 %{_libdir}/kde3/libamarok_xine-engine.la
170 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
171 %{_datadir}/services/amarok_xine-engine.desktop
172 %{_datadir}/services/amarok_xineengine_plugin.desktop
173 %endif
This page took 0.043675 seconds and 4 git commands to generate.