]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- subpackages PreReq main package to prevent dependency loop detected by poldek
[packages/amarok.git] / amarok.spec
1 #
2 # TODO:
3 #       * postgresql support alongside mysql
4 #       * NMM, MAS audio backend support
5 #       * make descriptions less useless
6 #       * HelixPlayer engine?
7 #       * nls files, kde html documents
8 #
9 # Conditional builds:
10 %bcond_without  arts            # disable arts engine
11 %bcond_without  gstreamer       # disable gstreamer
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disbale suport for zeroconf
15 %bcond_with     mysql           # enable mysql support
16 #
17 %define _beta   beta2
18 Summary:        A KDE audio player
19 Summary(pl):    Odtwarzacz audio dla KDE
20 Name:           amarok
21 Version:        1.3
22 Release:        0.%{_beta}.3
23 License:        GPL
24 Group:          X11/Applications/Multimedia
25 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
26 # Source0-md5:  ca7b22074dab6107c61b3b92dadbe26e
27 Patch0:         kde-common-gcc4.patch
28 URL:            http://amarok.kde.org/
29 BuildRequires:  SDL-devel
30 BuildRequires:  alsa-lib-devel
31 BuildRequires:  arts-qt-devel
32 BuildRequires:  automake
33 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
34 BuildRequires:  kdebase-devel
35 BuildRequires:  kdemultimedia-akode
36 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
37 BuildRequires:  libltdl-devel
38 BuildRequires:  libmusicbrainz-devel
39 BuildRequires:  libvisual-devel >= 0.2.0
40 BuildRequires:  pcre-devel
41 BuildRequires:  rpmbuild(macros) >= 1.129
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  sqlite3-devel
45 BuildRequires:  taglib-devel >= 1.3.1
46 #BuildRequires: unsermake >= 040511
47 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
48 %{?with_xmms:BuildRequires:             xmms-devel}
49 %{?with_mysql:BuildRequires:            mysql-devel}
50 #BuildRequires: kdebindings-kjsembed-devel
51 Requires:       %{name}-plugin = %{version}-%{release}
52 Requires:       kdebase-core >= 9:3.1.93
53 Requires:       kdemultimedia-audiocd >= 9:3.1.93
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 A KDE audio player.
58
59 %description -l pl
60 Odtwarzacz audio dla KDE.
61
62 %package arts
63 Summary:        Plugin arts
64 Summary(pl):    Wtyczka arts
65 Group:          X11/Applications/Multimedia
66 PreReq:         %{name} = %{version}-%{release}
67 Provides:       %{name}-plugin = %{version}-%{release}
68
69 %description arts
70 Plugin arts.
71
72 %description arts -l pl
73 Wtyczka arts.
74
75
76 %package akode
77 Summary:        Plugin akode
78 Summary(pl):    Wtyczka akode
79 Group:          X11/Applications/Multimedia
80 PreReq:         %{name} = %{version}-%{release}
81 Provides:       %{name}-plugin = %{version}-%{release}
82
83 %description akode
84 Plugin akode.
85
86 %description akode -l pl
87 Wtyczka akode.
88
89
90 %package gstreamer
91 Summary:        Plugin gstreamer
92 Summary(pl):    Wtyczka gstreamer
93 Group:          X11/Applications/Multimedia
94 PreReq:         %{name} = %{version}-%{release}
95 # needed libs
96 # at least /usr/lib/gstreamer-0.8/libgstresample.so
97 # probably /usr/lib/gstreamer-0.8/libgstadder.so
98 # and probably /usr/lib/gstreamer-0.8/libgstvolume.so
99 Requires:       gstreamer-audio-effects
100 Provides:       %{name}-plugin = %{version}-%{release}
101
102 %description gstreamer
103 Plugin gstreamer.
104
105 %description gstreamer -l pl
106 Wtyczka gstreamer.
107
108 %package xine
109 Summary:        Plugin xine
110 Summary(pl):    Wtyczka xine
111 Group:          X11/Applications/Multimedia
112 PreReq:         %{name} = %{version}-%{release}
113 Provides:       %{name}-plugin = %{version}-%{release}
114
115 %description xine
116 Plugin xine.
117
118 %description xine -l pl
119 Wtyczka xine.
120
121 %package zeroconf
122 Summary:        Zeroconf data
123 Summary(pl):    Dane dla zeroconf
124 Group:          X11/Applications/Multimedia
125 PreReq:         %{name} = %{version}-%{release}
126 Requires:       kdenetwork-kdnssd
127 Provides:       %{name}-plugin = %{version}-%{release}
128
129 %description zeroconf
130 Zeroconf data.
131
132 %description zeroconf -l pl
133 Zeroconf data.
134
135
136 %prep
137 %setup -q -n %{name}-%{version}-%{_beta}
138 %patch0 -p1
139 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
140         amarok/src/amarok.desktop \
141
142 %build
143 cp -f /usr/share/automake/config.sub admin
144
145 #export UNSERMAKE=/usr/share/unsermake/unsermake
146
147 %{__make} -f admin/Makefile.common cvs
148
149 %configure \
150         --disable-rpath \
151         %{!?with_arts:--without-arts} \
152         %{!?with_xine:--without-xine} \
153         %{!?with_gstreamer:--without-gstreamer} \
154         %{?with_mysql:--with-mysql} \
155         --disable-final \
156         --with-qt-libraries=%{_libdir} \
157         --without-included-sqlite
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT \
166         kde_htmldir=%{_kdedocdir} \
167         kde_libs_htmldir=%{_kdedocdir}
168
169 # remove bogus dir
170 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
171
172 #find_lang amarok --all-name --with-kde
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post
178 echo "Remember to install libvisual-plugins-* packages if you"
179 echo "want to have a visualizations in amarok."
180
181 %files
182 %defattr(644,root,root,755)
183 # -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS ChangeLog README TODO
186 %attr(755,root,root) %{_bindir}/amarok
187 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
188 %attr(755,root,root) %{_bindir}/amarokapp
189 %attr(755,root,root) %{_bindir}/amarok_libvisual
190 #%attr(755,root,root) %{_bindir}/release_amarok
191 %{_libdir}/kde3/konqsidebar_universalamarok.la
192 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
193 %{_libdir}/kde3/libamarok_void-engine_plugin.la
194 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
195 %{_datadir}/apps/amarok
196 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
197 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
198 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
199 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
200 %{_datadir}/apps/profiles/amarok.profile.xml
201 %{_datadir}/config/amarokrc
202 %{_datadir}/config.kcfg/amarok.kcfg
203 %{_datadir}/services/amarok_void-engine_plugin.desktop
204 %{_datadir}/servicetypes/amarok_plugin.desktop
205 %{_desktopdir}/kde/amarok.desktop
206 %{_iconsdir}/*/*/apps/amarok.*
207
208 %if %{with arts}
209 %files arts
210 %defattr(644,root,root,755)
211 %{_libdir}/kde3/libamarok_artsengine_plugin.la
212 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
213 %{_libdir}/libamarokarts.la
214 %attr(755,root,root) %{_libdir}/libamarokarts.so
215 %{_libdir}/mcop/Amarok
216 %{_libdir}/mcop/amarokarts.mcopclass
217 %{_libdir}/mcop/amarokarts.mcoptype
218 %{_datadir}/services/amarok_artsengine_plugin.desktop
219 %endif
220
221 %files akode
222 %defattr(644,root,root,755)
223 %{_libdir}/kde3/libamarok_aKode-engine.la
224 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
225 %{_datadir}/services/amarok_aKode-engine.desktop
226
227 %if %{with gstreamer}
228 %files gstreamer
229 %defattr(644,root,root,755)
230 %{_libdir}/kde3/libamarok_gstengine_plugin.la
231 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
232 %{_datadir}/config.kcfg/gstconfig.kcfg
233 %{_datadir}/services/amarok_gstengine_plugin.desktop
234 %endif
235
236 %if %{with xine}
237 %files xine
238 %defattr(644,root,root,755)
239 %{_libdir}/kde3/libamarok_xine-engine.la
240 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
241 %{_datadir}/services/amarok_xine-engine.desktop
242 #%{_datadir}/services/amarok_xineengine_plugin.desktop
243 %endif
244
245 %if %{with zeroconf}
246 %files zeroconf
247 %defattr(644,root,root,755)
248 %{_datadir}/apps/zeroconf/_shoutcast._tcp
249 %endif
This page took 0.041485 seconds and 4 git commands to generate.