]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- updated to 1.2-beta2
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 %bcond_with     mysql           # enable mysql support
8 #
9
10 %define         _beta   beta2
11 Summary:        A KDE audio player
12 Summary(pl):    Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        1.2.%{_beta}
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Applications/Multimedia
18 Source0:        http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
19 # Source0-md5:  8535db7a873f0ee2e697b98135e4b60d
20 URL:            http://amarok.kde.org/
21 Buildrequires:  alsa-lib-devel
22 Buildrequires:  arts-qt-devel
23 Buildrequires:  automake
24 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.8.1}
25 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
26 Buildrequires:  libmusicbrainz-devel
27 Buildrequires:  libvisual-devel >= 0.2.0
28 Buildrequires:  pcre-devel
29 BuildRequires:  rpmbuild(macros) >= 1.129
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  sqlite3-devel
32 BuildRequires:  taglib-devel >= 1.3
33 BuildRequires:  unsermake >= 040511
34 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.0-0.rc5.0}
35 %{?with_xmms:BuildRequires:     xmms-devel}
36 %{?with_mysql:BuildRequires:    mysql-devel}
37 #BuildRequires: kdebindings-kjsembed-devel 
38 Requires:       %{name}-plugin = %{version}-%{release}
39 Requires:       kdebase-core >= 9:3.1.93
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 A KDE audio player.
44
45 %description -l pl
46 Odtwarzacz audio dla KDE.
47
48 %package arts
49 Summary:        Plugin arts
50 Summary(pl):    Wtyczka arts
51 Group:          X11/Applications/Multimedia
52 Requires:       %{name} = %{version}-%{release}
53 Provides:       %{name}-plugin = %{version}-%{release}
54
55 %description arts
56 Plugin arts.
57
58 %description arts -l pl
59 Wtyczka arts.
60
61 %package gstreamer
62 Summary:        Plugin gstreamer
63 Summary(pl):    Wtyczka gstreamer
64 Group:          X11/Applications/Multimedia
65 Requires:       %{name} = %{version}-%{release}
66 Provides:       %{name}-plugin = %{version}-%{release}
67
68 %description gstreamer
69 Plugin gstreamer.
70
71 %description gstreamer -l pl
72 Wtyczka gstreamer.
73
74 %package xine
75 Summary:        Plugin xine
76 Summary(pl):    Wtyczka xine
77 Group:          X11/Applications/Multimedia
78 Requires:       %{name} = %{version}-%{release}
79 Provides:       %{name}-plugin = %{version}-%{release}
80
81 %description xine
82 Plugin xine.
83
84 %description xine -l pl
85 Wtyczka xine.
86
87 %prep
88 %setup -q -n %{name}-1.2-%{_beta}
89
90 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
91         amarok/src/amarok.desktop \
92
93 %build
94 cp -f %{_datadir}/automake/config.sub admin
95
96 export UNSERMAKE=%{_datadir}/unsermake/unsermake
97
98 %{__make} -f admin/Makefile.common cvs
99
100 %configure \
101         --disable-rpath \
102         %{!?with_arts:--without-arts} \
103         %{!?with_xine:--without-xine} \
104         %{!?with_gstreamer:--without-gstreamer} \
105         %{?with_mysql:--with-mysql} \
106         --with-qt-libraries=%{_libdir} \
107         --without-included-sqlite
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         kde_htmldir=%{_kdedocdir} \
117         kde_libs_htmldir=%{_kdedocdir}
118
119 # remove bogus dir
120 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
121
122 %find_lang amarok --all-name --with-kde
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files -f %{name}.lang
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog README TODO
130 %attr(755,root,root) %{_bindir}/amarok
131 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
132 %attr(755,root,root) %{_bindir}/amarokapp
133 %attr(755,root,root) %{_bindir}/amarok_libvisual
134 %attr(755,root,root) %{_bindir}/release_amarok
135 %{_libdir}/kde3/libamarok_void-engine_plugin.la
136 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
137 %{_datadir}/apps/amarok
138 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
139 %{_datadir}/config.kcfg/amarok.kcfg
140 %{_datadir}/services/amarok_void-engine_plugin.desktop
141 %{_datadir}/servicetypes/amarok_plugin.desktop
142 %{_desktopdir}/kde/amarok.desktop
143 %{_iconsdir}/*/*/apps/amarok.png
144 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
145 %{_datadir}/config/*
146
147 %if %{with arts}
148 %files arts
149 %defattr(644,root,root,755)
150 %{_libdir}/kde3/libamarok_artsengine_plugin.la
151 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
152 %{_libdir}/libamarokarts.la
153 %attr(755,root,root) %{_libdir}/libamarokarts.so
154 %{_libdir}/mcop/Amarok
155 %{_libdir}/mcop/amarokarts.mcopclass
156 %{_libdir}/mcop/amarokarts.mcoptype
157 %{_datadir}/services/amarok_artsengine_plugin.desktop
158 %endif
159
160 %if %{with gstreamer}
161 %files gstreamer
162 %defattr(644,root,root,755)
163 %{_libdir}/kde3/libamarok_gstengine_plugin.la
164 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
165 %{_datadir}/config.kcfg/gstconfig.kcfg
166 %{_datadir}/services/amarok_gstengine_plugin.desktop
167 %endif
168
169 %if %{with xine}
170 %files xine
171 %defattr(644,root,root,755)
172 %{_libdir}/kde3/libamarok_xine-engine.la
173 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
174 %{_datadir}/services/amarok_xine-engine.desktop
175 %{_datadir}/services/amarok_xineengine_plugin.desktop
176 %endif
This page took 0.03334 seconds and 4 git commands to generate.