]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- this spec can be adapterized again (pythonprov isn't obsolete)
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * HelixPlayer engine (fix build - propably some BRs)
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_with     helix           # enable HelixPlayer engine
15 %bcond_with     nmm             # enable NMM audio backend
16 %bcond_with     mysql           # enable mysql support
17 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
18 %bcond_with     altlyrics       # use alternative lyrics provider
19 Summary:        A KDE audio player
20 Summary(pl):    Odtwarzacz audio dla KDE
21 Name:           amarok
22 Version:        1.3
23 Release:        1.5
24 License:        GPL
25 Group:          X11/Applications/Multimedia
26 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
27 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
28 Patch0:         kde-common-gcc4.patch
29 Patch1:         http://websvn.kde.org/trunk/extragear/multimedia/amarok/src/playlistbrowseritem.h?rev=449581&r1=449054&r2=449581&makepatch=1&diff_format=u
30 Patch2:         %{name}-lyricsurl.patch
31 URL:            http://amarok.kde.org/
32 BuildRequires:  SDL-devel
33 BuildRequires:  alsa-lib-devel
34 BuildRequires:  arts-qt-devel
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
38 BuildRequires:  kdebase-devel
39 %{?with_akode:BuildRequires:    kdemultimedia-akode}
40 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
41 BuildRequires:  libltdl-devel
42 BuildRequires:  libmusicbrainz-devel
43 BuildRequires:  libvisual-devel >= 0.2.0
44 BuildRequires:  pcre-devel
45 BuildRequires:  rpmbuild(macros) >= 1.129
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  sqlite3-devel
49 BuildRequires:  taglib-devel >= 1.4
50 #BuildRequires: unsermake >= 040511
51 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
52 %{?with_xmms:BuildRequires:             xmms-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 #BuildRequires: kdebindings-kjsembed-devel
55 Requires:       %{name}-plugin = %{version}-%{release}
56 Requires:       kdebase-core >= 9:3.1.93
57 Requires:       kdemultimedia-audiocd >= 9:3.1.93
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 A KDE audio player.
62
63 %description -l pl
64 Odtwarzacz audio dla KDE.
65
66 %package arts
67 Summary:        Plugin arts
68 Summary(pl):    Wtyczka arts
69 Group:          X11/Applications/Multimedia
70 Requires:       %{name} = %{version}-%{release}
71 Provides:       %{name}-plugin = %{version}-%{release}
72
73 %description arts
74 Plugin arts.
75
76 %description arts -l pl
77 Wtyczka arts.
78
79 %package akode
80 Summary:        Plugin akode
81 Summary(pl):    Wtyczka akode
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       %{name}-plugin = %{version}-%{release}
85
86 %description akode
87 Plugin akode.
88
89 %description akode -l pl
90 Wtyczka akode.
91
92 %package gstreamer
93 Summary:        Plugin gstreamer
94 Summary(pl):    Wtyczka gstreamer
95 Group:          X11/Applications/Multimedia
96 # deps, to get it working:
97 # mp3 decoder: gstreamer-mad
98 # ogg decoder: gstreamer-vorbis
99 # audio output driver: gstreamer-audiosink-alsa
100 # from gstreamer-audio-effects to control volume, etc
101 # needed libs:
102 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
103 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
104 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
105 # gstreamer-musicbrainz for being able to edit id3 tags on files.
106 Requires:       gstreamer-audio-effects
107 Requires:       gstreamer-audiosink
108 Requires:       gstreamer-mad
109 Requires:       gstreamer-vorbis
110 Requires:       gstreamer-musicbrainz
111 Requires:       %{name} = %{version}-%{release}
112 Provides:       %{name}-plugin = %{version}-%{release}
113
114 %description gstreamer
115 Plugin gstreamer.
116
117 %description gstreamer -l pl
118 Wtyczka gstreamer.
119
120 %package xine
121 Summary:        Plugin xine
122 Summary(pl):    Wtyczka xine
123 Group:          X11/Applications/Multimedia
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       xine-plugin-audio
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description xine
129 Plugin xine.
130
131 %description xine -l pl
132 Wtyczka xine.
133
134 %package zeroconf
135 Summary:        Zeroconf data
136 Summary(pl):    Dane dla zeroconf
137 Group:          X11/Applications/Multimedia
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       kdenetwork-kdnssd
140 Provides:       %{name}-plugin = %{version}-%{release}
141
142 %description zeroconf
143 Zeroconf data.
144
145 %description zeroconf -l pl
146 Dane dla zeroconf.
147
148 %package scripts
149 Summary:        amaroK scripts
150 Summary(pl):    Skrypty amaroKa
151 Group:          X11/Applications/Multimedia
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       kdebase-kdialog
154 Requires:       python-PyQt
155
156 %description scripts
157 amaroK scripts allow you extend amaroK functionality.
158
159 You can learn more about scripts in amaroK from here:
160 <http://amarok.kde.org/wiki/index.php/Scripts>.
161
162 %description scripts -l pl
163 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
164
165 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
166 <http://amarok.kde.org/wiki/index.php/Scripts>.
167
168 %prep
169 %setup -q
170 %patch0 -p1
171 %patch1 -p3
172 %{?with_altlyrics:%patch2 -p1}
173 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
174         amarok/src/amarok.desktop \
175
176 # see kde bug #110909
177 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
178
179 %build
180 %{__aclocal}
181 %{__autoconf}
182 %{__autoheader}
183 %{__automake}
184
185 cp -f /usr/share/automake/config.sub admin
186
187 #export UNSERMAKE=/usr/share/unsermake/unsermake
188
189 %{__make} -f admin/Makefile.common cvs
190
191 %configure \
192         --disable-rpath \
193         %{!?with_arts:--without-arts} \
194         %{?with_mas:--with-mas} \
195         %{!?with_xine:--without-xine} \
196         %{!?with_gstreamer:--without-gstreamer} \
197         %{!?with_akode:--without-akode} \
198         %{?with_helix:--with-helix} \
199         %{?with_nmm:--with-nmm} \
200         %{?with_mysql:--with-mysql} \
201         --disable-final \
202         --with-qt-libraries=%{_libdir} \
203         --without-included-sqlite
204
205 %{__make}
206
207 %install
208 rm -rf $RPM_BUILD_ROOT
209
210 %{__make} install \
211         DESTDIR=$RPM_BUILD_ROOT \
212         kde_htmldir=%{_kdedocdir} \
213         kde_libs_htmldir=%{_kdedocdir}
214
215 # remove bogus dir
216 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
217
218 %find_lang amarok --all-name --with-kde
219
220 %clean
221 rm -rf $RPM_BUILD_ROOT
222
223 %post
224 if [ "$1" = 1 ]; then
225         echo "Remember to install libvisual-plugins-* packages if you"
226         echo "want to have a visualizations in amaroK."
227 fi
228
229 %files -f %{name}.lang
230 %defattr(644,root,root,755)
231 %doc AUTHORS ChangeLog README TODO
232 %attr(755,root,root) %{_bindir}/amarok
233 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
234 %attr(755,root,root) %{_bindir}/amarokapp
235 %attr(755,root,root) %{_bindir}/amarok_libvisual
236 #%attr(755,root,root) %{_bindir}/release_amarok
237 %{_libdir}/kde3/konqsidebar_universalamarok.la
238 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
239 %{_libdir}/kde3/libamarok_void-engine_plugin.la
240 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
241 %dir %{_datadir}/apps/amarok
242 %dir %{_datadir}/apps/amarok/scripts
243 %{_datadir}/apps/amarok/*.rc
244 %{_datadir}/apps/amarok/data
245 %{_datadir}/apps/amarok/icons
246 %{_datadir}/apps/amarok/images
247 %{_datadir}/apps/amarok/themes
248 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
249 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
250 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
251 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
252 %{_datadir}/apps/profiles/amarok.profile.xml
253 %{_datadir}/config/amarokrc
254 %{_datadir}/config.kcfg/amarok.kcfg
255 %{_datadir}/services/amarok_void-engine_plugin.desktop
256 %{_datadir}/servicetypes/amarok_plugin.desktop
257 %{_desktopdir}/kde/amarok.desktop
258 %{_iconsdir}/*/*/apps/amarok.*
259
260 %if %{with arts}
261 %files arts
262 %defattr(644,root,root,755)
263 %{_libdir}/kde3/libamarok_artsengine_plugin.la
264 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
265 %{_libdir}/libamarokarts.la
266 %attr(755,root,root) %{_libdir}/libamarokarts.so
267 %{_libdir}/mcop/Amarok
268 %{_libdir}/mcop/amarokarts.mcopclass
269 %{_libdir}/mcop/amarokarts.mcoptype
270 %{_datadir}/services/amarok_artsengine_plugin.desktop
271 %endif
272
273 %if %{with akode}
274 %files akode
275 %defattr(644,root,root,755)
276 %{_libdir}/kde3/libamarok_aKode-engine.la
277 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
278 %{_datadir}/services/amarok_aKode-engine.desktop
279 %endif
280
281 %if %{with gstreamer}
282 %files gstreamer
283 %defattr(644,root,root,755)
284 %{_libdir}/kde3/libamarok_gstengine_plugin.la
285 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
286 %{_datadir}/config.kcfg/gstconfig.kcfg
287 %{_datadir}/services/amarok_gstengine_plugin.desktop
288 %endif
289
290 %if %{with xine}
291 %files xine
292 %defattr(644,root,root,755)
293 %{_libdir}/kde3/libamarok_xine-engine.la
294 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
295 %{_datadir}/config.kcfg/xinecfg.kcfg
296 %{_datadir}/services/amarok_xine-engine.desktop
297 #%{_datadir}/services/amarok_xineengine_plugin.desktop
298 %endif
299
300 %if %{with zeroconf}
301 %files zeroconf
302 %defattr(644,root,root,755)
303 %{_datadir}/apps/zeroconf/_shoutcast._tcp
304 %endif
305
306 %files scripts
307 %defattr(644,root,root,755)
308
309 %dir %{_datadir}/apps/amarok/scripts/alarm
310 %{_datadir}/apps/amarok/scripts/alarm/README
311 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
312
313 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
314 %{_datadir}/apps/amarok/scripts/graphequalizer/README
315 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
316
317 %dir %{_datadir}/apps/amarok/scripts/playlist2html
318 %{_datadir}/apps/amarok/scripts/playlist2html/README
319 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
320 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
321 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
322
323 %dir %{_datadir}/apps/amarok/scripts/templates
324 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
325 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
326 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
327
328 %dir %{_datadir}/apps/amarok/scripts/webcontrol
329 %{_datadir}/apps/amarok/scripts/webcontrol/README
330 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
331 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
332 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
333 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
334 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
335 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
336 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
337 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
338 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
339 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
340 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
341 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
342 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
343 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
344 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
345 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
346
347 %dir %{_datadir}/apps/amarok/scripts/common
348 %{_datadir}/apps/amarok/scripts/common/Publisher.py
349 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
350
351 %dir %{_datadir}/apps/amarok/scripts/shouter
352 %{_datadir}/apps/amarok/scripts/shouter/README
353 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
354 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
355 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
356 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
357 %{_datadir}/apps/amarok/scripts/shouter/Services.py
358 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
359 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
360 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
361 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
362 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
363 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
364 %{_datadir}/apps/amarok/scripts/shouter/debug.py
365 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
366 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
367 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-128.mp3
368 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-160.mp3
369 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-192.mp3
370 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-224.mp3
371 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-256.mp3
372 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-320.mp3
373 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
374 %dir %{_datadir}/apps/amarok/scripts/shouter/test
375 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
376 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
377
378 %if 0
379 %dir %{_datadir}/apps/amarok/scripts/amarok_live
380 %{_datadir}/apps/amarok/scripts/amarok_live/README
381 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
382 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
383 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
384 %endif
This page took 0.088099 seconds and 4 git commands to generate.